Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

* .pdf

more options

I don't want the pdf to save to disk without my will when I open a pdf file from any website. Fire Fox saves the file first, then opens it for reading. How to change it? I want to read the pdf first and then decide what to do with it. This works similarly in Edge. FF is my main browser, I wouldn't want to change that, but I have too much garbage on my disk. every pdf is saved first, completely unnecessary.

I don't want the pdf to save to disk without my will when I open a pdf file from any website. Fire Fox saves the file first, then opens it for reading. How to change it? I want to read the pdf first and then decide what to do with it. This works similarly in Edge. FF is my main browser, I wouldn't want to change that, but I have too much garbage on my disk. every pdf is saved first, completely unnecessary.

Все ответы (17)

more options

In FF Settings/ Applications/ Portable Document Format .... Per another Forum suggestion I just changed mine from PDF-Xchange to Always Ask. A new Utility Bill PDF opened with PDF-X and a box for What to do with it -- BUT still Dnloaded to the Downloads Folder. Not sure how to Stop them now.

Изменено CraigS26

Полезно?

more options

As near as I can tell there now is no way to prevent FF from first downloading the PDF- this is supposed to be an "improvement" feature of the latest update but my job depends heavily on PDF files and at the end of the workday I usually have have upwards of 50 files I now have to delete from the desktop. This is in no way an improvement. I used FF specifically to avoid this. If I didn't mind the extra hassle I just would have stuck with using Chrome which also uses this beyond annoying process. PLEASE give us the option to revert back to the old way of viewing them locally without downloading!

Полезно?

more options

Every time the PDF is saved to my Desktop!! I have tried all the settings for PDF, including always ask. First issue: it doesn't always ask Second issue: it saves to my desktop regardless of my response, including OPEN in Adobe.....

So then I have to delete the file I didn't want saved on my desktop. Started last update on FF. My default browser but if I can't fix this may not be in future.

Полезно?

more options

It's true that Firefox always needs to save a file *somewhere* to work with it or pass it to another application. However, you do have some control over where.

Starting in Firefox 98, "Open with [relevant application]" or "Use [relevant application]" save in the folder listed on the Settings page next to "Save files to:" Before Firefox 98, Firefox saved the files in the system Temp folder (out of sight, out of mind).

More Options Expected in a Future Update. Many users have expressed the view that they preferred Firefox using the Windows Temp folder (or Linux /tmp directory) for "Open with [relevant application]" and "Use [relevant application]". Last week, the developers were tasked with adding an option to use a sub-folder of the Windows Temp folder (or Linux /tmp directory) for those downloads. I don't know whether to expect this with the scheduled June 28th release of Firefox 102 or in some later version.

Between now and then...

Cleaning Up. Rather than read through the Downloads folder (or Desktop), it may be faster to use the "Delete" item on the right-click context menu for items on the Downloads list. That deletes the file from disk and leaves a notation on the history that the file is missing/removed. You can use that to remove files you do not want to keep. But yes, it's an extra step.

Workaround? What I'm doing for now is this set of settings:

(1) Change the default download folder to a "temp" folder I created (2) Set Firefox to always ask where I want to save a file so I can choose a real folder when I want to keep the file

On the Settings page, it looks like this:

Полезно?

more options

jscher2000 Thx a lot I know that, I have such a catalog, but it is still full of garbage. Maybe this would be a good direction to open pdf in browser memory? Best regards Andrew

Полезно?

more options

Diabolo13 said

Maybe this would be a good direction to open pdf in browser memory?

Hi Andrew, I use "Open in Firefox" for PDFs on the settings page. See: View PDF files in Firefox or choose another viewer.

With that setting, PDFs open into the viewer without showing the download dialog, and they are saved in the web content cache along with web pages and other resources used in web pages.

Previously, the viewer's download button popped up the dialog so it was easy to open a file from there into Acrobat using the Temp folder. Now that button behaves like "Save PDF As..." instead, so that's an extra step.

There is a bug in Firefox 98-100 that causes PDFs coded as downloads to replace the current page. In Firefox 101, those should open in a new tab instead.

Полезно?

more options

I tried opening in Firefox, STILL saved to Desktop!

Полезно?

more options

canuhelp said

I tried opening in Firefox, STILL saved to Desktop!

Maybe I wasn't clear: you need to select "Open in Firefox" here, not in the Download dialog that appears if you select "Always ask" here:

Reference: View PDF files in Firefox or choose another viewer

Полезно?

more options

Thanks I didn't understand. I just created a folder on desktop and directed files to that folder in the area you show. Will clear out at end of day and hope that your Technicians get FF back to working like it used to on PDF files. Thank you. Haven't tried it yet..too busy but your reply has been helpful

Изменено James

Полезно?

more options

The fix (similar to Google Chrome) shouldn't be difficult. If it works there, it should work in FF. The claim that you can delete yourself from a directory is ridiculous. Duplicate rubbish should be avoided. I hope this will change over time. Andrew

Полезно?

more options

Diabolo13 said

The fix (similar to Google Chrome) shouldn't be difficult.

Hi Andrew, this is what I found when I tried Chrome. Is this what you get?

(1) Normal link: https://www.jeffersonscher.com/res/bugzilla-home.pdf

Opens in the viewer in a tab instead of downloading. Clicking the Download button asks me where to save the file. Then a button appears at a Downloads bar at the bottom of the browser.

(2) Forced download link: https://www.jeffersonscher.com/res/servepdf.php?f=bugzilla-home.pdf

Exactly the same.

It seems very similar to how Firefox behaves with the default PDF action of "Open in Firefox" except that instead of showing a Download bar, Firefox opens the Downloads list from the main toolbar.

Полезно?

more options

I have FF 100.0.2 set to " Always ask where to save files ", and to open pdf files in Adobe Reader.

But, FF never asks me where to save the pdf and automatically saves it in the folder listed in the "Save files to" box, even though it's not the selected option. Don't know how that folder ever got selected in first place. It isn't the Download folder on this PC.

How do I get FF to ask where to save every single time? If I'm forced to save them, even if I do not want to save them, I want to select the folder because the destination depends on what the pdf is about and on which drive that folder resides. Putting them all in a Download folder, means more work because I either have to move them to a suitable folder or to delete them.

And I really do hope the default Save folder can be somewhere that's automatically deleted when "Delete cookies and site data when Firefox is closed" is selected. If I really want to save the pdf, I can save it in Reader, but that should be my decision.

Изменено rohe1318

Полезно?

more options

rohe1318 said

I have FF 100.0.2 set to " Always ask where to save files ", and to open pdf files in Adobe Reader.

As you know, when you set the action for PDFs to "Use [relevant application]" on the Settings page, Firefox 97 and earlier automatically saved the file in the system Temp folder, and Firefox 98 and later automatically save the file in the "Save files to:" folder. This change was made because people sometimes lost a necessary file when it was flushed from the Temp folder.

Starting in Firefox 102, there will be a new preference in about:config (expected to be named browser.downloads.start_downloads_in_tmp_dir) allowing Windows and Linux users to go back to using the Temp folder instead of the Save files to: folder. Firefox 102.0 is scheduled to release on June 28th.

But, FF never asks me where to save the pdf and automatically saves it in the folder listed in the "Save files to" box, even though it's not the selected option. Don't know how that folder ever got selected in first place. It isn't the Download folder on this PC. How do I get FF to ask where to save every single time? If I'm forced to save them, even if I do not want to save them, I want to select the folder because the destination depends on what the pdf is about and on which drive that folder resides. Putting them all in a Download folder, means more work because I either have to move them to a suitable folder or to delete them.

When the action is to "Use [relevant application]" Firefox doesn't ask where you want to save. You would need to switch the action to "Save file" to select a save location, and then open the file by clicking it on the Downloads list.

You can edit the "Save files to:" location. Select that option temporarily to enable the Browse button to choose a different folder. I actually created my own Temp folder under Downloads to collect things that I might later nuke. On the Settings page, it looks like this:

Then when I want to save something, I choose a more useful location.

And I really do hope the default Save folder can be somewhere that's automatically deleted when "Delete cookies and site data when Firefox is closed" is selected. If I really want to save the pdf, I can save it in Reader, but that should be my decision.

I think if you set Firefox 102 to use the system Temp folder, it will delete the file after you close it, but I haven't tested it yet. Clearing downloads is not related to deleting cookies (short strings of text sent to the server with every request) or site data (data sites ask Firefox to store for offline use). Those need to be kept separate.

Полезно?

more options

@jscher2000 -Thanks for the response. I understand all that, but that's extra work that really shouldn't be necessary.

I just want FF to launch Adobe Reader without having to choose where the file gets saved every single time and then remembering to manually delete the file(s) later. As I said, if I do want to keep the pdf, after it opens in Reader I just use Save page as... and choose the destination, which may be on an internal HDD or on one of several different external USB drives, that aren't connected to this PC all the time, and rarely/never connected at the same time. Using Reader to save the file also allows me to change the title (eg, add the date) at same time, which FF doesn't currently allow.

Majority of time, I don't keep the .pdf and just want it to disappear. So if FF must save the file, it should be saved directly in a temp folder that automatically gets deleted or emptied when I exit FF, the same way FF can be set to delete cookies and site data on exit, even if these "delete" activities have to be done separately/differently.

To add to this, we should be able to choose exactly where that temp folder is located. Frequent writes/deletes can eat into the lifespan of an SSD (boot drive) so it's better to save these files in a temp folder on an internal HDD, assuming one is installed. I have my FF profile stored on an internal HDD, so -hopefully- the temp file would go there too.

I'll look forward to seeing how the improvements are implemented in FF 102.0.

Полезно?

more options

I agree with all the above. I want to decide if I want the file downloaded using the Save As option. Tried to open a bill today and got this message:

    C:\Users\mailf\Downloads\fGJ5r9rV.pdf.part could not be saved, because you cannot change the contents
    of that folder.
    Change the folder properties and try again, or try saving in a different location.

Not a happy camper.

Creating the TEMP folder under Downloads did the trick.

Изменено mailforrobin

Полезно?

more options

canuhelp said

Thanks I didn't understand. I just created a folder on desktop and directed files to that folder in the area you show. Will clear out at end of day and hope that your Technicians get FF back to working like it used to on PDF files. Thank you. Haven't tried it yet..too busy but your reply has been helpful

Are your techs working on reverting how Firefox handles pdf downloads like it used to (in temp so deleted when I close?) Hope so but how will I know that this bug has been fixed and it will be like it used to be. I'm getting tired of deleting PDFs in the folder I created as a workaround.

Полезно?

more options

canuhelp said

Are your techs working on reverting how Firefox handles pdf downloads like it used to (in temp so deleted when I close?) Hope so but how will I know that this bug has been fixed and it will be like it used to be.

Firefox 102, scheduled to release next Tuesday, will have an option to revert downloads to starting in the Windows Temp or Linux /tmp folder. For content types set to "Use [relevant application]" or types set to "Always ask" where you choose "Open with [relevant application]" in the download dialog, the files should be opened from that folder. I haven't tested whether the files are deleted after you close them.

For future reference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.download.start_downloads_in_tmp_dir and pause while the list is filtered

This preference will appear in Firefox 102

(3) Double-click the preference to switch the value from false (use the "Save files to:" folder) to true (use the Windows Temp or Linux /tmp folder)

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.