Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox closes my open tabs when I exit

  • 3 ответа
  • 1 имеет эту проблему
  • 1076 просмотров
  • Последний ответ от FredMcD

more options

I have the Startup checked, to Open previous windows and tabs, but when I close Firefox, all tabs are closed. I have "Remember history" selected under History. Under "Cookies and Site Data" the box that says, "Delete cookies and site data when Firefox is closed" is unchecked. See uploaded images.

I have the Startup checked, to Open previous windows and tabs, but when I close Firefox, all tabs are closed. I have "Remember history" selected under History. Under "Cookies and Site Data" the box that says, "Delete cookies and site data when Firefox is closed" is unchecked. See uploaded images.
Приложенные скриншоты

Выбранное решение

Hello. Thank you for the reply. I had most of those settings that way. I changed the ones that were not, but it did not work. Before your reply, I was continuing to troubleshoot. I found that the 32-bit and 64-bit versions were installed on my computer. The 32-bit version was the one I opened every day. I opened the 64-bit and tested the tabs and they stayed open. I pinned the 64-bit version so I would only use that one.

Прочитайте этот ответ в контексте 👍 0

Все ответы (3)

more options

You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address box. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

more options

Выбранное решение

Hello. Thank you for the reply. I had most of those settings that way. I changed the ones that were not, but it did not work. Before your reply, I was continuing to troubleshoot. I found that the 32-bit and 64-bit versions were installed on my computer. The 32-bit version was the one I opened every day. I opened the 64-bit and tested the tabs and they stayed open. I pinned the 64-bit version so I would only use that one.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.