Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Gmail won't switch accounts

  • 38 ответов
  • 6 имеют эту проблему
  • 948 просмотров
  • Последний ответ от Infinity__

more options

I've used gmail (with multiple email accounts) on Firefox for many, many years. I switch back and forth between my email accounts daily.

In the past few weeks, though, when I try to switch from my primary account to the others, it just defaults back to the primary. I've purged the cache, I've signed out and signed in. This does not happen on Chrome, just Firefox, which is why I've brought it here.

If I change the URL of the mailbox

https://mail.google.com/mail/u/0/#inbox

to

https://mail.google.com/mail/u/1/#inbox

It will take me to another mailbox. I can then change that number to get to the others. But it shouldn't be that way. So ... what is going on? How do I fix it?

I've used gmail (with multiple email accounts) on Firefox for many, many years. I switch back and forth between my email accounts daily. In the past few weeks, though, when I try to switch from my primary account to the others, it just defaults back to the primary. I've purged the cache, I've signed out and signed in. This does not happen on Chrome, just Firefox, which is why I've brought it here. If I change the URL of the mailbox https://mail.google.com/mail/u/0/#inbox to https://mail.google.com/mail/u/1/#inbox It will take me to another mailbox. I can then change that number to get to the others. But it shouldn't be that way. So ... what is going on? How do I fix it?

Выбранное решение

Thanks, stripping out FB Purity seems to have helped me here; things are working normally at the moment. Thanks for helping out!

Прочитайте этот ответ в контексте 👍 0

Все ответы (18)

more options

Same problem here - no FB purity. It was working perfectly fine for years, with the very same set of Gmail accounts and same set of active extensions. Yet, for last few weeks it's going nuts. It still does work sometimes but usually I need to try to switch multiple time until it "kicks in".

There's no such problem with Chrome. Something must have changed in last FF updates...

more options

This may be the browser blocking the redirection which allows you to go to another inbox, as when I look at the source code, the link given is correct. This may also be caused by some cookies just messing up. Only current workaround is to change the link manually.

more options

That's been my experience, but man is it a dumb thing to have to do!

more options

I've reported this bug in Bugzilla (https://webcompat.com/issues/102408) (GitHub link: https://github.com/webcompat/web-bugs/issues/102408) and it is currently pending moderation.

more options

I've reported this on Bugzilla (https://webcompat.com/issues/102408) and am currently awaiting a response for moderation. The most I can do at this point.

more options

I now have the exact same problem too.

Details: Most recent firefox version. The problem does not repeat in chrome. I do not have FB purity extension.

Some things I've learned: When switching the account in google you click on the selected account in the account menu. But by just hovering on it, we can see the actual link at the bottom in the status bar. When I hover on the secondary account in chrome I am referred to this link: https://mail.google.com/mail/data/u/1/ But when I hover on the secondary account in firefox I can see that I am referred to this link: https://mail.google.com

Which obviously cannot work... Hope this detail helps in resolving the issue somehow...

I have tried to remove all my history (cache, cookies, everything...) Logged in again to gmail in both accounts and it solved the issue! Unfortunately, then I tried to log-in to google keep, another web-app by google, and I can see the secondary account in the account menu there as well, but the problem still stays there. So far, after clearing the history, I can switch accounts in gmail, google-search and in youtube, but the problem stayed for keep and calendar...

Hope a solution will be found soon.

Изменено James

more options

edited: sorry. yet nothing new to add on my previous post

Изменено haibrenner

more options

The bug is currently on Bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=1764428

more options

Thanks for putting it on Bugzilla and upgrading it. I'm sorry others are having the issue, but I'm glad it's not just me any more. The more noise we make the more likely is someone will fix it.

more options

They're currently investigating the issue. It appears that this may be a Gmail issue given that this also works in older builds.

more options

I would also like to say thank you for the bugzilla posting and holy hell I know I don't pay google money for access to my email accounts but it definitly costs me money ya feel me?

Just glad they finally worked out the change your password four times a month but now I have to verify on my Note 10+ and on my Lenovo Tab to even sign in anywhere else. I've tossed out all the other verification bs cause its just so damn, uh now I'm blanking uh kinda redundant (I know thats not the word I'm looking for, its a nice word for giant pain in the ass).

The private window thing is barely even usable in my case.

But thanks everyone for the effort.

more options

Same thing happening here. Tried all the fixes. Doesn't happen on Chrome. Not got any extensions. On version 99. It's only a recent thing.

more options

This just started happening for me too. Thank you for the tip for manually changing the URL, I couldn't get in to my other email otherwise.

more options

Same thing is happening to me, but in my case, if insist it will eventually open the correct account

I was getting really frustrated! Thankfully i found this thread and saw this is happening to more people. This means there's a higher chance of this issue eventually get a fix!

more options

Bugzilla has determined that this is a Google (Gmail) issue, as they are able to reproduce the bug on Safari (Webkit) and Firefox (Moz) but are unable to reporoduce on Edge, Chrome and Brave (Chromium). Most likely due to the service being tested on chronium but not other browsers. You'll have to go to Google/Gmail to get this fixed.

Изменено Infinity__

more options

Google appears to have fixed the issue. Thank you all for your report!

more options

It's still going on for me. Exact same thing as previously reported here. I don't have extensions.

more options

Fab Fox said

It's still going on for me. Exact same thing as previously reported here. I don't have extensions.

As far as the Mozilla Firefox team is concerned, it's not a Firefox problem. Bugzilla was able to reprosuce the bug on all the most common non-chromium browsers. You'll have to contact either the GMail or Google team to try get this fixed.

  1. 1
  2. 2