Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Download toolbar button opens at random

  • 4 ответа
  • 3 имеют эту проблему
  • 314 просмотров
  • Последний ответ от Darxide

more options

Starting yesterday, the button next to the address bar for download progress will randomly open as if I clicked on it. Happens whether or not something is downloading and whether or not there's anything in the download history or not. I haven't changed anything with Firefox. No new addons or settings changes. I didn't change anything on my system, either. Same day as any other. Just started happening.

Starting yesterday, the button next to the address bar for download progress will randomly open as if I clicked on it. Happens whether or not something is downloading and whether or not there's anything in the download history or not. I haven't changed anything with Firefox. No new addons or settings changes. I didn't change anything on my system, either. Same day as any other. Just started happening.

Выбранное решение

That change will be temporary (sorry, don't have the link for that). Set the following preference to false. browser.download.alwaysOpenPanel

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Прочитайте этот ответ в контексте 👍 3

Все ответы (4)

more options

Should mention that it happens whether or not I'm interacting with Firefox, too. I can be completely idle, doing something on my phone and I'll see it pop up or it can happen while I'm typing in this box right now. There's no rhyme or reason for it.

Полезно?

more options

Set this setting to false in about:config

browser.download.improvements_to_download_panel

It seemed to fix the problem for me and for many others.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Изменено Chris Ilias

Полезно?

more options

Выбранное решение

That change will be temporary (sorry, don't have the link for that). Set the following preference to false. browser.download.alwaysOpenPanel

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Изменено Chris Ilias

Полезно?

more options

I have been using the first solution all day and it's worked fine. But after doing some searching on both of those options it seems like the second one is really the cause of the problems that I was having and I am far from the only one. My search terms were just not hitting on the right posts.

Opening at random like this must be a bug, though.

Thanks both of you.

Изменено Darxide

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.