Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Can't use themes

  • 6 ответов
  • 1 имеет эту проблему
  • 216 просмотров
  • Последний ответ от spatiallychaotic

more options

I have Dark Theme set to default but it doesn't work. When I enable it, it'll stop working when I close the option tab or move to a different settings menu. When I was looking for the cause, I found the handlers.json files in my Firefox Profiles folder were corrupt. In an older thread I found, it said that if the files are corrupt they need to be "regenerated" but doesn't say how to do so. Please help! How do I fix this so I can turn the Dark Theme back on?

I have Dark Theme set to default but it doesn't work. When I enable it, it'll stop working when I close the option tab or move to a different settings menu. When I was looking for the cause, I found the handlers.json files in my Firefox Profiles folder were corrupt. In an older thread I found, it said that if the files are corrupt they need to be "regenerated" but doesn't say ''how'' to do so. Please help! How do I fix this so I can turn the Dark Theme back on?
Приложенные скриншоты

Выбранное решение

UPDATE 2/17/2021 I found the cause of my problem. I had an add-on called "Colorful Tabs" installed. When I disabled the add-on, dark mode stayed on.

Thank you everyone for the help, I really appreciate it.

Прочитайте этот ответ в контексте 👍 0

Все ответы (6)

more options

Hmm, a .corrupt file extension is troubling, but the handlers.json file stores data on downloads, like what program you prefer to open PDFs, it doesn't relate to themes. Normally if Firefox is adding .corrupt to a file name, it already created a new handlers.json and you don't need to do anything (except wonder why that is happening).

Back to the theme problem.

Does it make any difference if you change themes on the Add-ons page? You can open that using Ctrl+Shift+A, or from the main menu. In the left column, click Themes. Then find the one you want and click its Enable button.

What theme is Firefox switching to -- System theme? Some other theme?

By default, Firefox will sync your theme with other Firefox installations. If you use Sync, you can break the connection so you can have control of your theme separately in different installations. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste extensions.activeThemeID and pause while the list is filtered

Firefox should show two preferences, one being the ID of your current theme and the other being the one we want to switch.

(3) Double-click the services.sync.prefs.sync.extensions.activeThemeID preference to switch the value from true to false

more options

jscher2000 said

Does it make any difference if you change themes on the Add-ons page? You can open that using Ctrl+Shift+A, or from the main menu. In the left column, click Themes. Then find the one you want and click its Enable button. What theme is Firefox switching to -- System theme? Some other theme?

A bit more information. So, Firefox isn't switching themes. After enabling the dark mode theme and switching to a different tab or something of the like which makes it switch back to light mode, it'll still say that dark mode is enabled. It also does this with the System Theme. My computer is set to make apps appear in dark mode automatically, so System Theme will turn it to dark mode and them right back to light. I also followed the steps you listed, but no change.

more options

You can check for problems with preferences. You can delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

more options

Before renaming or removing prefs.js, backup your profile folder because it will cause immense problems and you will want to reinstate your profile as it was.

more options

Which parts are not staying dark? Toolbars and built-in pages, or only built-in pages?

more options

Выбранное решение

UPDATE 2/17/2021 I found the cause of my problem. I had an add-on called "Colorful Tabs" installed. When I disabled the add-on, dark mode stayed on.

Thank you everyone for the help, I really appreciate it.