Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Bookmarks are saving but never show up in my bookmarks bar folders?

  • 4 ответа
  • 1 имеет эту проблему
  • 34 просмотра
  • Последний ответ от searl75au

more options

Bookmarks are saving but never show up in my bookmarks bar folders?

  • I have tried to uninstall and reinstall but still same problem. And yes I did a hard delete of all installation files in users - app data..
  • I have checked the read only is not selected in the "places.sqlite", and even deleted it to force a new one, still didn't help.
  • I have also deleted the "xulstore.json" file and that also did not help.
  • I have reset in safe mode to default setting but that also didn't help.

Does anyone please know how to fix this very annoying problem?

Please I really don't want to go back to Chrome but if that's the only reliable browser without so many downsides (apart from privacy) then I don't see any other option if I can't fix this asap.

thank you.

Bookmarks are saving but never show up in my bookmarks bar folders? * I have tried to uninstall and reinstall but still same problem. And yes I did a hard delete of all installation files in users - app data.. * I have checked the read only is not selected in the "places.sqlite", and even deleted it to force a new one, still didn't help. * I have also deleted the "xulstore.json" file and that also did not help. * I have reset in safe mode to default setting but that also didn't help. Does anyone please know how to fix this very annoying problem? Please I really don't want to go back to Chrome but if that's the only reliable browser without so many downsides (apart from privacy) then I don't see any other option if I can't fix this asap. thank you.

Выбранное решение

I am an idiot, I was saving to "Bookmarks menu" and always assumed the same bookmarks would show in "Bookmarks Toolbar". Clearly I was wrong so this is my mistake! I have learned to save them in the right place.. der! Thank you anyway. Assumptions are the mother all %$£k ups.  :)

Прочитайте этот ответ в контексте 👍 0

Все ответы (4)

more options

Are you saying that the Bookmarks Toolbar is not displayed, or the toolbar is blank?


Step 1: If you have sync, and there is a problem anywhere, Shut Down Sync Immediately On All Devices to prevent the problem from spreading. Type https://accounts.firefox.com/settings<enter> in the address box. Once the problem is fixed, perform the same repair on all computers/profiles before using sync again.


[v57+] Places Maintenance is built into Firefox.

Type about:support<enter> in the address box.

You will find Places Database near the bottom. Press the Verify Integrity button.

If any errors are reported: https://support.mozilla.org/en-US/kb/fix-bookmarks-and-history-will-not-be-functional

The places.sqlite and favicons.sqlite files contains your History and Bookmarks. And it looks like they are corrupted.

Type about:support<enter> in the address box.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above files. Then rename or delete them. Restart Firefox. The browser should then create a new place.sqlite and recover your bookmarks from the backup files.

Note: Your history is not backed up and will be lost.

more options

Is the toolbar not displaying?

Customize Firefox controls, buttons and toolbars {web link}

Type about:customizing<enter> in the address box.

Note: about:customizing is no longer present in Firefox v47+ releases.

  • Press Alt or F10 to bring up the Menu Bar. Then View > Toolbars >
  • Right-click on a blank spot on the toolbar and select what you want.
  • Right-click on a blank spot on the toolbar and select Customize Toolbar.
    Look for Show / Hide Toolbars or just Toolbars at the bottom left.
    There is also a Restore Defaults button at the bottom right.
more options

Is the toolbar blank?

Open the Bookmarks Manager; Press the Alt or F10 key to bring up the toolbar and select Bookmarks. Hot key is <Control> (Mac=<Command>) <Shift> B. Firefox 84+ <Control> (Mac=<Command>) <Shift> O.

On the folder ‘tree’ at the left, select Bookmarks Toolbar Is anything shown? Try creating/moving something here.

more options

Выбранное решение

I am an idiot, I was saving to "Bookmarks menu" and always assumed the same bookmarks would show in "Bookmarks Toolbar". Clearly I was wrong so this is my mistake! I have learned to save them in the right place.. der! Thank you anyway. Assumptions are the mother all %$£k ups.  :)

Изменено searl75au