Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Background on websites dark all of a sudden

  • 7 ответов
  • 2 имеют эту проблему
  • 1 просмотр
  • Последний ответ от TKTrooper

more options

I don't why (as i have not altered any settings). But now when i use Mozilla firefox browser, a lot of websites are being displayed with a blark/dark background. I know it is the firefox browser as it does not do the same if i use other web browsers. I tried looking up the issue and solutions. All i could find was some suggestion that websites are displayed according to the settings on my PC i.e if it is set to light or dark mode. I checked this and the settings have not changed. Also as previously mentioned, then if that was the reason, surely the websites would display dark when using another browser. I have attached a screen shot of the twitter website as an example.

I don't why (as i have not altered any settings). But now when i use Mozilla firefox browser, a lot of websites are being displayed with a blark/dark background. I know it is the firefox browser as it does not do the same if i use other web browsers. I tried looking up the issue and solutions. All i could find was some suggestion that websites are displayed according to the settings on my PC i.e if it is set to light or dark mode. I checked this and the settings have not changed. Also as previously mentioned, then if that was the reason, surely the websites would display dark when using another browser. I have attached a screen shot of the twitter website as an example.
Приложенные скриншоты

Выбранное решение

OK, it's dark theme and now webpages follow it. If you want to keep it, enter "about:config" in the URL bar and set layout.css.prefers-color-scheme.content-override to 2 or 1.

Прочитайте этот ответ в контексте 👍 3

Все ответы (7)

more options

Check if you have a dark theme selected in ≡ -> Extensions and themes -> Themes.

more options

TyDraniu said

Check if you have a dark theme selected in ≡ -> Extensions and themes -> Themes.

Not that i can see. As mentioned i have not been messing about with any settings anyway. But from the theme installed there isn't even a "light/Dark" option available that i can see

more options

And i have had this theme installed for quite sometime now

more options

Выбранное решение

OK, it's dark theme and now webpages follow it. If you want to keep it, enter "about:config" in the URL bar and set layout.css.prefers-color-scheme.content-override to 2 or 1.

more options

TyDraniu said

OK, it's dark theme and now webpages follow it. If you want to keep it, enter "about:config" in the URL bar and set layout.css.prefers-color-scheme.content-override to 2 or 1.

Do you mean the creator changed the theme to a dark theme? Because like i said, i have had the them for well over 12 months now and ive never had this issue until the other day.

Also i have checked by disabling it and enabling other previous themes ive used and the websites are still displaying the same.

more options

Firefox 96 and newer look at the text color used in the toolbar area (tab bar) and if the text color is a light color (white) then the Firefox devs decided that you prefer to use a dark background and light text on webpage and thus switches to a dark theme. If you set layout.css.prefers-color-scheme.content-override = 1 (dark:0, light:1, system:2, browser:3) you override this for webpages to use a light theme.

more options

cor-el said

Firefox 96 and newer look at the text color used in the toolbar area (tab bar) and if the text color is a light color (white) then the Firefox devs decided that you prefer to use a dark background and light text on webpage and thus switches to a dark theme. If you set layout.css.prefers-color-scheme.content-override = 1 (dark:0, light:1, system:2, browser:3) you override this for webpages to use a light theme.

Thanks for explaining.


Also Thank you TyDraniu for the solution