Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How to force light mode on regardless of theme

  • 2 ответа
  • 2 имеют эту проблему
  • 114 просмотров
  • Последний ответ от nick151

more options

I have a custom theme on Firefox called Charlies Red. Up until two days ago, Firefox would always consider it to be in light mode (which I prefer) whenever I'd use it. Now, however, it's in dark mode, and the only way I can return to light mode is to give up my custom theme and instead choose Light as a theme, which I don't like as much as Charlies Red.

Is there a way to force light mode on regardless of which theme I use? One source said I could go to about:config and create a ui.systemUsesDarkTheme number, setting it to 0, but I tried it to no avail and so deleted the number.

I have a custom theme on Firefox called Charlies Red. Up until two days ago, Firefox would always consider it to be in light mode (which I prefer) whenever I'd use it. Now, however, it's in dark mode, and the only way I can return to light mode is to give up my custom theme and instead choose Light as a theme, which I don't like as much as Charlies Red. Is there a way to force light mode on regardless of which theme I use? One source said I could go to about:config and create a ui.systemUsesDarkTheme number, setting it to 0, but I tried it to no avail and so deleted the number.

Выбранное решение

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.

  • layout.css.prefers-color-scheme.content-override [dark:0, light:1, system:2, browser:3]

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

To go beyond that you need to use CSS code in userChrome.css.

Прочитайте этот ответ в контексте 👍 1

Все ответы (2)

more options

Выбранное решение

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.

  • layout.css.prefers-color-scheme.content-override [dark:0, light:1, system:2, browser:3]

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

To go beyond that you need to use CSS code in userChrome.css.

Полезно?

more options

cor-el said

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.
  • layout.css.prefers-color-scheme.content-override [dark:0, light:1, system:2, browser:3]
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. To go beyond that you need to use CSS code in userChrome.css.

That solved it! While changing the layout.css.prefers-color-scheme.content-override from 3 to 2 still kept Firefox in dark mode (which is strange, assuming 2 causes it to match Windows, which I have in light mode), the good news is that changing it to 1, which you said is light, fixed the problem instantly. Thank you!

Изменено nick151

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.