On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Dark pages

more options

When I changed my add-on theme today, all website pages are now dark. I want them white. I deleted and reinstalled FF but that did not help. Any fix for this?

When I changed my add-on theme today, all website pages are now dark. I want them white. I deleted and reinstalled FF but that did not help. Any fix for this?

Выбранное решение

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.

  • layout.css.prefers-color-scheme.content-override
    Dark (0), light (1), system (2) or browser (3)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also this pref:

  • ui.systemUsesDarkTheme [0:light; 1:dark; 2:no-preference]
  • 1736218 - Add some sort of UI to select content dark theme preference
Прочитайте этот ответ в контексте 👍 0

Все ответы (5)

more options

Type about:addons<enter> in the address box to open the Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance or Themes. Then select Default or System theme — auto. Now restart Firefox.

more options

Pages are still dark when I enable the theme I had earlier today.

more options

Выбранное решение

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.

  • layout.css.prefers-color-scheme.content-override
    Dark (0), light (1), system (2) or browser (3)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also this pref:

  • ui.systemUsesDarkTheme [0:light; 1:dark; 2:no-preference]
  • 1736218 - Add some sort of UI to select content dark theme preference
more options

Chosen solution works. Dark pages (blank) still load prior to web page loading in light. Some drop down boxes are still black but guess I'll just have to live with that.

more options

jivey said

Chosen solution works. Dark pages (blank) still load prior to web page loading in light. Some drop down boxes are still black but guess I'll just have to live with that.

Yes, if your toolbar theme has light-colored text on the background/inactive tabs, it's normal for right-click context menus and toolbar drop-down panels to have light text on a black background. If it becomes too annoying you could consider changing your theme.