Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Apple TV Plus Video Glitch (likely DRM related)

  • 6 ответов
  • 4 имеют эту проблему
  • 22 просмотра
  • Последний ответ от ala2

more options

Audio seems to be fine, but the video is completely garbled/distorted (see attached image)

Tried with Firefox Nightly for Android 96.0a1 and Firefox Browser for Android 94.1.2. Both are experiencing the same issue.

Audio seems to be fine, but the video is completely garbled/distorted (see attached image) Tried with Firefox Nightly for Android 96.0a1 and Firefox Browser for Android 94.1.2. Both are experiencing the same issue.
Приложенные скриншоты

Изменено KaNeoRotar

Все ответы (6)

more options

Here is the screenshot

more options

Hello,

This most likely isn't your problem, as I can't see an attached image and have little information to go on, but to rule out graphics acceleration, please follow the instructions. (this does assume that you are using a computer to cast or passthrough)

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

  1. Click the menu button Fx57Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

more options

andmagdo said

Hello, This most likely isn't your problem, as I can't see an attached image and have little information to go on, but to rule out graphics acceleration, please follow the instructions. (this does assume that you are using a computer to cast or passthrough) Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:
  1. Click the menu button Fx57Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.
Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: Thank you.

Thank you for your reply. Please note that I'm experiencing this problem on Firefox for Android. Your instructions seem to apply only to desktop versions.

Please check the screenshot in my first reply to this thread.

more options

Hi

Is this only happening on Apple TV or does it happen on other media sites (such as YouTube)?

more options

I have the identical problem. It does not occur on the Windows version. Only the Android version. I can watch Apple+ TV previews perfectly. I can watch videos on other streaming services perfectly. Could there be a DRM passing issue?

Изменено ala2

more options

Any chance someone can look into this? Apple is pointing at Firefox when it's even admitting this option exists at all.