Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Blocked downloads in Firefox 93

  • 3 ответа
  • 2 имеют эту проблему
  • 129 просмотров
  • Последний ответ от ljbetche

more options

Since updating to Firefox 93.0, I notice that downloads from certain sites are being blocked, because they are using a basic HTTP connection, requiring me to explicitly allow each download. I understand that this is a new "feature," as explained here: https://blog.mozilla.org/security/2021/10/05/firefox-93-protects-against-insecure-downloads/, however, I in no way desire this behavior. It is an asinine nuisance, and if I cannot disable it, I will have no choice but to revert to an early version of Firefox. My question, then is this: is it possible to disable this check, and simply allow all downloads? If so, how can I do that?

Since updating to Firefox 93.0, I notice that downloads from certain sites are being blocked, because they are using a basic HTTP connection, requiring me to explicitly allow each download. I understand that this is a new "feature," as explained here: https://blog.mozilla.org/security/2021/10/05/firefox-93-protects-against-insecure-downloads/, however, I in no way desire this behavior. It is an asinine nuisance, and if I cannot disable it, I will have no choice but to revert to an early version of Firefox. My question, then is this: is it possible to disable this check, and simply allow all downloads? If so, how can I do that?

Выбранное решение

To turn it off, enter about:config in the URL bar and switch the dom.block_download_insecure preference to false. Or, for this specific file, you can just click the right arrow in the download panel and accept this file.

Прочитайте этот ответ в контексте 👍 2

Все ответы (3)

more options

I tried toggling off the "Block dangerous downloads" option in the Privacy and Security page of my Preferences, which sounds like it should fix this particular issue, but it had no effect.

Изменено ljbetche

more options

Выбранное решение

To turn it off, enter about:config in the URL bar and switch the dom.block_download_insecure preference to false. Or, for this specific file, you can just click the right arrow in the download panel and accept this file.

more options

Thank you TyDraniu! That was exactly what I was looking for.