Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Double-clicking on PDF attachment when composing email won't open the file

  • 7 ответов
  • 3 имеют эту проблему
  • 79 просмотров
  • Последний ответ от m70

more options

In version 91.1.2 (32-bit), when writing a new email with attachments, if I double-click on a PDF attachment to view the file (either in the new Thunderbird pdf preview or Acrobat Viewer), it opens a new email composition window in thunderbird with the PDF in attachment instead of opening the pdf file.

I always double-check the files I have attached by double-clicking on them before I send an email with sensitive information. This is a very important feature. Hopefully you can bring it back.

Thanks

Выбранное решение

Hi Guys,

I solved this problem for me. My Thunderbird was reading the .pdf as a html file In composition which I think is a bug.

Under Preferences and Under Files & Attachments - select Firefox HTML Document And either delete or change action to use adobe acrobat reader and it should solve the problem.

Прочитайте этот ответ в контексте 👍 2

Все ответы (7)

more options

That version behaves as expected on my end. When I try to reproduce your problem, I get a prompt for what Thunderbird should do with the file. That prompt gives me the option to open the file using the program I choose or save the file. When I open a message that has a pdf attachment and double-click the attachment, it opens in Thunderbird's pdf (pre)view(er). This is in line with my preference which is set to "Preview in Thunderbird".

Полезно?

more options

This is very strange. Following your reply I tried to change the configuration to 'Always Ask' but it still opens a new 'Write' window. Please note that it behaves as expected when reading emails, the problem only happens when writing a new email.

Полезно?

more options

I have exactly the same problem. I'm running 91.2.1 (32-bit) and when I am composing an email and click on a pdf attachment in it to check it, it opens a new compose window rather than opening the pdf. Very annoying as I have to waste time finding the file again and opening it just to check it is the correct one.

Полезно?

more options

I also can't open PDFs in emails that I am writing since the update, but I don't get the compose new email issue. Mine just provides the option to open with applications that aren't PDF readers, or to save the file.

Полезно?

more options

Выбранное решение

Hi Guys,

I solved this problem for me. My Thunderbird was reading the .pdf as a html file In composition which I think is a bug.

Under Preferences and Under Files & Attachments - select Firefox HTML Document And either delete or change action to use adobe acrobat reader and it should solve the problem.

Полезно?

more options

Thank you Brendan, it worked for me. Only difference is that I had to delete Chrome HTML Document instead. So I guess delete "Tour Main Browser" HTML Document for it to work.

Полезно?

more options

Thanks both of you. That sorted it for me. It still identified the pdf as html, even after I deleted the html entry in Files & Attachments and restarted. However I just forced it to use Adobe Reader instead of the offered choices.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.