Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Window column width

  • 5 ответов
  • 1 имеет эту проблему
  • 13 просмотров
  • Последний ответ от jrbraid

more options

Hello all, I regularly open up pop up windows to do my job, containing lots of column data. Until recently, the columns would squeeze down as small as they could - depending on data field and font size - meaning the bottom scroll bar was unnecessary. However, in last 1-2 weeks(?) the data columns seem happy to spread themselves out menaing I always have to scroll right to see the last few columns. Is there anything like a 'make the columns fit if they're capable of doing' command/shortcut? Thanks all.

Выбранное решение

Thanks for both replies. I think I found it - Settings - general - Zoom and tick Zoom text only. This seems to have returned it to as before....for now! Thanks again.

Прочитайте этот ответ в контексте 👍 0

Все ответы (5)

more options

One possible reason that table cells might not get narrower to fit the window is if there are long words or URLs that Firefox won't break. Do you notice anything like that in the tables?

It's always difficult to track down little layout changes, but there is a tool you can use -- if you have a lot of bandwidth and a good chunk of time -- to find the patch that caused a change in Firefox. More info about the Mozregression tool on this site: https://mozilla.github.io/mozregression/

Полезно?

more options

Thanks for the reply. The data fields aren't long, and the puzzling bit is it's managed to auto-scale before when the font has allowed, but now it wants to scroll. It's as if a setting has changed to 'not', from 'used to'.

Полезно?

more options

Normally Firefox will squeeze web content that doesn't have a fixed width as much as possible to avoid a horizontal scrollbar. I can't think of a setting to not do that.

I'm not sure what else to suggest without being able to see the problem page, except perhaps to poke around in the table style rules, or perhaps check the entire page for rules or content that would prevent it from narrowing.

Does this affect other sites for you? As an example, the content on this page (regular paragraphs and table) should narrow until you reach the minimum width Firefox allows for windows:

https://www.jeffersonscher.com/ext/pdf-converters.html

Полезно?

more options

You may have accidentally zoomed webpage(s). Reset the page zoom on pages that cause problems.

  • View -> Zoom -> Reset (Ctrl+0/Command+0 (zero))

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Полезно?

more options

Выбранное решение

Thanks for both replies. I think I found it - Settings - general - Zoom and tick Zoom text only. This seems to have returned it to as before....for now! Thanks again.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.