Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Suddenly got this error: "Did Not Connect: Potential Security Issue"

  • 8 ответов
  • 1 имеет эту проблему
  • 28 просмотров
  • Последний ответ от farisfadhir

more options

I suddenly got this error a few days back and it only appears when I try to open facebook and youtube (or at least just those two websites for now). I can still google things just fine. I also copied the following from firefox:

https://www.youtube.com/

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: true HTTP Public Key Pinning: true

Certificate chain:


BEGIN CERTIFICATE-----

MIIDSDCCAjCgAwIBAgIEYMoTvDANBgkqhkiG9w0BAQsFADBAMQ4wDAYDVQQKDAVD aXNjbzEuMCwGA1UEAwwlQ2lzY28gVW1icmVsbGEgU2Vjb25kYXJ5IFN1YkNBIGhr Zy1TRzAeFw0yMTA2MTQxNTAyMzBaFw0yMTA2MTkxNTAyMzBaMGwxCzAJBgNVBAYT AlVTMRMwEQYDVQQIDApDYWxpZm9ybmlhMRYwFAYDVQQHDA1TYW4gRnJhbmNpc2Nv MRYwFAYDVQQKDA1PcGVuRE5TLCBJbmMuMRgwFgYDVQQDDA93d3cueW91dHViZS5j b20wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQDUOxWZs6S+HMCY03le TYlVZ9X3B0qd250c3qpnrxvPaUH4tyiXXv66eA1vOuFl2PipRu8+WeYVhl/b/nfO DuVUbeEZ20Dng5He/KaObcFRXhVrF6eUgsDC5np3yeQIgMon1rNXPp+M+JFmtE9A XOiqA70EStgj/r+v5Acs1BKwl1gnFQtEvAjkgQFpCXQOEWEjXkCxN8THh+U25Ifu 2SQj2KkrYW7cg7nG9MaNuioThOlqYrOqynw+Qls01Pc/mV46sEOg+jqtrw35VI4S fhP3GiiUSw0ktMVGpgTdE0AlYBVK053fxA8zU9oZn2kUpsmRTrMU5QC79HkKKYXm ks8jAgMBAAGjHjAcMBoGA1UdEQQTMBGCD3d3dy55b3V0dWJlLmNvbTANBgkqhkiG 9w0BAQsFAAOCAQEA0tQVuQLjGpTUK0VgMvgvV1eg/+nb9LoIiEZyutXPrQl3Pvoa 1WhGw4woMFcHiVGOyrD68AqJsRH779I6VPhsYKAHJoQcPZ0zs+27HgooaWXfSuGy xBrLJUV6yT+ZqmT1BA2QkYRT8JgWSoBMlXXvLQfwj2KMdlSlVGv1SXu0fq9Y5SyN deir0Nq1p+83p0wr7JQvZHq6CwvQBXDx7XSAVoYIkFVlUBtJlzlPcu75fQBu6bY/ 9zoDVBcQxxANMsT90z8z8a5bzwTP/e9z0mWdiWrpMgHYGWWaRVwZJrDj5vq6rUmw 9JDXWcaNkWmNuulSN0cdyBz8vR5aWgDl/kFYjA==


END CERTIFICATE-----
BEGIN CERTIFICATE-----

MIIENjCCAx6gAwIBAgIRAOxWhi1BRktMpBCowvYwkjwwDQYJKoZIhvcNAQELBQAw cTELMAkGA1UEBhMCVVMxEzARBgNVBAgMCkNhbGlmb3JuaWExFjAUBgNVBAcMDVNh biBGcmFuY2lzY28xDjAMBgNVBAoMBUNpc2NvMSUwIwYDVQQDDBxDaXNjbyBVbWJy ZWxsYSBQcmltYXJ5IFN1YkNBMB4XDTIxMDYxNDE3NDIwMVoXDTIxMDYyNTE3NDIw MVowQDEOMAwGA1UECgwFQ2lzY28xLjAsBgNVBAMMJUNpc2NvIFVtYnJlbGxhIFNl Y29uZGFyeSBTdWJDQSBoa2ctU0cwggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEK AoIBAQDUOxWZs6S+HMCY03leTYlVZ9X3B0qd250c3qpnrxvPaUH4tyiXXv66eA1v OuFl2PipRu8+WeYVhl/b/nfODuVUbeEZ20Dng5He/KaObcFRXhVrF6eUgsDC5np3 yeQIgMon1rNXPp+M+JFmtE9AXOiqA70EStgj/r+v5Acs1BKwl1gnFQtEvAjkgQFp CXQOEWEjXkCxN8THh+U25Ifu2SQj2KkrYW7cg7nG9MaNuioThOlqYrOqynw+Qls0 1Pc/mV46sEOg+jqtrw35VI4SfhP3GiiUSw0ktMVGpgTdE0AlYBVK053fxA8zU9oZ n2kUpsmRTrMU5QC79HkKKYXmks8jAgMBAAGjgfkwgfYwEgYDVR0TAQH/BAgwBgEB /wIBADAOBgNVHQ8BAf8EBAMCAYYwHQYDVR0OBBYEFAIpVEnS1669E34m/m9jW9ug 4JLsMB8GA1UdIwQYMBaAFEVf9ZtxMyWpwE48AkTPPOhGBhbEMEwGCCsGAQUFBwEB BEAwPjA8BggrBgEFBQcwAoYwaHR0cDovL2NybC5wcm9kLmNhZ2VuZXJhdG9yLnBr aS5zdHJsbi5uZXQvY2EucGVtMEIGA1UdHwQ7MDkwN6A1oDOGMWh0dHA6Ly9jcmwu cHJvZC5jYWdlbmVyYXRvci5wa2kuc3RybG4ubmV0L2NybC5wZW0wDQYJKoZIhvcN AQELBQADggEBAKdZP2XFQHAdcRGHN0GQRKge68eFJ58cH4ZSuYysK/SQ5hZfCZ8P qa8pT0xOk9E3ZRvlCSHw1VYLk6HDe5ksTYJi+PH2rJI6f2ILpa0pCJYt/xwsnjtd yqDMmwWqhhMtfwn2XRB8xdH6xYf8kNkO4w7Y5qzWKafSgXZr/LbAmJwugfJoHgfl XQOf996l9qoGBTye3ZTZ1+JPHuZiZ5GQGe5SzKfjPjhF8amPsOdvrqNR3UGNWdWb l74DWwvm5t5/qGCRVzEKJV4T0oYmAfAbSRJ5v/J+/boKYQPAVeu4FJWMiV0W5+zZ nBTpQSZX6UZocMv4NCn1LKswreGxWPe1n5E=


END CERTIFICATE-----
BEGIN CERTIFICATE-----

MIIEuzCCA6OgAwIBAgIJAcQ3zFeNvKYVMA0GCSqGSIb3DQEBCwUAMDExDjAMBgNV BAoTBUNpc2NvMR8wHQYDVQQDExZDaXNjbyBVbWJyZWxsYSBSb290IENBMB4XDTE5 MDUyMTE5NTMxOFoXDTI0MDUyMTE5NTMxOFowcTELMAkGA1UEBhMCVVMxEzARBgNV BAgMCkNhbGlmb3JuaWExFjAUBgNVBAcMDVNhbiBGcmFuY2lzY28xDjAMBgNVBAoM BUNpc2NvMSUwIwYDVQQDDBxDaXNjbyBVbWJyZWxsYSBQcmltYXJ5IFN1YkNBMIIB IjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAuFEhA5TkN8CiGmW7XjaUbuve U274v0kt6hRW8UUakmbyLnkI4d/BBQrGW71LYiT2QH4UaoYuihTXjuyAlzDxJ9OQ Vje2NB9RdE3FcUCISeW5GrQs7vF2xFrjs2TGgG4ZXjE/8WymgFZP50nsTJYf7VqL 1r6Brs59DAbbQ1rVvsz/DFxoE3ruFagSFcOF07/watUxFrAPV+S/kK6Nb5TqrI1j 32hK6i49ujavDcbbb12aozwdoyPSyhs4cB0sCXFHK/yEdaE4CNXEAH8EjKUuj6O2 QUvRtBGM480688BId0T0ws3q+hSzRiVJ+dYCr3iufmTrAMhVwc+EzGjlEfLyXwID AQABo4IBlDCCAZAwDgYDVR0PAQH/BAQDAgGGMBIGA1UdEwEB/wQIMAYBAf8CAQEw UgYDVR0gBEswSTBHBgorBgEEAQkVAR0AMDkwNwYIKwYBBQUHAgEWK2h0dHA6Ly93 d3cuY2lzY28uY29tL3NlY3VyaXR5L3BraS9wb2xpY2llcy8wHQYDVR0OBBYEFEVf 9ZtxMyWpwE48AkTPPOhGBhbEMEwGA1UdHwRFMEMwQaA/oD2GO2h0dHA6Ly93d3cu Y2lzY28uY29tL3NlY3VyaXR5L3BraS9jcmwvY2lzY291bWJyZWxsYXJvb3QuY3Js MIGHBggrBgEFBQcBAQR7MHkwSQYIKwYBBQUHMAKGPWh0dHA6Ly93d3cuY2lzY28u Y29tL3NlY3VyaXR5L3BraS9jZXJ0cy9jaXNjb3VtYnJlbGxhcm9vdC5jZXIwLAYI KwYBBQUHMAGGIGh0dHA6Ly9wa2ljdnMuY2lzY28uY29tL3BraS9vY3NwMB8GA1Ud IwQYMBaAFENzAN4kukAaQFQsfXzVAEiJDHCkMA0GCSqGSIb3DQEBCwUAA4IBAQC6 P7ugvpQSkNxrzY1ZM0Nd9Q3LaoTERS4ItcxMsswFPl7ID/3Vk3v3ZT6KgtCZ+Nh0 MUgZztLATHf42ZppdSkdMf1HfCmLSWORz/eK+fZxztE63M1EGiZJoe8qFKT9z6qx iDD989jyjY74sYfiSo5nbhcb5meUrUO6MQvOO5pUnlhWsDiBUg+yBzyfVoLnGRlY 2t7UZVTUz5kbBNFieTIt86yaYAumgOqriz/dCgQltFySbOkrgg/PN7cRv3IWm84C uKQ9prsXbXLLbl8U+bGRH119prl3zJyRnQ0D+ursCqUnIfziBdKv7yLsupGDGt+Q oqLzmkMPYE+WZmEi+3j5


END CERTIFICATE-----
Приложенные скриншоты

Все ответы (8)

more options

The certificate has been issued by "OpenDNS, Inc.", so it looks that you either switched the DNS service or you lost the root certificate for "OpenDNS, Inc." if this worked previously.

You can possibly set security.enterprise_roots.enabled = true on the about:config page to see if that helps.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Полезно?

more options

OpenDNS is linked to the Cisco Umbrella security service that companies may use to protect employee computers on the web, or to filter what employees to do on the web.

cor-el pointed to the simplest solution; hopefully that works.

Otherwise, to allow Firefox to work with Umbrella, you also can import a certificate as described in a Cisco support article -- problem being that you need an admin login to get the certificate from Cisco...

https://docs.umbrella.com/deployment-umbrella/docs/install-cisco-umbrella-root-certificate#firefox

Полезно?

more options

cor-el said

The certificate has been issued by "OpenDNS, Inc.", so it looks that you either switched the DNS service or you lost the root certificate for "OpenDNS, Inc." if this worked previously. You can possibly set security.enterprise_roots.enabled = true on the about:config page to see if that helps. You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".


Unfortunately, it didnt work for me. You implied that i could have switched DNS services or even lost the certificate and Im wondering how that happens.

Полезно?

more options

OpenDNS / Cisco Umbrella is a service that you either can subscribe to yourself, or which may be used by your employer, if it's a company computer. If you were setting it up yourself, you could change DNS in any number of places, including your wired/wireless router or Windows TCP/IP settings. If it's work network or PC, there are other ways to implement it.

The reason for a certificate error is that Umbrella diverts certain requests to its own server without changing the original site address, which requires presenting a fake site certificate to Firefox. Firefox will reject the fake certificate unless the certificate used to sign the fake site certificate either (A) has been saved to Firefox's own certificate store as a trusted authority or (B) has been saved to the Windows system certificate store as a trusted authority and you change the Firefox setting to instruct Firefox to trust the Windows certificate store.

Does that make sense?

Полезно?

more options

I see, I understand what youre saying. So, is there a reset that I can use to turn back the certificates to their original ones?

Полезно?

more options

farisfadhir said

So, is there a reset that I can use to turn back the certificates to their original ones?

I don't know why your Firefox (or your Windows) is routing your requests through OpenDNS. You could check your connection settings:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

At the bottom of the panel is the DNS over HTTPS setting. You can experiment with turning this on and off. More info in the following article: Firefox DNS-over-HTTPS.

Полезно?

more options

Sorry, it didnt work either

Полезно?

more options

Ok, now everything is back to normal. I dont exactly know what happened but thanks for the tips

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.