Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

firefox.ocm => firefox.com . Without asking me. Without notifying me.

  • 2 ответа
  • 1 имеет эту проблему
  • Последний ответ от jscher2000

more options

When I type in ANY URL, I want exactly that to be loaded. And not anything else.

When I type in mozilla.rog into the address bar, I want firefox to fetch the page mozilla.rog. I want firefox to try, and if it does not exist, I demand to be notified that it does not exist. With an error message. URL not found. Error 404.

But instead, Firefox silently changes mozilla.rog to mozilla.org (and probably any page e.g. from .rog to .org, and from .ocm to .com , and the like) without my permission, and loads this other page I did not type in.

I do NOT and NEVER allow ANY program to alter my commands without notifying me.

so... which about:config setting disables this autocorrection-behavior?

Все ответы (2)

more options

Maybe setting 'keyword.enabled' to false in the about:config page will help.

Полезно?

more options

I'm not sure why you say "without notifying me" because Firefox displays the URL it will visit in the top line of the autocomplete drop-down as you type. To bypass the "guessing" and force Firefox to take your text literally, type a slash after the host name (see screenshot):

I'm not aware of a preference related to the .rog => .org behavior. The source code shows the full list of substitutions: https://searchfox.org/mozilla-release/source/docshell/base/URIFixup.jsm#684

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.