Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

How do I figure out why Content tracking is blocking my site?

  • 7 ответов
  • 1 имеет эту проблему
  • 30 просмотров
  • Последний ответ от sam.redmond

more options

We have a site that for some reason just started getting blocked by FireFox's Tracking content setting in private browsing mode. We have a Production build that still works but our QA build does not. For the life of my I can't figure out what changed that would have triggered Tracking content to start blocking the site. Basically the site will load but we only get a blank page.

Is there any way to debug what exactly the Tracking content filter is blocking?

Все ответы (7)

more options

.....

Изменено jonzn4SUSE

Полезно?

more options

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection.

You can check the Web Console for messages about blocked content.

Полезно?

more options

@cor-el it's not really helpful and doesn't really give me any detailed information. That and I get the same response from the version of our site that does work

Полезно?

more options

Are you sure that ETP is blocking content and not some content blocking extension ?

It would help if you provide the URL and possibly attach a screenshot that shows what is wrong.

The Web Console and Network Monitor should show every item that is blocked and why it is blocked.

Полезно?

more options

Yes I'm quite sure. I have no extensions installed. I'm in private browser mode and when I turn off Tracking content in about:preferences#privacy my site works, when I turn it on it breaks so I'm confident that's the culprit.

What I really want is a way to debug what exactly that setting is doing that is preventing my site from loading. Having something that can tell me exactly what that setting is blocking would be helpful.

Also there are no scripts or network calls are the same for the working version and the broken version nothing is being singled out from that perspective.

Изменено sam.redmond

Полезно?

more options

Did you try to temporarily allow all third-party cookies as a test ?

If something is blocked by Firefox then you should see errors or warnings in the Web Console about content being blocked.

Aren't there any messages in the console ?

Полезно?

more options

Toggling 3rd party cookies didn't do anything and we see no errors in the console. It seems that that the Track content setting is messing with some lifecycle events. We have a react app that listens for the pageshow event in a useEffect hook. Normally this works fine, but with this setting on it seems not to work at all. We tested this by adding in

window.addEventListener('pageshow', () => {

 console.log('pageShow event fired');

});

at the top of the main app file and it fires before the useEffect which shouldn't be happening. Why would toggling the track content setting change this behavior?

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.