Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Firefox tries saving all JPEG files as .jif.

  • 9 ответов
  • 1 имеет эту проблему
  • 151 просмотр
  • Последний ответ от Abrimaal

more options

For the past few days, my browser has started trying to save all JPEG files, regardless of their actual fire extension, as .jif. (see attached photo) I have not changed anything that should have done that, and cannot seem to change it back. Any help would be much appreciated!

For the past few days, my browser has started trying to save all JPEG files, regardless of their actual fire extension, as .jif. (see attached photo) I have not changed anything that should have done that, and cannot seem to change it back. Any help would be much appreciated!
Приложенные скриншоты

Выбранное решение

Turns out it was a Windows Registry issue, I fixed it through there.

Прочитайте этот ответ в контексте 👍 2

Все ответы (9)

more options

So if you change it to .jpg, download it, and repeat the process and what option is there?

more options

jonzn4SUSE said

So if you change it to .jpg, download it, and repeat the process and what option is there?

Still .jif is the default. If I rename it to .jpg when downloading it works fine, even changing the extension after downloading works. But .jif doesn't show thumbnails and messes with a few search strings I use, and I'd rather not have to rename every image I download.

Изменено malendras1

more options

Выбранное решение

Turns out it was a Windows Registry issue, I fixed it through there.

more options

Can you go into the registry and verify this key and that Extension value is .jpg?

Изменено jonzn4SUSE

more options

See also threads like these:

  • /questions/1272478 When I upload an image, Firefox does not show jpg in Windows Explorer dialogue
more options

Mee too it's by default in jif : https://i.imgur.com/PT1cKrg.png regedit:https://i.imgur.com/HXXas6r.png

more options

I had the same problem, .jpg images were saved as .jpeg - not a common extension. I changed the extension in the registry from .jpeg to .jpg Now I am unsure if I can open .jpeg, but every time I can associate it with a viewer. The issue can be related to the alphabetic order, because .jfi and .jpeg are above .jpg and the first option is selected.

more options

Hi Abrimaal

Did you check the image/jpg key as that is more likely the related MIME type send for a JPG image ? To what key in the MIME\Database is HKEY_CLASSES_ROOT\.jpg linked ?

What is the file extension linked under image/jif

It is probably best to leave image/jpeg as .jpeg as that can be a different format.

more options

No I didn't check. If the first solution is working, why looking for other. Even if I find a single file with .jpeg extension on my PC, I can send it to a viewer and change extension while opening.