Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

"For quick access, place your bookmarks here on the bookmarks toolbar. Manage bookmarks..." message.

  • 12 ответов
  • 3 имеют эту проблему
  • 693 просмотра
  • Последний ответ от ADNAN PMI

more options

Hi. The message "For quick access, place your bookmarks here on the bookmarks toolbar. Manage bookmarks..." has appeared at the top of my Firefox window. I don't think it's been there for more than a couple of days, so it must have been added by a recent update. I already have my bookmarks available just fine, so is there a way to get rid of the message? Thanks!

Приложенные скриншоты

Выбранное решение

Starting in Firefox 84, unless I'm missing something, the placeholder will appear as long as the bar is empty.

Is there anything you might be willing to add to the bar? For example, if the bar contains

  • "Bookmarks Toolbar Items" (with no actual bookmarks) on the left
  • the Full Screen button (or some other button you might use) on the right

Would that be too distracting?

If that won't work for you, I believe we have to move into the realm of custom style hacking. This is an unofficial community-supported workaround such as:

  • Extend the bottom margin of the main toolbar so you don't need to display the Bookmarks Toolbar
  • Hide or modify the appearance of the placeholder text (feasibility TBD)
Прочитайте этот ответ в контексте 👍 1

Все ответы (12)

more options

The Bookmarks Toolbar is currently empty, so you see its placeholder text. Either you haven't added any bookmarks to the toolbar, or you moved them to a different toolbar. Either way, I suggest hiding that bar.

To turn different bars on and off, you can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn off the Bookmarks Toolbar, click it on the list (or if you have the newer sub-menu design, set it to never show).

Does that "stick" on yours or does Firefox re-open the bar later? If it re-opens, can you figure out any trigger for it?

Полезно?

more options

Note that in Firefox 84 you can toggle the Bookmarks Toolbar via Ctrl+Shift+B, previously used to open the Bookmarks Manager (Library => Ctrl+Shift+O), in case you accessibility used this shortcut key.

Изменено cor-el

Полезно?

more options

Thank you both for your answers. However, none actually fix this for me. You see, I've had the bookmarks toolbar visible and empty for years. I like the look that it provides. Looking from top to bottom, the way the website appears right below the address bar isn't to my liking. the empty bookmarks toolbar fixes that by acting as a visual buffer. To provide @jscher2000 with an answer, if I make the toolbar invisible, it remains invisible. But again, that doesn't solve my issue. I'd like to know if there's a way to remove the message without making the bookmarks toolbar invisible. At least having the option to do that doesn't seem like a very far fetched feature.

Полезно?

more options

Выбранное решение

Starting in Firefox 84, unless I'm missing something, the placeholder will appear as long as the bar is empty.

Is there anything you might be willing to add to the bar? For example, if the bar contains

  • "Bookmarks Toolbar Items" (with no actual bookmarks) on the left
  • the Full Screen button (or some other button you might use) on the right

Would that be too distracting?

If that won't work for you, I believe we have to move into the realm of custom style hacking. This is an unofficial community-supported workaround such as:

  • Extend the bottom margin of the main toolbar so you don't need to display the Bookmarks Toolbar
  • Hide or modify the appearance of the placeholder text (feasibility TBD)

Полезно?

more options

jscher2000 said

If that won't work for you, I believe we have to move into the realm of custom style hacking. This is an unofficial community-supported workaround such as:
  • Extend the bottom margin of the main toolbar so you don't need to display the Bookmarks Toolbar
  • Hide or modify the appearance of the placeholder text (feasibility TBD)

For the second of those, it would be as follows. Setting this up is a little bit involved, so please set aside 10 quiet minutes to work through it.

(For anyone who already has a userChrome.css file set up, you just need to add the rule under (A) to your file.)

(A) Select and copy the following style rule code

/*** Bookmarks Toolbar: Hide the empty toolbar message ***/
#personal-toolbar-empty {
  visibility: hidden !important;
}
 

(Note for people familiar with CSS: You can use display:none instead but the bar loses a bit of height with that rule.)

(B) Generate and download a userChrome.css file

Open the following page and paste the above rules into the editor, replacing the sample rule:

https://www.userchrome.org/download-userchrome-css.html

Then click "Generate CSS File" and save the userChrome.css file to your computer. (See first attached screenshot)

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See second attached screenshot)

Minimize that file browser window for later reference.

(C) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have videos for both Windows and Mac in case the text is not clear.

(D) Move the userChrome.css file you downloaded in Step B into the chrome folder you created in Step C

(E) Set Firefox to look for userChrome.css at startup -- see step #6 in the above article.

The next time you exit Firefox and start it up again, it should discover that file and apply the rule.

Success?

Once you start tweaking the interface this way, you'll probably find more and more things you want to do. I suggest bookmarking the pages where you get the code for future reference because changes to Firefox may break them and it's easier to request an update if you can find the source.

Полезно?

more options

@jscher2000 thank you for another reply, and so soon at that. The "Bookmarks Toolbar Items" item was already on the toolbar, all the way to the left and the message still appeared. However, I didn't know that I could add icons, such as the Full Screen icon that you mentioned, on the bookmarks toolbar! I added it all the way to the right and it's just fine now. Thank you for helping out and I apologize for not utilizing what you went through the trouble of writing as a second option. Have a good day/night!

Полезно?

more options

No worries, the easy workaround often is the best.

Полезно?

more options

jscher2000 said

Starting in Firefox 84, unless I'm missing something, the placeholder will appear as long as the bar is empty. Is there anything you might be willing to add to the bar? For example, if the bar contains
  • "Bookmarks Toolbar Items" (with no actual bookmarks) on the left
  • the Full Screen button (or some other button you might use) on the right
Would that be too distracting? If that won't work for you, I believe we have to move into the realm of custom style hacking. This is an unofficial community-supported workaround such as:
  • Extend the bottom margin of the main toolbar so you don't need to display the Bookmarks Toolbar
  • Hide or modify the appearance of the placeholder text (feasibility TBD)

this toolbar popped up after updating to FF 84 (x64), so i wanted to give it a try tried adding bookmarks to the bookmarks toolbar from the bookmarks menu + tried simple drag and drop url or links to bookmarks quick access toolbar neither of them worked for me. . is there something i'm missing

Полезно?

more options

Hi ADNAN PMI, could you open the Customize panel and confirm that the "Bookmarks Toolbar Items" control is on the Bookmarks Toolbar? See: Customize Firefox controls, buttons and toolbars

Полезно?

more options

jscher2000 said

Hi ADNAN PMI, could you open the Customize panel and confirm that the "Bookmarks Toolbar Items" control is on the Bookmarks Toolbar? See: Customize Firefox controls, buttons and toolbars

yeah its there. but the text content in the box is little bit different from ur image. i think i might have deleted the "Getting Started" and "Most visited" from the bookmarks toolbar that's why its empty.

Полезно?

more options

Hi ADNAN PMI, thank you for the screenshot. I see it on the bottom row of available controls, fourth position. You need to drag that back onto the Bookmarks Toolbar in order to "receive" dropped bookmarks.

Полезно?

more options

Thanks @jscher2000 that solved it. thanks for the help. this feature will save a lot of time. don't have to type. just open it in one click. Thanks

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.