Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

I've been logged out of my websites every time I close the browser

more options

I have all my settings set where it doesn't do that. I have everything unchecked with regards to deleting history and logins and have the delete cookies to unchecked to. My settings have been the same for years and haven't changed.

I have all my settings set where it doesn't do that. I have everything unchecked with regards to deleting history and logins and have the delete cookies to unchecked to. My settings have been the same for years and haven't changed.

Выбранное решение

joshandjosh92 said

FredMcD said

At the bottom of the page, turn on Clear History When Firefox Closes.

At the far right, press the Settings button. Turn on ONLY

Cache and Form And Search History leaving the others off.

The only thing I do different from that is have browsing and download history checked in the settings box. Is that causing the problem?

Actually, yes. Firefox recently enabled a new form of protection against first-party tracking cookies. They get purged if you haven't visited the site for 30-45 days. Firefox computes the last visit date from -- you guessed it -- your history.

Assuming you want to keep clearing history, you probably need to turn off this new feature for now (until they come up with another approach):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste purge and pause while the list is filtered

(3) Double-click the privacy.purge_trackers.enabled preference to switch the value from true to false

Please let us know whether that makes any difference for you.

Прочитайте этот ответ в контексте 👍 0

Все ответы (4)

more options

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

more options

FredMcD said

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out. You may be in Private Browsing mode or told Firefox not to remember. Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings. Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

The only thing I do different from that is have browsing and download history checked in the settings box. Is that causing the problem?

more options

Those should not remove your 'logged-in' cookie.


Profile data can be removed or not recorded in several ways;

  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings; (In the address bar,type about:preferences#privacy<enter>)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers
    Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.
more options

Выбранное решение

joshandjosh92 said

FredMcD said

At the bottom of the page, turn on Clear History When Firefox Closes.

At the far right, press the Settings button. Turn on ONLY

Cache and Form And Search History leaving the others off.

The only thing I do different from that is have browsing and download history checked in the settings box. Is that causing the problem?

Actually, yes. Firefox recently enabled a new form of protection against first-party tracking cookies. They get purged if you haven't visited the site for 30-45 days. Firefox computes the last visit date from -- you guessed it -- your history.

Assuming you want to keep clearing history, you probably need to turn off this new feature for now (until they come up with another approach):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste purge and pause while the list is filtered

(3) Double-click the privacy.purge_trackers.enabled preference to switch the value from true to false

Please let us know whether that makes any difference for you.