Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Yahoo!, AOL & 3rd-Party Applications - Popping Mail

  • 16 ответов
  • 1 имеет эту проблему
  • 62 просмотра
  • Последний ответ от firefox1078

more options

I pop email from an AOL email account and a Yahoo! email account. As some T-bird users are no doubt aware, Verizon/Yahoo!/AOL have decided to complicate life.

I was afraid to delete and recreate an account in T-bird (as directed by both Yahoo! and AOL) b/c I knew completely new profiles would be created. So I was going to opt for that so called, "single-use password." I figured that way I wouldn't loose all my mail, settings and mail filters, or be forced to have to recreate what was set up years ago, and has been continually built upon since then.

On AOL, T-bird is not in the list of email clients in that single-use password generator. There is an "other app" choice, but when you clik on it, the field is simply populated with "Other App." Yet, when you hit the "Generate" button, a message pops up advising, "Please specify your app password first." I dunno what the hell THAT even means... so I guess that "single-use password" for AOL is out of the question since their "generator" isn't working properly.

On Yahoo!, the process starts out the same, but you can at least type in the name of the "other app" b/c again, T-bird is not in the list. After typing in T-bird and clikking on "Generate," a 16-character password appears. Users are then presented with a "generic" set of instruction which advise to go "find the screen where you enter your Yahoo! account username and password." You are then allegedly able to enter that 16-character password into the password field.

How to use this app password

   1.  Go to the settings section of your app
   2.  Find the screen where you enter your Yahoo account username and password
   3.  Copy the app password above and paste it into the password field

Thing is... I can't find that password field. So... 1. Has anyone else run into the issue with the PW generator on AOL, and if so, what did you do? 2. How do I find the password field in T-bird to even apply that single-use pw for my Yahoo! and AOL accounts? 3. How do I tell Verizon/Yahoo!/AOL to go take a flying leap? Okay, okay...forget that question...LOL

I don't want to lose all my mail, settings (in both mail AND calendar), and mail filters!

Thank in advance for any help.

I pop email from an AOL email account and a Yahoo! email account. As some T-bird users are no doubt aware, Verizon/Yahoo!/AOL have decided to complicate life. I was afraid to delete and recreate an account in T-bird (as directed by both Yahoo! and AOL) b/c I knew completely new profiles would be created. So I was going to opt for that so called, "single-use password." I figured that way I wouldn't loose all my mail, settings and mail filters, or be forced to have to recreate what was set up years ago, and has been continually built upon since then. On AOL, T-bird is not in the list of email clients in that single-use password generator. There is an "other app" choice, but when you clik on it, the field is simply populated with "Other App." Yet, when you hit the "Generate" button, a message pops up advising, "Please specify your app password first." I dunno what the hell THAT even means... so I guess that "single-use password" for AOL is out of the question since their "generator" isn't working properly. On Yahoo!, the process starts out the same, but you can at least type in the name of the "other app" b/c again, T-bird is not in the list. After typing in T-bird and clikking on "Generate," a 16-character password appears. Users are then presented with a "generic" set of instruction which advise to go "find the screen where you enter your Yahoo! account username and password." You are then allegedly able to enter that 16-character password into the password field. How to use this app password 1. Go to the settings section of your app 2. Find the screen where you enter your Yahoo account username and password 3. Copy the app password above and paste it into the password field Thing is... I can't find that password field. So... 1. Has anyone else run into the issue with the PW generator on AOL, and if so, what did you do? 2. How do I find the password field in T-bird to even apply that single-use pw for my Yahoo! and AOL accounts? 3. How do I tell Verizon/Yahoo!/AOL to go take a flying leap? Okay, okay...forget that question...LOL I don't want to lose all my mail, settings (in both mail AND calendar), and mail filters! Thank in advance for any help.

Выбранное решение

No need to remove accounts or use an app password. Change the authentication method to OAuth2 on the incoming servers in Server Settings, and the outgoing in Tools/Account Settings, Outgoing Server (SMTP), at the bottom of the left pane of Account Settings, ensure that cookies are allowed in TB Options/Privacy, remove the passwords in Options/Security/Passwords/Saved Passwords, restart TB, and enter the regular account password in the OAuth browser window when prompted.

Прочитайте этот ответ в контексте 👍 2

Все ответы (16)

more options

Выбранное решение

No need to remove accounts or use an app password. Change the authentication method to OAuth2 on the incoming servers in Server Settings, and the outgoing in Tools/Account Settings, Outgoing Server (SMTP), at the bottom of the left pane of Account Settings, ensure that cookies are allowed in TB Options/Privacy, remove the passwords in Options/Security/Passwords/Saved Passwords, restart TB, and enter the regular account password in the OAuth browser window when prompted.

more options

sfhowes... thank you for your reply. I do have another question however.

You indicate that I must allow cookies. I always "Accept cookies from sites," but for "Accept third-party cookies," that is set to "Never."

Must I accept third-party cookies also? And if so, must I continue to do so after I have finished setting up T-bird in order to get my email, or can I then return the setting for third-party cookies back to "Never?"

more options

sfhowes said

No need to remove accounts or use an app password. Change the authentication method to OAuth2 on the incoming servers in Server Settings, and the outgoing in Tools/Account Settings, Outgoing Server (SMTP), at the bottom of the left pane of Account Settings, ensure that cookies are allowed in TB Options/Privacy, remove the passwords in Options/Security/Passwords/Saved Passwords, restart TB, and enter the regular account password in the OAuth browser window when prompted.

Brilliant, thank you.

So much less stress than trying to ensure all saved emails were not lost. But why was this a secret. The Yahoo instructions do not give this option, neither does the Thunderbird page we're directed to from Yahoo. I did have to upgrade Thunderbird to find the OAuth2 option in the incoming server section, which required imputting all my passwords for all accounts, as teh upgrade for some reason failed to bring them with it.

Thanks again.

more options

" and the outgoing in Tools/Account Settings, Outgoing Server (SMTP), at the bottom of the left pane of Account Settings,"

What should this be changed to? From the message above it seems OAuth2, but my version TB 68.12.1 in outgoing server (SMTP)/ edit/security/authentication/authentication method has drop down options of normal password encrypted password Kerberos/GSSAPI NTLM

TIA

more options

Perhaps I should have added that I am using pop.csi.com - maybe I should move to pop.aol.com? Do both support OAuth2?

Thanks again

more options

FitAintBrkDntFxIt said

sfhowes... thank you for your reply. I do have another question however. You indicate that I must allow cookies. I always "Accept cookies from sites," but for "Accept third-party cookies," that is set to "Never." Must I accept third-party cookies also? And if so, must I continue to do so after I have finished setting up T-bird in order to get my email, or can I then return the setting for third-party cookies back to "Never?"

I don't think you have to accept 3rd-party cookies, but I haven't tested it. The important setting is to allow cookies from at least *.aol.com, even if you wish to block all others.

more options

ansondave said

" and the outgoing in Tools/Account Settings, Outgoing Server (SMTP), at the bottom of the left pane of Account Settings," What should this be changed to? From the message above it seems OAuth2, but my version TB 68.12.1 in outgoing server (SMTP)/ edit/security/authentication/authentication method has drop down options of normal password encrypted password Kerberos/GSSAPI NTLM TIA

There seems to be a bug where OAuth2 doesn't appear in the authentication menu for some providers. It does appear here for my AOL account, but if it doesn't, open Config. editor (under Tools/Options/General/Advanced in 68, Options/General in 78), enter auth in the search box. Right-click the preference mail.smtpserver.smtpN.authMethod, where N is 1,2,or 3... depending on the account, Modify, and change the value to 10. That will set the authentication to OAuth2.

more options

sfhowes said

I don't think you have to accept 3rd-party cookies, but I haven't tested it. The important setting is to allow cookies from at least *.aol.com, even if you wish to block all others.

Ohhhh-KAY!! We're in business. I did not allow 3rd party cookies... so as you suggested, as long as cookies were allowed for Yahoo! and AOL, that's all that's needed. I followed the remainder of your instructions, then closed TB, relaunched and checked email. I received an email from Yahoo! and from AOL advising that there was a log in to the accounts.

After finishing the process I closed and relaunched TB again to check email to see if I was going to have to sign in again. All went well. It's like nothing ever happened.

Thanks sfhowes. I'll post back in a couple of days - after "dooms day" has passed (20th)...LOL... to let ya know if Yahoo! and AOL continue to play nice. I will at that time also mark this issue as solved.

Hope everyone else who joined this conversation is able to get everything worked out.

more options

sfhowes said

I don't think you have to accept 3rd-party cookies, but I haven't tested it. The important setting is to allow cookies from at least *.aol.com, even if you wish to block all others.

Ohhhh-KAY!! We're in business. I did not allow 3rd party cookies... so as you suggested, as long as cookies were allowed for Yahoo! and AOL, that's all that's needed. I followed the remainder of your instructions, then closed TB, relaunched and checked email. I received an email from Yahoo! and from AOL advising that there was a log in to the accounts.

After finishing the process I closed and relaunched TB again to check email to see if I was going to have to sign in again. All went well. It's like nothing ever happened.

Thanks sfhowes. I'll post back in a couple of days after "dooms day" has passed (20th)...LOL... to let ya know if Yahoo! and AOL continue to play nice. I will at that time also mark this issue as solved.

Hope everyone else who joined this conversation is able to get everything worked out with their email also.

more options

sfhowes - thanks for the quick feedback, thats very helpful - I'll try it out and see how it goes.

Regards

more options

Hi sfhowes, I tried the following suggestion you offered (included below) to enable my outbound SMTP server setting to OAuth2, and I did not have the options you outlined.

"There seems to be a bug where OAuth2 doesn't appear in the authentication menu for some providers. It does appear here for my AOL account, but if it doesn't, open Config. editor (under Tools/Options/General in 78), enter auth in the search box.

Here is where I got stuck.... I could not locate this option.... "Right-click the preference mail.smtpserver.smtpN.authMethod, where N is 1,2,or 3... depending on the account, Modify, and change the value to 10. That will set the authentication to OAuth2."

The only options I have are connection and certificates. I have attached screenshots for reference. FYI, I am running version 78.4.1

I appreciate any help you can provide. Thanks, Renee

I have another update... I was able to find the config editor option via Tools/Options and typing advanced in the search field.

I made the change as you suggested and the OAuth2 now shows as the authorization method for my outbound.att.net port 465 server. Unfortunately, I am still having an issue and get the following error message.

"Sending of the message failed. The Outgoing server (SMTP) outbound.att.net does not support the selected authentication method. Please change the 'Authentication method' in 'Account Settings | Outgoing Server (SMTP)'."

Any suggestions? Thanks so much! Renee

Изменено reneeschaefer

more options

Type config in the search box, then click Config. editor (see picture) to open a window with the TB preferences. Type auth in the Config. editor search.

more options

Hi sfhowes, Thanks for the quick reply! I was able to successfully make the change to the outbound server config and OAuth2 now is selected.

Unfortunately, I still get the following error message when trying to send an outbound email. "Sending of the message failed. The Outgoing server (SMTP) outbound.att.net does not support the selected authentication method. Please change the 'Authentication method' in 'Account Settings | Outgoing Server (SMTP)'."

I had no problem when I set up the inbound email a few days ago, but I did not have to brute force that one as OAuth2 showed up in the drop down options.

Any suggestions? Thanks so much! Renee

more options

With an AT&T account, use 'normal password' authentication and enter a 'secure mail key' instead of the account password.

https://support.mozilla.org/en-US/questions/1313640

more options

Thank you so much sfhowes! That worked like a charm! I am now able to send and receive emails from my ATT sbcglobal.net email.

Thanks for all your help! It is really appreciated! Renee

more options

OMG THANK YOU!

I just spent an hour on the phone with aol support, and they wanted me to pay for support. The only other option they could offer was to ask Thunderbird support, and that actually worked!

If I didn't have such a low opinion of them, I would try to convince them to fix their misleading doc.

I've had this account 30 years...