Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

Bookmarked sites added to homescreen are opening with their app not ff

  • 2 ответа
  • 1 имеет эту проблему
  • 12 просмотров
  • Последний ответ от Carol

more options

Bookmarked sites such as Instagram that I have pinned to my homescreen (because I really don't like the actual app) are opening with the instagram app instead of firefox. If I open it from the bookmark inside ff it goes to the webpage. i have open the app feature turned OFF on ff settings. how do i fix this?

Выбранное решение

Hello,

I think what you are experiencing is related to something known as a Progressive Web App or PWA. Certain sites, such as Instagram, are programmed by their developers to be PWAs. This allows browsers like Firefox to provide an app-like experience for this website when it is added to the home screen. It is opening in Firefox, it's that Firefox recognizes this website as a PWA, and removes the URL bar/etc and just presents the website, making it feel more like the app, when it is actually just running inside Firefox, just without the Firefox UI around it. You can tell for sure by long pressing on the app's icon in the app switcher. I've attached a screenshot as an example. The logo is Instagram's, but the name of the app is Firefox.

I don't believe there is an option to turn this off.

Прочитайте этот ответ в контексте 👍 0

Все ответы (2)

more options

Выбранное решение

Hello,

I think what you are experiencing is related to something known as a Progressive Web App or PWA. Certain sites, such as Instagram, are programmed by their developers to be PWAs. This allows browsers like Firefox to provide an app-like experience for this website when it is added to the home screen. It is opening in Firefox, it's that Firefox recognizes this website as a PWA, and removes the URL bar/etc and just presents the website, making it feel more like the app, when it is actually just running inside Firefox, just without the Firefox UI around it. You can tell for sure by long pressing on the app's icon in the app switcher. I've attached a screenshot as an example. The logo is Instagram's, but the name of the app is Firefox.

I don't believe there is an option to turn this off.

Изменено Matt

Полезно?

more options

I believe you are correct, however the title of the app in the carousel shows as Instagram not as firefox that may just the nature of the beast (phone brand) . My insta app is in dark mode where the web page is not. I hate it so hopefully there will be a work around soon. And for the hassle of getting to bookmarks now.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.