Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Yahoo intruded and set itself as default search, even though Google was and is still listed as default.

  • 13 ответов
  • 3 имеют эту проблему
  • 249 просмотров
  • Последний ответ от jscher2000

more options

Yahoo intruded and functions as default search, even though Google has been and is still designated as default in the settings. I removed Yahoo from the list of 1-click browsers, but that didn't affect its unwanted function as default search. This began out of the blue several days ago, and I have no idea how. I dislike Yahoo in general and have not been on that site. I'm getting really frustrated!

Все ответы (13)

more options

hi, thank you for the report - there seems to be an increase in malware addons recently that force yahoo search upon users against their will. could you enter about:support into the address bar of firefox, then copy the text contents of that page, paste it to a site like https://dpaste.com/ and provide the link here in a reply?

thank you

more options

Thanks for your reply! But I haven't been able to get anything on about:support -- sorry! I tried a number of times, in the address bar and the search bar, and only got blank new pages. (I'm an older generation user - over 70 - and don't carry in my head the experience and assumptions you do, unfortunately.) I did copy down the full address that came into the address bar when I ran a search for "Firefox," just in case anything there might be helpful. It does show the Yahoo intrusion from the beginning, even though I was searching from my Firefox homepage. Here's the address on dpaste: https://dpaste.com/2HRHFEJFP#

more options

Also, if it means anything, I already ran a full scan by my security, ESET, which found nothing.

more options

thank you, can you try to get into about:support when you launch firefox in safe mode once to provide a log?

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

I think I may have what you wanted. Check https://dpaste.com/2DJ92XD23

Sally

more options

great, can you try (in safemode again) to go to the firefox menu ≡ > add-ons > extensions panel and remove the "New Custom Tab" entry there to see if this can make difference? *fingers crossed*

more options

Done -- that one wasn't even hard to find! I may not get back to this tonight -- I've got other stuff I need to do, and I want to go back and try this fix when I have time if I need it. I'll post back to this page before the day is out tomorrow, and hopefully it will just be to thank you.

Sally

more options

I am another one that has my browser changed to yahoo even though google is the default. I will look around here but if anyone has any more help I sure could use it.

more options

I am missing something here trying to follow instructions so I will check back later.

more options

Just in case someone happens by I finally tried "refresh firefox" and it fired the problem.

more options

Hi, Tried all of the above with no luck. The Dpaste links don't work and menu ≡ > add-ons > extensions panel is a blank page. Google is on the search box as the engine when I search but the results are all Yahoo. I have checked the settings choices of search engine too and Yahoo isn't even on there. I wouldn't mind but it is a rubbish engine. Any new suggestions?

Изменено antonyldala

more options

I got hijacked by yahoo also, I think firefox does it on purpose now? I want it to be google.

more options

Dazzlerman said

I got hijacked by yahoo also, I think firefox does it on purpose now? I want it to be google.

It's not on purpose. One possible culprit would be an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

If the Add-ons page is blank or blocked then you need to restart Firefox in its Safe Mode to access the page. Either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Can you regain control of search in your Firefox?

Изменено jscher2000