Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

Drafts are Saving to Archives Folder

  • 9 ответов
  • 1 имеет эту проблему
  • 9 просмотров
  • Последний ответ от Stans

more options

Hello all,

I have a problem.

I have set up my email to keep draft messages in "Drafts" folder on Local Folders. Auto save is also set to keep Auto Save draft messages in "Drafts" folder on Local Folders.

However, all drafts are saving into the Archives folder.

I am not sure what to do next to correct this issue.

I hope you can help.

Приложенные скриншоты

Все ответы (9)

more options

Looks like you already have those folders created under the Local Folders account. Why don't you set those settings to Other then select the respective local folders?

Полезно?

more options

I tried that. It does not work. The Drafts are saved in the Archive folder.

Полезно?

more options

Check if the right paths are saved in Config Editor. For templates, use the search term stationery_folder and draft_folder for drafts. You will see entries for each id (account). Check the stored string value to confirm that the right URI paths are saved. If they are correct, and Tbird is not abiding by them, you may have to start afresh with a new profile.

Полезно?

more options

Stans, This is the string value in each field: mailbox://nobody@Local%20Folders/Drafts

What should it be?

Полезно?

more options

"may have to start afresh with a new profile"

How do I do this without losing all of my emails and setups? I have 11 imap accounts and 2 pop accounts that I have set up in Thunderbird.

Полезно?

more options

cporan said

Stans, This is the string value in each field: mailbox://nobody@Local%20Folders/Drafts What should it be?

That value is for the Drafts folder of the special Local Folders account, and the name of the parameter is mail.identity.default.draft_folder

Each account has a parameter named like so mail.identity.id1.draft_folder and the value should be a URI to that account's Drafts folder. For IMAP accounts, the URI looks like imap://stans*****%40gmail.com@imap.gmail.com/Drafts. When you right-click a folder and open its Properties dialog, you will see its URI in the Location field. To determine the id number assigned to each of your accounts, so that you can tell which parameter entry belongs to which account, use the search term useremail in Config Editor. This will give you a nice list that you can screenshot and refer to, so that you don't mix up those settings.

Before you go to all that trouble, try resetting each account's parameter. This will clear their string values, then you can simply change the folder settings via Account Settings without having to mess with Config Editor.

Полезно?

more options

Perhaps that is the problem. I don't think so though. I want all of the drafts to be kept in the same drafts folder in the local folder. This is why they all have the string value of mailbox://nobody@Local%20Folders/Drafts.

Полезно?

more options

Wow, I just discovered something.

I keep the view of my folders as "Unified"

However, the Unified Drafts folder does not roll up the Drafts - Local Folders which is shown as one of its subfolders.

But, the Drafts-Local Folder shows its contents in the Archives folder, even though it is not shown as a subfolder there.

What could cause this?

Полезно?

more options

I have no idea why that is the case, but the last time I had trouble with unified folders, I opened the profile folder > Mail > smart mailboxes subfolder and deleted everything in there while Tbird is not running, then restarted Tbird and updated each Unified folder's search scope. Since you're only having problems with the drafts and archives, you could try deleting only their respective files inside the smart mailboxes folder and relaunch Tbird.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.