Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Single URL sites are redirecting to Google Search

  • 1 ответ
  • 1 имеет эту проблему
  • 121 просмотр
  • Последний ответ от DetectiveShrek

more options

I use Firefox for my office, and there are several URLs internal to my company that work with a single word.

For example: "xyz/12345" is the same as "http://xyz.company.com/12345" which opens the resource 12345.

This used to work absolutely fine until the latest update.

Current: 78.0.1 (64-bit) on MAC OS 10.15.5

Now, xyz/12345 searches google instead of navigating to the website. I do still need google search on the browser bar, as I use it frequently as well.

Having to type out http://xyz/12345 is an overhead that I would like to avoid.

Please suggest if there are any workarounds that could be used to get this working again.

I use Firefox for my office, and there are several URLs internal to my company that work with a single word. For example: "xyz/12345" is the same as "http://xyz.company.com/12345" which opens the resource 12345. This used to work absolutely fine until the latest update. Current: 78.0.1 (64-bit) on MAC OS 10.15.5 Now, xyz/12345 searches google instead of navigating to the website. I do still need google search on the browser bar, as I use it frequently as well. Having to type out '''http://'''xyz/12345 is an overhead that I would like to avoid. Please suggest if there are any workarounds that could be used to get this working again.

Выбранное решение

Posted the same query to reddit.com/r/firefox and got the answer.

Go to about:config and change the value of browser.fixup.dns_first_for_single_words to True.

This fixed the problem.

Прочитайте этот ответ в контексте 👍 0

Все ответы (2)

more options

Выбранное решение

Posted the same query to reddit.com/r/firefox and got the answer.

Go to about:config and change the value of browser.fixup.dns_first_for_single_words to True.

This fixed the problem.