Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to really stop autoplaying videos

  • 6 ответов
  • 1 имеет эту проблему
  • 13 просмотров
  • Последний ответ от useruser

more options

I can't stop autoplaying videos in FF77. I disabled them in the options, and also set

media.autoplay.blocking_policy = 2

and the videos still play automatically after restarting FF.

Все ответы (6)

more options

The settings for blocking video autoplay are in the regular Firefox settings page. They no longer need to be manipulated through the about:config page, as was the case when this feature was first launched. Furthermore, the preference that you are modifying is not the correct preference anyway.

Go to the Firefox settings page and select Privacy & Security on the left side. Scroll down to the Permissions section and press the Settings... button next to Autoplay. You can change the default setting and modify any exceptions that have been added.

Firefox provides three options for blocking videos from autoplaying:

  • Allow Audio and Video: Videos will not be blocked.
  • Block Audio: Only videos with sound will be blocked. Muted videos will start automatically.
  • Block Audio and Video: All videos will be blocked.

You can learn more about this Firefox feature from the Allow or block media autoplay in Firefox page.

Hope this helps.

Полезно?

more options

I tried that and it still doesn't work. The videos still autoplay.

Полезно?

more options

Did you check the Autoplay setting in "Tools -> Page Info -> Permissions" for this website ?

Do you see the autoplay icon in the location bar and the play/mute icon on the tab ?

Полезно?

more options

Yes, I've tried that. In this instance, Autoplay is set to default, which is to block autoplaying video and audio. The location bar icon is set to blocked also, and the media still autoplays.

Полезно?

more options

Try this pref setting on the about:config pageṠ:

Изменено cor-el

Полезно?

more options

I've just tried that, and restarted FF, and the problem still exists. In Page Info, the source of the video is a blob file. I'm using Privacy mode.

Изменено useruser

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.