Поиск в Поддержке

Избегайте мошенничеств со службой поддержки. Мы никогда не просим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Сообщить о нарушении».

Learn More

All http sites are redirecting to https and display "potential security risk ahead" error

  • 14 ответов
  • 4 имеют эту проблему
  • 1777 просмотров
  • Последний ответ от Roland, NK2U

more options

In my browser whenever I am opening non secure sites that are only like http://example.com it redirects to https://example.com and display the error. "Warning: Potential Security Risk Ahead" error. I could not know how to fix this error. This is happening all of a sudden. I could not find a way to fix this error.

Приложенные скриншоты

Выбранное решение

vpp.nagaraju1234 said

FredMcD said

Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

No, the issue is not there when I do this.

Thanks for your help. After I removed the extension DuckDuckGo essential that I installed long time ago was causing the problem. I removed it and everything works fine.

Прочитайте этот ответ в контексте 👍 0

Все ответы (14)

more options

hello

vpp.nagaraju1234...

step:1

Clear all cookies, site data and cache

  • Click the ≡ menu button. and select Options. Preferences.
  • Select the Privacy & Security panel and go to the Cookies and Site Data section.
  • Click the Clear Data… button. The Clear Data dialog will appear. ...
  • Click Clear.


step:2

Turn off / Disable Firefox “Warning: Potential Security Risk Ahead

Type about:config in the address bar and press Enter. 1) A warning page may appear. Click Accept the Risk and Continue.

2) Change the following settings:

  • security.insecure_field_warning.contextual.enabled = false
  • security.certerrors.permanentOverride = false
  • network.stricttransportsecurity.preloadlist = false
  • security.enterprise_roots.enabled = true

3) Restart Firefox to apply changes.

i hope resolved your problem then reply back to me.

thank you and regards,

Arman

more options

Press the 'Advanced' button. What does it say?

more options

This is what is says when I click advanced

more options

ARMAN KHAN said

hello vpp.nagaraju1234... step:1 Clear all cookies, site data and cache
  • Click the ≡ menu button. and select Options. Preferences.
  • Select the Privacy & Security panel and go to the Cookies and Site Data section.
  • Click the Clear Data… button. The Clear Data dialog will appear. ...
  • Click Clear.
step:2 Turn off / Disable Firefox “Warning: Potential Security Risk Ahead Type about:config in the address bar and press Enter. 1) A warning page may appear. Click Accept the Risk and Continue. 2) Change the following settings:
  • security.insecure_field_warning.contextual.enabled = false
  • security.certerrors.permanentOverride = false
  • network.stricttransportsecurity.preloadlist = false
  • security.enterprise_roots.enabled = true
3) Restart Firefox to apply changes. i hope resolved your problem then reply back to me. thank you and regards, Arman

Can I know why I need to do those changes? Are they the default settings because I did not change them. I tried to clear the cookies and cache but it still persists

more options
  • MOZILLA_PKIX_ERROR_MITM_DETECTED
  • uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN
  • configured their website improperly

How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER


There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connection certificates and send their own.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

Websites don't load - troubleshoot and fix error messages

http://kb.mozillazine.org/Error_loading_websites

What do the security warning codes mean

more options

FredMcD said

  • MOZILLA_PKIX_ERROR_MITM_DETECTED
  • uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN
  • configured their website improperly
How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connection certificates and send their own. https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message Websites don't load - troubleshoot and fix error messages http://kb.mozillazine.org/Error_loading_websites What do the security warning codes mean

I think you did not understand what was my issue. The issue is that the sites having only http in url are redirected to https and show the security risk warning. Sites having https in url are loading properly.

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

FredMcD said

Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

No, the issue is not there when I do this.

more options

Выбранное решение

vpp.nagaraju1234 said

FredMcD said

Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

No, the issue is not there when I do this.

Thanks for your help. After I removed the extension DuckDuckGo essential that I installed long time ago was causing the problem. I removed it and everything works fine.

more options

That was very good work. Well Done.

more options

When will this bug be fixed. I can't get to the site http://reversebeacon.net/ It keeps putting HTTPS. I want to get to the site but Firefox won't let me! This is nerve wracking!

more options

The crazy thing is, I never thought I'd have to use Microsoft Edge to view the site http://reversebeacon.net/ but that's what I have to do now.

more options

Hi Roland, NK2U

No problem with accessing reversebeacon.net via the HTTP protocol, even with HTTPS-Only enabled Firefox allows to continue with HTTP.. If Firefox switches to HTTPS and refuses to use HTTP then you either have an extension or security software forcing a secure connection.

more options

OK, I did not realize that there was a new option to turn off HTTPS. I found it and turned it off, now everything is great! Thanks!