Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Problem in DNS over HTTPS

  • Нет ответов
  • 1 имеет эту проблему
  • 1 просмотр
more options

I set DNS in my router to Cleanbrowsing adult filter which also forces safe search in search engines. When I activated DoH in firefox (mode 2) I find that safe search in Google still forced. Dns leak test shows that I'm using Cloudflare and I can visit any site with no restriction. I cleared history and flushed DNS cache. Bing search does not have this problem and i can turn off safe search in it. Using DoH mode 3 solve my problem and allows me to turn off safe search in Google, but I want to use the default mode 2 which is supposed to use DoH first. After testing I found what it may cause the problem. I was setting my home page to Google. I set it to Firefox home page again and now the problem has gone. So I think that Firefox loads Google home page (using router DNS) before it loads DoH settings. I don't know if I'm right, but you can investigate this problem.

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.