Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Tab Crash

  • 8 ответов
  • 1 имеет эту проблему
  • 15 просмотров
  • Последний ответ от AMAN ARYAN

more options

All I'd like to know is how to completely disable the ability of tabs crashing for any reason at all, permanently. I'd very seriously would rather the computer freeze or risk hardware damage, whatever pref(s) listed and unlisted I need to enable or disable I can put in lock file or anything. -Thanks!

All Replies (8)

more options

Gah-Your-tab-just-crashed https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help

We have recently seen multiple reports that Bitdefender is causing issues with tab crashes in Firefox 73.

It looks that Bitdefender has pushed an update to address this issue 21 Feb 2020

Helpful?

more options

Appreciate it, it might help others. I'm not using Bitdefender or any antivirus or whatnot. I'm on Linux. I don't care what's causing it, (I do know using inspector crashes any and every page no matter what) But I seriously want it to just let whatever is happening, happen. Even if my computer freezes or bursts into flames. I don't want it to protect anything. I want the crash, "feature," or whatever, completely disabled permanently. -TY

Helpful?

more options

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most recent 7 - 10 Submitted crash reports, and copy them. Now go to the reply box and paste them in.

aboutcrashesFx57

For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

Helpful?

more options

Okay, Will do. But so the system and everyone is clear or whatever, this is *not* solved until someone tells me how I can disable the browser's ability to crash the tabs, and instead let it do whatever it's trying to prevent.

Helpful?

more options

Hi guyfromkcmo:

You wrote: "All I'd like to know is how to completely disable the ability of tabs crashing for any reason at all, permanently."

There is no way to do that in Linux, Windows or MacOS or any software system for that matter. To do that you'd have to ensure the entire operating system from crashing which is impossible given the state of the art in computer science! (unless i'm totally missing what you are saying which is possible :-) if so please clarify)

Cheers!

...Roland (developer of software and computer scientist since 1977 because i have no other skills :-) !)

Helpful?

more options

Happy to clarify, I'm talking about the relatively new feature (maybe a couple years now, maybe longer...) that isolates the tab to "protect" the other tabs, the browser, the computer, etc, from whatever, memory bloat, or something that would potentially freeze the whole system, I don't want it doing that, I want it to *not* protect my system by crashing just that tab, in essence, I'd rather my entire computer crash than that tab.

Helpful?

more options

Okay, so near I can tell from this https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Multiprocess_Firefox, I'm basically screwed, unless there's a Pref or add-on that controls the how or when the WebContent process just mysteriously crashes when I'm trying to use inspector in tools to block specific garbage in pages with uBlock Origin or Adblock Plus (where uBlock Origin doesn't work right like on YouTube), and any Greasemonkey scripts (FB Purity and Social Fixer) trying to work in Facebook will just crash it too. So, great... This is the type stuff that has me usually using the fork Basilisk, and FF only when I have a gun to my head needing the latest Widevine to watch Twitch or something.

Helpful?

more options

Chosen Solution

hi, this should be a workaround to avoid the tab crashes: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.wmf.vp9.enabled. double-click it and change its value to false, then restart firefox once.

Helpful?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.