Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

uBlock origin (possibly other addons) installs but does not work - Firefox 68.8.0ESR on Debian 10

  • 3 ответа
  • 1 имеет эту проблему
  • 10 просмотров
  • Последний ответ от no_face

more options

I'm running a brand new install of Debian. Initially the install comes with Firefox version 68.7.0 ESR. After setting up my Firefox preferences, I tried installing uBlock origin. The install seemed to go fine, but I noticed that the uBlock button does not appear to the right of the address bar by the bookmarks/sidebars/firefox account buttons. I went on Youtube to check to see if it was actually blocking ads and it is not blocking. When I open the addons page to check if it is there (Tools > Addons) it shows uBlock origin as an enabled addon.

I opened synaptic to see if there is an upgrade version available and saw that there was (Version 68.8.0 ESR). I went ahead and installed the upgrade, but there is no improvement, still seeing ads on Youtube. I removed it and reinstalled, but also no improvement. I've been searching google for answers but other than references to the issues last year with addons being broken I am not finding anything helpful.

Any ideas on how to fix this? Your help is appreciated.

All Replies (3)

more options

If you go into the Customize mode, is the button available either on the "overflow" list or in the available buttons? Customize Firefox controls, buttons and toolbars

If it isn't available in Customize, either, or disappears when you close out of Customize, it could be:

One possible reason for this is if you are using a private window and the extension is not allowed to run in private windows.

To check on that:

(A) Open the Add-ons page, either

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

(B) In the left column of the Add-ons page, click Extensions.

(C) Find OneNote Clipper uBlock Origin on the right side.

If there is no purple mask icon next to the name:

(D) Click the extension name to open its Details panel, and scroll down to where you find this option and click the bubble for Allow:

Run in Private Windows     (*) Allow  (_) Don’t Allow

Was that it?

Изменено jscher2000


more options

Hi jscher2000, thanks for your reply.

The button was not present in the overflow list, or in the available buttons menu in Customize mode.

Now, this is going to sound totally bizarre, but...

I went to the addons page as you suggested. uBlock was not set to run in Private Windows, so I set it to Allow. When I clicked the back button, uBlock completely disappeared from the list of addons...

So, I went back to the addons page and searched uBlock origin. As far as the page was concerned, it thought uBlock origin wasn't installed at all. I reinstalled it, and when the window popped up that it had installed, selected the check box for "Allow to run in private windows". It now shows the uBlock origin icon in the toolbar. I went to Youtube quick and it does appear to be blocking banner ads and ads on videos. Fixed I guess? But the bad kind of fixed - no idea what fixed it or what is going on.

I'm going to try installing HTTPS everywhere now and see if that works OK. Is there any other info you'd like or suggestions from here?


more options

Installed HTTPS Everywhere and did the same thing - selected the "Allow to run in private windows" checkbox, and the icon showed up in the toolbar and, near as I can tell, is working. Very strange for me. I am a newish linux user and can't remember ever having this problem on Windows-based installs or non-ESR versions running on other distros. ¯\_(ツ)_/¯


Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.