Поиск в Поддержке

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

text encoding not refreshing when opening email

  • 2 ответа
  • 1 имеет эту проблему
  • 5 просмотров
  • Последний ответ от fordpinto

more options

Observed a problem with the text encoding not refreshing.

When opening an email, there are characters that is not consistent with a typical text email. When I go to VIEW > TEXT ENCODING and select UNICODE, the email display properly. When I go back into the same email, I have to do the same procedure.

One point to make on the above procedure. Sometimes the UNICODE is shown as being already selected - other times not. Regardless, I select UNICODE even if it is shown as selected.

Additionally, when I go to OPTIONS > DISPLAY > FORMATTING > ADVANCED, I tried different variations for the default text encoding for incoming & outgoing emails. Every variation I tried still does not fix my original problem.

Any help on this matter would be greatly appreciated. Thanks (in advance)...

Все ответы (2)

more options

The problem is in the formatting of the email as a general rule, which is why Thunderbird does not guess. The text formatting to be used in properly formatted email is actually defined in the message, either the header, message body or both.

For example reply email from this forum contain the following at the beginning of the text and HTML parts of the message body.

Content-Type: text/html; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit

Do your problem email contain this information?

Полезно?

more options

Hello Matt,

I pasted the first three lines from a given problem email: <meta content="text/html; charset=UTF-8" http-equiv="Content-Type"> In going thru the remainder of the email, I did not see any '''MIME-Version''' nor '''Content-Transfer-Encoding '''text.

Полезно?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.