Search Support

Old version of firefox that wont update when installed on new computers

  • 12 ответов
  • 1 имеет эту проблему
  • 10 просмотров
  • Последний ответ от Seburo

more options

Hello firefox community

Im hoping you can help with this request, here goes my issue is as following: we need firefox version 6.0.1 64bit that wont auto update, as we have some products where the webinterface only works with this browser and this version and early.

Is there a way to ensure this version wont update? like when you run the setup you can use a -noupdate command etc.

Thanks in advance

FYI, we cannot change the interface so this is the only way to ensure access to these products.

All Replies (12)

more options

Joe said

we need firefox version 6.0.1 64bit that wont auto update

Are you sure about the version number? That is older than old.

How do you completely turn off update checks in Firefox v64?
You can use a policies.json file to disable updates for all users.
https://github.com/mozilla/policy-templates/blob/master/README.md
or
https://winaero.com/blog/disable-updates-firefox-63-above/

Helpful?

more options

We are in need of this version, to ensure that clients can access the interface (the interface will not be updated according to the manufacturer )

The idea that i'm looking for is a copy of Firefox, where i can send include it with the product. and it wont update etc. ive been trying to read up on the .json files, but so far i've not managed to get it to work.

Helpful?

more options

I'm afraid that 64bit Firefox is available since version 42. Everything below is 32bit only for Windows.

In such an old version it was enough to remove update URL in about:config. It even doesn't include the Maintenance Service, so it should be straightforward.

Helpful?

more options

TyDraniu said

I'm afraid that 64bit Firefox is available since version 42. Everything below is 32bit only for Windows. In such an old version it was enough to remove update URL in about:config. It even doesn't include the Maintenance Service, so it should be straightforward.

Thanks, i will try and see if this can be useful. when advising clients in this mess regarding Firefox (in regards to accessing the interface, not Firefox as a product)

There has to be a way to ensure a setup where it cant update itself without to much tinkering. As some of the users needing this, can barely install Firefox yet along change settings.

Helpful?

more options

What interface requires a browser from 2011?! Seriously. It's 2020.

Are your users on Windows? Rather than cripple their main browser, they could consider using a self-contained "Portable" installation of Firefox for this special purpose:

https://sourceforge.net/projects/portableapps/files/Mozilla%20Firefox%2C%20Portable%20Ed./Mozilla%20Firefox%2C%20Portable%20Edition%206.0.2/

Helpful?

more options

jscher2000 said

What interface requires a browser from 2011?! Seriously. It's 2020. Are your users on Windows? Rather than cripple their main browser, they could consider using a self-contained "Portable" installation of Firefox for this special purpose: https://sourceforge.net/projects/portableapps/files/Mozilla%20Firefox%2C%20Portable%20Ed./Mozilla%20Firefox%2C%20Portable%20Edition%206.0.2/

It's not in regards to windows, its a product where the interface only works with Firefox and only up to this version. the status is that they will not update their interface, so we have to downgrade to ensure access to said product.

Helpful?

more options

Considering how old Firefox 6 is, is there any scope for you to feedback to the people that made the service that requires it to see if this requirement can be updated?

Helpful?

more options

Seburo said

Considering how old Firefox 6 is, is there any scope for you to feedback to the people that made the service that requires it to see if this requirement can be updated?

They have been informed and have made it clear that it works with a downgrader / old version of Firefox. We do INFORM them that this version is only for said product, and should only be used on a PC with no internet access.

Helpful?

more options

If you need the 6.0.1 64 bit version for linux, it and windows versions are available at

https://ftp.mozilla.org/pub/firefox/releases/6.0.1/

Select your OS and then your language fo find the correct file to install. This version is so old, I am not sure whether it has an update switch available.

DO NOT USE ON INTERNET ENABLED SYSTEMS. THERE IS NO SUPPORT FOR ANTIVIRUS OR OTHER SECURITY PROTECTIONS.

Helpful?

more options

You can use autoconfig.cfg to lock specific prefs to disable updating if necessary. - - - - You can use the autoconfig.cfg file in the Firefox installation folder to initialize (set/lock) preferences and run privileged JavaScript code.

To use Autoconfig, place two files into the Firefox directory.

  • on Windows, they go in the same directory where Firefox is installed
  • on macOS, they go into the Contents/Resources directory of the Firefox.app

The autoconfig.js file that specifies to use autoconfig.cfg is placed into the "defaults\pref" directory where the channel-prefs.js file is located.

//
pref("general.config.filename", "autoconfig.cfg");
pref("general.config.obscure_value", 0);

The autoconfig.cfg file is placed at the top level of the Firefox directory.

These functions can be used in autoconfig.cfg:

defaultPref();	// set new default value, requires special data: format for localized prefs
pref();	// set pref, allow changes in current session
lockPref();	// lock pref, disallow changes
  • autoconfig.cfg and autoconfig.js need to start with a comment line (//)
  • autoconfig.js needs to use Unix line endings (LF instead of CR/LF)

See also:

Helpful?

more options

A big thank you, to everyone who gave helped. the information used here will help in some way or another, problem is solved.

Helpful?

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

Helpful?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.