Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

I foolishly upgraded firefox and now the new version has tabs again. How do I get rid of them?

  • 6 ответов
  • 1 имеет эту проблему
  • 2 просмотра
  • Последний ответ от mike_z

more options

I was happy with firefox 63.0.1 and should not have upgraded, but I did. I seem to remember adding a CSS file to eliminate tabs in 63. How can I eliminate the tabs in the new version that I just upgarded to? Thanks

Выбранное решение

Well...... once again this old man was his worst enemy. Poor typing and in the wrong places caused my problem. GOt it fixed, thank a million for the help, Mike.

Прочитайте этот ответ в контексте 👍 0

All Replies (6)

more options

Helpful?

more options

I found my userchrome.css file and it has

  1. TabsToolbar { visibility: collapse !important; }

in it. But it is not doing what it should. Any help? Thanks

Helpful?

more options

Do I have to change any options or settings to make Firefox look at the CSS file? Mike

Helpful?

more options

That code in userChrome.css should work to hide the Tab bar, so something else might be wrong.

Does other code in the file still work properly --- It is not that difficult to create if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a plain text file with the name (name is case sensitive). In this text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named .txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Helpful?

more options

Well, I've been trying, but the internet here is so busy, it is hard just to get to google.com

I added an extra routine to userChrome.CSS, the one which moves the tab bar down a couple of lines. And I did toolkit.legacyUserProfileCustomizations.stylesheets = true, but it still does not work. Is there a simple item I can add to userChrome.css, like changing the color of something, where I can test it? Also how do I know whether or not the CSS file is actually being looked at? Thanks Mike

Helpful?

more options

Выбранное решение

Well...... once again this old man was his worst enemy. Poor typing and in the wrong places caused my problem. GOt it fixed, thank a million for the help, Mike.

Helpful?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.