Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Bookmarks Toolbar in Fullscreen Mode

  • 7 ответов
  • 1 имеет эту проблему
  • 6 просмотров
  • Последний ответ от Danny6497

more options

Hi,

I prefer Firefox to show bookmarks toolbar in fullscreen mode. In the previous version of Firefox, this can be done by creating a CSS. Refer to the link below: https://support.mozilla.org/en-US/questions/1212156

However, after updating to Firefox 75.0, the CSS method doesn't work anymore. Google searches also returned no result considering the update is recent. That's why I'm writing it here.

Refer to the attachment below as bookmarks toolbar is hidden when hovering to toolbar.

Thank You.

Приложенные скриншоты

Все ответы (7)

more options

Hmm, I tested in "Nightly" (future Firefox 78) and there is a problem with the screen not rolling down under some conditions. This is a minor update. Does it help on yours?

/*
   Override hiding of Bookmarks Toolbar in F11 full screen
   when you roll down the tabs/main toolbar 
*/
:root[inFullscreen="true"] #PersonalToolbar:not([collapsed="true"]) {
  visibility: unset !important;
}
more options

Thank you for reply.

Unfortunately the css doesn't.

I applied the css after upgrading to Nightly 78 but still no luck.

The workaround I found is to use Firefox 68 esr instead. The old css still works.

But thanks anyways.

more options

Sorry, it worked for me. Not sure why it isn't working on yours.

more options

Don't sweat it.

Your css does its job by displaying the bookmarks toolbar but somehow the whole top bar(toolbar, menu etc.) stays unhidden while browsing which is not the expected behavior in fullscreen mode.

more options

Oh, that can be caused by the cursor being in the address bar when going to fullscreen. Sometimes even if you move the cursor in to the document the bars stay rolled down. You may need to press F11 twice in that case.

I am not aware of any other possible causes.

more options

Check in the right-click context menu in the toolbar area that you have enabled "Hide Toolbars".

Note that it is possible that Firefox from the repositories behaves differently.

more options

@jscher2000

I don't think that's the case since I've tried different ways to get it to work including re-enter fullscreen mode. I also tried refreshing Firefox and even do a fresh install just to be sure which only then I chose to install the esr.

But I'm running on esr version now and it's working. So it's fine. I appreciate your help.

@cor-el

Yes I'm pretty sure I've enabled that.

I installed it from the repo so that might explains why it didn't work. Thanks