Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

remove Search with Amazon from address bar suggestions

  • 21 ответ
  • 2 имеют эту проблему
  • 3411 просмотров
  • Последний ответ от mydiylife

more options

Everytime I open the suggestions in the address bar Search with Google or Search with Amazon appear at the top. You cannot remove them by using the 'forget about this site' feature and if you change the browser.urlbar.openViewOnFocus to 'False' you don't get the suggestions. Can you tell me how to permanently remove Search with Google or Search with Amazon from the suggestions. Thank you.

Выбранное решение

Hi gspotts, when you click in the address bar on Firefox 75+, before you start typing anything, the first 8 sites in your "Top Sites" on the built-in Firefox Home / new tab page drop down. So that is where the Amazon search shortcut is coming from.

If you use the built-in Firefox Home / new tab page, you can update your Top Sites list to be more useful. If you do not use that page, or if you use that page but do not use the Top Sites section, you can turn off Top Sites and Firefox will drop down your old list of "frequently/recently used sites" instead. (That was for Firefox 75-77 only)

To edit Top Sites:

Open the Firefox Home / new tab page. If you've changed your home page and new tab page, you can type or paste either of these special internal addresses in the address bar and press Enter to load them:

  • about:home
  • about:newtab

And then see the "Customize your Top Sites" section of this article for how to unpin or remove tiles from the Top Sites section: Customize the New Tab page.

If you turned off the Top Sites section of the page, you can turn that back on for editing purposes. See: Hide or display content in New Tab.


To switch the list by turning off Top Sites (Firefox 75-77 only):

Open the Options / Preferences page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Home.

Then on the right side, under Firefox Home Content uncheck the box for Top Sites.

Success? Let us know how you decide to proceed.

Прочитайте этот ответ в контексте 👍 1

Все ответы (20)

more options

Выбранное решение

Hi gspotts, when you click in the address bar on Firefox 75+, before you start typing anything, the first 8 sites in your "Top Sites" on the built-in Firefox Home / new tab page drop down. So that is where the Amazon search shortcut is coming from.

If you use the built-in Firefox Home / new tab page, you can update your Top Sites list to be more useful. If you do not use that page, or if you use that page but do not use the Top Sites section, you can turn off Top Sites and Firefox will drop down your old list of "frequently/recently used sites" instead. (That was for Firefox 75-77 only)

To edit Top Sites:

Open the Firefox Home / new tab page. If you've changed your home page and new tab page, you can type or paste either of these special internal addresses in the address bar and press Enter to load them:

  • about:home
  • about:newtab

And then see the "Customize your Top Sites" section of this article for how to unpin or remove tiles from the Top Sites section: Customize the New Tab page.

If you turned off the Top Sites section of the page, you can turn that back on for editing purposes. See: Hide or display content in New Tab.


To switch the list by turning off Top Sites (Firefox 75-77 only):

Open the Options / Preferences page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Home.

Then on the right side, under Firefox Home Content uncheck the box for Top Sites.

Success? Let us know how you decide to proceed.

Изменено jscher2000

Полезно?

more options

Whoops, I forgot to add a link to this article on editing Top Sites: Customize the New Tab page.

Полезно?

more options

The article addresses the customizing of Home page or New Tab page. When I left-click on the Address bar (not Search bar which I also have), there used to be 8 most visited sites.

As of today, 2 of them have been replaced with Search with Google (and there is a small pin symbol next to it), and Search with Amazon. Again, this is 8 entries in the left-click drop-down menu in Address bar. Sounds like same problem that Gspotts describes - unwanted suggestions in drop-down menu. These 2 entries are NOT my most visited sites. Heck, I don't even use Search with Amazon - my default search engine is Google and when I want to buy, I open Amazon homepage and search with built-in Search box.

Both my Home and New Tab page are set to Blank Page, the box Top Sites is unchecked.

Полезно?

more options

Did you uncheck Top Sites for the address bar suggestions ?

  • Options/Preferences -> Privacy & Security
    Address Bar: When using the location bar, suggest:
    History
    Bookmarks
    Open tabs
    Top sites

Полезно?

more options

al220011.am said

Both my Home and New Tab page are set to Blank Page, the box Top Sites is unchecked.

Hi al220011.am, as you may recall, Firefox 75 introduced a new behavior to the address bar: when the focus (cursor) moves into the bar, a list of your first 8 Top Sites would drop down automatically.

There was a workaround for Firefox 75-77 to switch that to your classic frequently visited URLs list by disabling the Top Sites section of the new tab page. Sounds like you were using that. That doesn't work any more in Firefox 78.

So you could now turn to cleaning up your Top Sites list. Basically, after you remove pinned items and dismiss any other unwanted sites, it should look very similar to your classic frequently visited URLs list -- the order is not the same due to some different secret sauce in the ranking between the two lists.

Of course, typing a space in the address bar will still summon the classic list, so that's an alternative to using the more limited Top Sites feature.

Полезно?

more options

The answer above it wrong. Here's how you fix it:

Click on the tools bar and drop down to options (about:home NO LONGER works)

On the left select SEARCH (this is a search options bug, Home has nothing to do with it)

Go down to 'one click search engines'

Select 'Amazon.com'

Select remove.

Close all your tabs, close your browser, wait a minute or two, then restart. That fixes it.

Изменено vanstry

Полезно?

more options

Hi vanstry, a lot of effort goes into making the articles a good reference, so I usually do not copy/paste those. But let's see where you're getting stuck.

Do you want to:

(A) Edit the list of sites that appear when you click in the address bar, or

(B) Stop a list from appearing when you click in the address bar?

For (A):

The list shows the first 8 Top Sites on the new tab page.

Step #1: Open that page

Usually you can open the new tab page by clicking the + button on the tabs bar. However, if you set Firefox to show a blank page on a new tab, or if you use an add-on to replace the new tab page, then you may need to undo those changes temporarily. Or you could try typing or pasting about:newtab or about:home in the address bar and press Enter to load the page.

Can you get the built-in Firefox Home / new tab page displayed?

Step #2: Edit the Top Sites section

Does your Firefox Home / new tab page show the Top Sites section? If not, you can turn that on from the Options/Preferences page. There's a little gear icon in the right corner of the new tab page to take you to that area. After turning that on, either reload the new tab page or open a new one.

Hover your mouse over the unwanted site and a button should appear with ••• -- click that to open a little menu. You can click Unpin to remove pinned sites, or Dismiss to remove unpinned sites. Does that work on yours?

Полезно?

more options

vanstry said

Click on the tools bar and drop down to options (about:home NO LONGER works) On the left select SEARCH (this is a search options bug, Home has nothing to do with it) Go down to 'one click search engines' Select 'Amazon.com' Select remove. Close all your tabs, close your browser, wait a minute or two, then restart. That fixes it.

Hi vanstry, if you want to remove the Amazon entry pinned on the list that automatically drops from the address bar --

-- you still can do that from the new tab page --

-- and it's a good idea to do that otherwise it that slot on your Top Sites list is wasted.

Полезно?

more options

I'm on 78.0.1 64 bit and the only way I can get rid of Amazon and Google as the "search with" (top two) addresses is to remove them from 1 click search engines. Bing, DuckDuckGo, ebay and wikipedia are also in the 1 click list, but do not show as Amazon and Google do.

I do not see a way to "unpin" them as described in earlier "solutions".

Полезно?

more options

Hi joea, are you using the built-in Firefox Home / new tab page?

If not, you can open that page by pasting either about:home or about:newtab in the address bar and pressing Enter/Return.

Does the page display the Top Sites section?

If not, this article describes how to turn that section back on: Hide or display content in New Tab.

Can you get that section displayed? That is where you unpin unwanted pinned URLs.

Полезно?

more options

At first I thought "about:home or about:newtab" were non functional as I expected a different display.

But by following along I managed to see what you were getting at and resolved the issue. It may be exactly what you described earlier on, but, this time I found what was described.

Thanks.

Полезно?

more options

Apologies this isn't a contribution to solving the problem. It's more about how did it happen to me also? The "Search with Amazon from address bar suggestions" also appeared for me say 10? July.

But I don't use Amazon & I don't think have visted them, certainly not on purpose. So it doesn't reflect visits to websites. I would call it a form of hacking - as in taking information from me I don't want someone else to have & using it to bias my behaviour.

Полезно?

more options

Hi richard.potter1, the Google and/or Amazon search shortcuts were added to the Top Sites section of the new tab page nearly two years ago. If you don't use that section, you may not have encountered them before. The new behavior of dropping down the Top Sites list from the address bar in Firefox 75+ may be the first time many people have really noticed what is in that section.

Earlier replies in this thread show how to remove unwanted search shortcuts from the Top Sites section one by one, and there's also a preference for avoiding search shortcuts in that section:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste searchsh and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

Полезно?

more options

What has just worked for me is

  • Main Menu
  • Preferences
  • Pick Search Preferences
  • There's then a box of "One-Click Search Engines"
  • Pick Amazon and chose Remove

(Apologies if not up to standard way of saying this!)

Still puzzling why Amazon started appearing when I hadn't been there or changed anything...

Полезно?

more options

I am having this same problem. Running Firefox 78.0.2 (64 bit). I was able to unpin Google & Bing on new tab page (by clicking on the 3 small dots, then the drop-down) easily on first try, but not Amazon. I've also tried via F'fox preferences. I've tried both 'dismiss' and 'unpin'. I've closed the browser and waited then opened again. Amazon will not go away! I never ever go to the Amazon site. The only time I did was by mistake yesterday while trying to get rid of it in F'fox Top Search! So I cleared its cookies, and tried all the above again. Please: What am I missing?! PS I do want to keep the Top Sites function, just have the sites that appear there be helpful. Amazon just... annoys me. Period.

Полезно?

more options

Hi mydiylife, is the problem tile the search shortcut that pops @amazon into the address bar when you click it, or a URL to Amazon itself?

I don't know why a shortcut you unpin or dismiss (or both) would refuse to leave. Does it return as a pinned shortcut or is it free-floating in the list?

Do you use Firefox Sync with any other installations of Firefox?

Полезно?

more options

Hi jscher2000 and thanks for your reply I'm only just seeing! It doesn't return as a pinned shortcut, it just stays there. It is the only shortcut that has the pin there even when I'm not hovering over the top right corner's 3 bars. It is always the first of the quick search icons. And as I wrote, I was easily able to get Google & Bing to stop appearing. I don't know the answer to whether or not I use Firefox sync with other installations. I do have Firefox on my smartphone. (And I only just now synced the two, I believe.) When I open Firefox on my phone, my actual top sites show, Amazon does not appear there. Don't think it's relevant that I use DuckDuckGo as my search engine, but in case it is... I am using DDG on my laptop & my phone. Thanks for anything else you suggest or can walk me through! I've attached a desktop screenshot if that's helpful. And my current Firefox version is 79.0 (64-bit).

Изменено mydiylife

Полезно?

more options

You can try to open the Amazon link to create a fresh history entry and then use "Forget About This Site" in the right-click context menu.

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Полезно?

more options

Hi mydiylife, thank you for the screenshot. It doesn't look like a search shortcut, just a site shortcut. Another method for clearing pinned tiles is:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste pinned and pause while the list is filtered

(3) For the browser.newtabpage.pinned preference, either click the trash can on the right end of the row, or double-click it to display an editing field, delete the entire contents, then press Enter or click the blue check mark button to save the change.

If you open a new new tab page, are there any pins, or are they gone?

If that change doesn't stick, the following article lists some of the possible reasons: How to fix preferences that won't save.

Полезно?

more options

Hi jscher2000, and thank you again for responding. Also thanks cor-el. I tried what cor-el suggested first, went back through my history searching for amazon anything (besides searching for these answers here!) and right-clicked to 'forget about this site'. I went all the way through 'over 6 months ago'. (I do 'manage cookies' quite regularly, and am careful with that as well.) Then I received your reply and followed your suggestions as well. I DID do one additions deletion, after nothing changed with trashing 'browser.newtabpage.pinned', and that was since I saw both google & amazon in the bar above that one 'browser.newtabpage.activity-stream.improvesearch.topSiteSearchShortcuts.havePinned' I deleted that as well. (Gulp.) Apparently I needn't have worried, both came back. Once again I successfully unpinned & forgot google, but once again amazon stayed. Currently it has shifted in the 'queue' and appears second, after YouTube. (I have been searching a lot on YouTube lately, opening & closing its tab, so that would be accurate as my current most-searched.) Sooo I'm now going to read the article you linked on preferences that won't save. And again, here are screenshots of the advanced preferences page/s and what my new tab page looks like now! Thanks so much. Maybe I will find what's going on via that linked article!

Изменено mydiylife

Полезно?

  1. 1
  2. 2
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.