Search Support

Text in website footer too large and not aligned.

  • 17 ответов
  • 1 имеет эту проблему
  • 24 просмотра
  • Последний ответ от McCoy

more options

www.southwalespistons.com - footer text too large / making hours out of alignment This was reported to me by my client - I have the same issue when I look, so it cannot really be any setting or extension on a specific computer that is causing this.. It displays correctly in Chrome/Edge/Opera.....but not in Firefox.

Выбранное решение

The website sets a fixed width (width="115") for the SPAN element width that content, so if you use a font that is wider or have increased the default minimum font size then the content is wrapped because it doesn't fit in the container.

If you have made changes to Advanced font-size settings like increasing the minimum/default font-size then try the Default font-size setting "16" and the Minimum font-size setting "none" in case the current setting is causing the problem.

  • Options/Preferences -> General: Fonts & Colors -> Advanced -> Minimum Font Size (none)

Make sure you allow pages to choose their own fonts.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font-size, but to use an extension to set the default page zoom to prevent issues with text not getting displayed properly.

Прочитайте этот ответ в контексте 👍 0

All Replies (17)

more options

. Whenever you get a message / popup like that;

DO NOT USE ANY OF THE PROVIDED LINKS OR ANY PHONE NUMBERS ! !

Such messages are only Spam that could lead you to Fake Support. Not only can they damage or hack your system, they charge you to do so.

You can report such a site at; Google Report Phishing Page {web link} which is the same when done while on site by going to Help > Report Web Forgery

Help us safeguard Mozilla’s trademarks by reporting misuse {web link}

Helpful?

more options

Hi gprit,

I've checked the web address in Firefox, Chrome, and Edge, and I don't see a difference.

Would you mind sending us a screenshot of what you're seeing? For instructions, see How do I create a screenshot of my problem?.

For reference, here are screenshots of what I see in each browser.

Helpful?

more options

see attached

Helpful?

more options

Check your zoom controls.

<Control> (Mac=<Command>) + (plus) enlarge - (minus) reduce 0 (zero) restore

Изменено FredMcD

Helpful?

more options

I did but it make no difference....it should look ok at 100%

Helpful?

more options

Выбранное решение

The website sets a fixed width (width="115") for the SPAN element width that content, so if you use a font that is wider or have increased the default minimum font size then the content is wrapped because it doesn't fit in the container.

If you have made changes to Advanced font-size settings like increasing the minimum/default font-size then try the Default font-size setting "16" and the Minimum font-size setting "none" in case the current setting is causing the problem.

  • Options/Preferences -> General: Fonts & Colors -> Advanced -> Minimum Font Size (none)

Make sure you allow pages to choose their own fonts.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font-size, but to use an extension to set the default page zoom to prevent issues with text not getting displayed properly.

Helpful?

more options

Thanks for that......but adjusting settings on my OWN computer does not solve the issue that client (and their customers) also see it wrong. Can you confirm that you also see it incorrect in FF at 100%.

The website is actually a few years old and this has only just occurred when publishing a change completely separate to the footer. This leads me to believe it is something to do with FF releases since the original publication.

As I say, it is fine in all other browsers so why no FF??

Helpful?

more options

Do not add the width="115" attribute (possibly set the width via CSS) as shown in the second screenshot, but let the browser handle this automatically. Setting a width this way will always cause issues when a larger is used font or zoom text only is used.

Helpful?

more options

thanks again.....that attribute is set automatically via the package I use to create. I cannot change the html. I CAN access the CSS....what should this be set to then?

Helpful?

more options

I hadn't looked too closely to that part of the code, but now I see that this full part consists of a set of nested tables that each have a specific width set, so I don't think that an easy solution is possible.

Try to ask advice at a forum more specialized in web development.

Helpful?

more options

Chris Ilias said

Hi gprit, I've checked the web address in Firefox, Chrome, and Edge, and I don't see a difference. Would you mind sending us a screenshot of what you're seeing? For instructions, see How do I create a screenshot of my problem?. For reference, here are screenshots of what I see in each browser.

Chris...before I look to other sites as suggested, what version of FF are you using? I use 74.0 (64-bit). But as screenshot shows, the footer text is larger and the hours consequently misaligned.

Helpful?

more options

Hello gprit,

FWIW : for me, on Windows 10, Firefox 74.0 (64-bit), just like
for Chris Ilias, the footer text isn't larger. Looks perfectly normal
(zoom level 100%).

Helpful?

more options

You should be able to reproduce this by increasing the Font Size to 20 or by using "Zoom Text Only" instead of full page zoom

  • Options/Preferences -> General: Fonts & Colors

Helpful?

more options

Solved(!) Thanks to all responses and to cor-el, who provided the solution.

As there were several suggestions in her post I gthink it is appropriate to confirm gthat THIS was the culprit: Options/Preferences -> General: Fonts & Colors -> Advanced [X] "Allow pages to choose their own fonts, instead of my selections above"

Ticked that box and it is ok - don't recall ever unticking it.......a very odd co-incidence is that client had the same!...or maybe the default changed in FF somewhere over past releases...?.

Изменено gprit

Helpful?

more options

gprit said

This was the culprit: Options/Preferences -> General: Fonts & Colors -> Advanced [X] "Allow pages to choose their own fonts, instead of my selections above"

You inadvertenly marked your own post as Chosen Solution .... Would you be so kind as to mark cor-el's post (where he suggested to tick that box) as such ? You can rectify it by clicking on the "Undo" button to the right of your post, and then mark cor-el's post ("Solved the problem" button to the right of his post). Thank you in advance !

I'm glad that mystery is solved - well done !

Helpful?

more options

Apologies for repeated solution post......!

Изменено gprit

Helpful?

more options

gprit said

Apologies for repeated solution post......!

    Absolutely no need to apologize  !

    (thank you for rectifying the mark)

Helpful?

Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.