X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

All email attachments get sent to Firefox for opening

Размещено

Attempting to open an email attachment results in the 'request' being sent to Firefox (my default browser) even though the Incoming content type settings under Tools->Options->attachments are correct (ie. set to the relevant default application). Consequently, Firefox doesn't know what to do with them and so opens a file save dialog.

I've deleted and re-created the attachments actions using the relevant EXE direct path but then nothing happens when I attempt to open the attachment.

Does anyone have a solution?

webby

Attempting to open an email attachment results in the 'request' being sent to Firefox (my default browser) even though the Incoming content type settings under Tools->Options->attachments are correct (ie. set to the relevant default application). Consequently, Firefox doesn't know what to do with them and so opens a file save dialog. I've deleted and re-created the attachments actions using the relevant EXE direct path but then nothing happens when I attempt to open the attachment. Does anyone have a solution? webby
Цитата

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Дополнительная информация

sfhowes
  • Top 10 Contributor
1897 решений 9485 ответов
Размещено

Have you updated to 68.4.1? There were some fixes for attachments that might apply to your issue. Help/About TB.

Have you updated to 68.4.1? There were some fixes for attachments that might apply to your issue. Help/About TB.
Помогла ли вам это?
Цитата

Задавший вопрос

Yes, on the latest version 68.4.1

Yes, on the latest version 68.4.1
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1897 решений 9485 ответов
Размещено

Try this: Help/Troubleshooting, click Open Folder to open the profile, close TB. Delete or rename handlers.json, restart TB. This will reset all attachment helper apps, so that when you open an attachment, specify the opening app.

Try this: Help/Troubleshooting, click Open Folder to open the profile, close TB. Delete or rename handlers.json, restart TB. This will reset all attachment helper apps, so that when you open an attachment, specify the opening app.
Помогла ли вам это?
Цитата

Задавший вопрос

OK, well that sort of solved one aspect of the problem but then highlighted what may be the real problem.

If I delete handlers.json as you said and then try to open a email attachment (in this case an Excel file) I then go through a process to 'handle' that file type. The first dialog box (see image1) "knows" about Microsoft Excel and so I just have to tick the 'do this automatically...' option and click OK.

Then a 2nd dialog opens (see image2) which requires me to then navigate to, and select the actual *.EXE location (see image3) then tick the 'Remember my choice...' option and then click Open Link. The file then opens in the application.

However, if I then try to open another file type (Word docx, pdf, mp4 etc) I again get the first dialog box, which defaults to the correct relevant application (MS Word, vlc, pdf-reader) and I tick the 'Do this automatically...' option and then click OK. BUT, I don't get the second dialog and TB tries to open the file in Excel!

In fact, all subsequent attempts to assign different file types to the relevant application don't work, TB always tries to open the file in the first file type assigned, in this case Excel.

I've done this a number of times with different content types as the 'first' open attachment and any subsequent attachments always use whatever the first assignment was.

Another interesting wrinkle is that any attempt to assign *.jpg files to any appropriate graphics application at all never work ie. those files never open.

OK, well that sort of solved one aspect of the problem but then highlighted what may be the real problem. If I delete handlers.json as you said and then try to open a email attachment (in this case an Excel file) I then go through a process to 'handle' that file type. The first dialog box (see image1) "knows" about Microsoft Excel and so I just have to tick the 'do this automatically...' option and click OK. Then a 2nd dialog opens (see image2) which requires me to then navigate to, and select the actual *.EXE location (see image3) then tick the 'Remember my choice...' option and then click Open Link. The file then opens in the application. However, if I then try to open another file type (Word docx, pdf, mp4 etc) I again get the first dialog box, which defaults to the correct relevant application (MS Word, vlc, pdf-reader) and I tick the 'Do this automatically...' option and then click OK. BUT, I don't get the second dialog and TB tries to open the file in Excel! In fact, all subsequent attempts to assign different file types to the relevant application don't work, TB always tries to open the file in the first file type assigned, in this case Excel. I've done this a number of times with different content types as the 'first' open attachment and any subsequent attachments always use whatever the first assignment was. Another interesting wrinkle is that any attempt to assign *.jpg files to any appropriate graphics application at all never work ie. those files never open.

Изменено webby2019

Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1897 решений 9485 ответов
Размещено

I can't say at the moment why you see this odd behavior, but here is a suggestion: when your first picture appears, click the drop-down and select Use other..., and in the next window, don't select any app from the list, but Browse... to the exe file. This might avoid any issues with the settings for Windows default apps and TB's misreading of them.

I can't say at the moment why you see this odd behavior, but here is a suggestion: when your first picture appears, click the drop-down and select Use other..., and in the next window, don't select any app from the list, but Browse... to the exe file. This might avoid any issues with the settings for Windows default apps and TB's misreading of them.
Помогла ли вам это?
Цитата

Задавший вопрос

I tried what you suggested but it just exhibits the same problem as when I tried to associate *.jpg files with mspaint.exe, nothing happens when I try to open the attachments.

A couple of further interesting observations.

The first picture is of my current Content Type mappings showing attempts at MP4 and XLSX mapping. Both of these attachments are "opened" by MS Word.

The second picture is a view of what's in the handlers.json file. 1. There's no application handler shown under 'mime-types' for MP4 or DOCX files but there is XLSX files. 2. Under 'schemes' there's only Winword.exe and it's path shown which suggests (to me) that this is the section that performs the action(s).

All very strange (to me).

I tried what you suggested but it just exhibits the same problem as when I tried to associate *.jpg files with mspaint.exe, nothing happens when I try to open the attachments. A couple of further interesting observations. The first picture is of my current Content Type mappings showing attempts at MP4 and XLSX mapping. Both of these attachments are "opened" by MS Word. The second picture is a view of what's in the handlers.json file. 1. There's no application handler shown under 'mime-types' for MP4 or DOCX files but there is XLSX files. 2. Under 'schemes' there's only Winword.exe and it's path shown which suggests (to me) that this is the section that performs the action(s). All very strange (to me).
Помогла ли вам это?
Цитата

Задавший вопрос

Not sure why but 3 days after my last attempts to fix this problem it's suddenly working. All attachments open in their correct applications.

I have no idea why but there you go....

Not sure why but 3 days after my last attempts to fix this problem it's suddenly working. All attachments open in their correct applications. I have no idea why but there you go....
Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.