X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Want to change length of Thunderbird line wrap displayed when composing

Размещено

When I draft an email in Thunderbird (68.3.1 32-bit, Windows 10), the line wraps at less than a quarter the width of the screen (about 40 characters). I would like to change that, but I don't find an option for it under Composition or elsewhere. (And I'm not certain, but I believe the line length got shorter somewhere between T-bird 60 and 68.)

When I draft an email in Thunderbird (68.3.1 32-bit, Windows 10), the line wraps at less than a quarter the width of the screen (about 40 characters). I would like to change that, but I don't find an option for it under Composition or elsewhere. (And I'm not certain, but I believe the line length got shorter somewhere between T-bird 60 and 68.)

Выбранное решение

So based on:

https://bugzilla.mozilla.org/show_bug.cgi?id=853834#c1

The text is actually not wrapped after 40 characters - technically as in inserting newline characters. Rather it's just wrapped visually.

This is due to:

"If you set a minimum font size to something larger than the monospace font, wrapping is broken. Seems the line length calculation is solely based on the monospace font size (in plain text mode), not the effective font size."

I had the minimum size set to something larger (17) than the monospace font (12). Setting monospace font to 17 (as the minimum size) fixed the issue.

Прочитайте этот ответ в контексте 1
Цитата

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Дополнительная информация

sfhowes
  • Top 10 Contributor
2014 решений 10096 ответов
Размещено

Open Tools/Options/Advanced/General/Config. editor, right-click the preference mailnews.wraplength, Modify, and change it from the default 72. A value of 0 (zero) wraps to the window width. This applies to the wrapping of plain text messages in the message composer.

Open Tools/Options/Advanced/General/Config. editor, right-click the preference ''mailnews.wraplength'', Modify, and change it from the default 72. A value of 0 (zero) wraps to the window width. This applies to the wrapping of plain text messages in the message composer.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Thanks for the suggestion. I did that (config showed the value as already modified to 70). I changed it to 80, closed and re-opened Thunderbird, verified that the value was now 80, and began to compose a message with some sample text. No change; it wrapped at 40, as the screen snip shows.

Thanks for the suggestion. I did that (config showed the value as already modified to 70). I changed it to 80, closed and re-opened Thunderbird, verified that the value was now 80, and began to compose a message with some sample text. No change; it wrapped at 40, as the screen snip shows.

Изменено ronks1

Помогла ли вам это?
Цитата
Размещено

Полезный ответ

However, I just set the value to zero and it does seem to fill the screen width now before wrapping; that is at least a good temporary solution.

However, I just set the value to zero and it does seem to fill the screen width now before wrapping; that is at least a good temporary solution.
Помогла ли вам это? 1
Цитата
peter.meier+thunderbird 1 решений 3 ответов
Размещено

I can confirm that TB now wraps after about 40 characters, although I have all the default settings and set to 72.

This is on Fedora 31 - Thunderbird 68.5.0 (64-bit)

I can confirm that TB now wraps after about 40 characters, although I have all the default settings and set to 72. This is on Fedora 31 - Thunderbird 68.5.0 (64-bit)
Помогла ли вам это?
Цитата
peter.meier+thunderbird 1 решений 3 ответов
Размещено

I tried with all the Add-Ons disabled (just in case), but still no luck, as can be seen by the attached screenshot.

I tried with all the Add-Ons disabled (just in case), but still no luck, as can be seen by the attached screenshot.
Помогла ли вам это?
Цитата
peter.meier+thunderbird 1 решений 3 ответов
Размещено

Выбранное решение

So based on:

https://bugzilla.mozilla.org/show_bug.cgi?id=853834#c1

The text is actually not wrapped after 40 characters - technically as in inserting newline characters. Rather it's just wrapped visually.

This is due to:

"If you set a minimum font size to something larger than the monospace font, wrapping is broken. Seems the line length calculation is solely based on the monospace font size (in plain text mode), not the effective font size."

I had the minimum size set to something larger (17) than the monospace font (12). Setting monospace font to 17 (as the minimum size) fixed the issue.

So based on: https://bugzilla.mozilla.org/show_bug.cgi?id=853834#c1 The text is actually not wrapped after 40 characters - technically as in inserting newline characters. Rather it's just wrapped visually. This is due to: "If you set a minimum font size to something larger than the monospace font, wrapping is broken. Seems the line length calculation is solely based on the monospace font size (in plain text mode), not the effective font size." I had the minimum size set to something larger (17) than the monospace font (12). Setting monospace font to 17 (as the minimum size) fixed the issue.
Помогла ли вам это? 1
Цитата
Размещено

Задавший вопрос

Thanks! Yes, I discovered that too. Setting the value to zero for display purposes while composing the text works for me.

Thanks! Yes, I discovered that too. Setting the value to zero for display purposes while composing the text works for me.
Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.