X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Right click menu does not show

Размещено

So after browsing for a while, when i right click (on any page) the popup menu doesn't show up. Also, when this happens, if i click any _folder_ in the Bookmarks toolbar, the popup window containing the items doesn't show/pop up either.

So, i created an entirely new profile in Firefox, without installing any addons or changing any of the other default settings. And, after browsing for a bit the same issue happens again...

Rebooting Firefox fixes the problem for a while. Please advise, thank you :)

So after browsing for a while, when i right click (on any page) the popup menu doesn't show up. Also, when this happens, if i click any _folder_ in the Bookmarks toolbar, the popup window containing the items doesn't show/pop up either. So, i created an entirely new profile in Firefox, without installing any addons or changing any of the other default settings. And, after browsing for a bit the same issue happens again... Rebooting Firefox fixes the problem for a while. Please advise, thank you :)

Выбранное решение

I found the issue, it seems to be a bug:

I am running macOS 10.15.2 / Firefox 71.0; To reproduce:

1. Make sure you have multiple virtual desktops opened (mission control) 2. Go to "Desktop 1" and open Firefox (i used a new/clean profile) 3. Right click the opened Firefox icon in the Dock, and choose "Options - Assign to -> This Desktop" 4. Now maximize the Firefox window by clicking on the green dot to enter full screen (this will move Firefox to Desktop 2 or 3 or above) 5. Now, if you right click in any webpage, the context menu that should pop up (the one that contains "save page as" etc), will *not* appear, as if the right mouse button is not working. Also, if you left click any *folder* in the bookmark toolbar, the popup window with the items in that folder will not appear.

To show what's going on: in step #5 when you right click (and the popup window does not show up), open Mission Control (in my case it's swiping up with 3 fingers on the trackpad) to show the overview of all the desktops, and you will see that while Firefox is opened Fullscreen in Desktop 2+, the right-click context menu is opened in Desktop 1 which we assigned Firefox to in step #3.

The workaround is to NOT assign Firefox to a specific Desktop.

Прочитайте этот ответ в контексте 0
Цитата

Дополнительные сведения о системе

Установленные плагины

none

Приложение

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

Дополнительная информация

Dinushi Dhananjani
  • Top 25 Contributor
5 решений 216 ответов
Размещено

hy dr..

how to edit the right-click context menus in FF

Install Menu Editor the same way you would any other Firefox

Add-on, and then restart Firefox. 
   Scroll down to the Menu 

Editor entry, select it, and click the Preferences button.

   The main Options window
for Menu Editor will open.

https://appuals.com/fix-right-click-not-working-on-firefox/

hy dr.. how to edit the right-click context menus in FF Install Menu Editor the same way you would any other Firefox Add-on, and then restart Firefox. Scroll down to the Menu Editor entry, select it, and click the Preferences button. The main Options window for Menu Editor will open. https://appuals.com/fix-right-click-not-working-on-firefox/

Изменено Dinushi Dhananjani

Помогла ли вам это? 0
Цитата
Размещено

Задавший вопрос

That does not solve my problem...

That does not solve my problem...
Помогла ли вам это?
Цитата
FredMcD
  • Top 10 Contributor
4314 решений 60603 ответов
Размещено

Let’s do a full clean re-install;

Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.


Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Let’s do a full clean re-install; Note: Firefox comes in three or more folders on all computers. They are; Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user. If you remove the Firefox folder, the user profiles would not be affected. ----------- [http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems] {web link} Save the file. Then '''Close Firefox. ''' Using your file browser, open the '''Programs Folder''' on your computer. '''Windows: ''' C:\Program Files C:\Program Files (x86) '''Note:''' Check Both Folders '''Mac: ''' Open the ''' "Applications" ''' folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac '''Linux: ''' Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any '''Mozilla''' or '''Firefox''' program folders. Do not remove the '''Mozilla Thunderbird''' folder if there is one. '''Do Not''' remove any profile folders. After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your '''Computer''' in safe mode and try again. http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia
Помогла ли вам это?
Цитата
cor-el
  • Top 10 Contributor
  • Moderator
17699 решений 160142 ответов
Размещено

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings Close and restart Firefox after modifying the setting for changes to take effect. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Помогла ли вам это?
Цитата
Размещено

Выбранное решение

I found the issue, it seems to be a bug:

I am running macOS 10.15.2 / Firefox 71.0; To reproduce:

1. Make sure you have multiple virtual desktops opened (mission control) 2. Go to "Desktop 1" and open Firefox (i used a new/clean profile) 3. Right click the opened Firefox icon in the Dock, and choose "Options - Assign to -> This Desktop" 4. Now maximize the Firefox window by clicking on the green dot to enter full screen (this will move Firefox to Desktop 2 or 3 or above) 5. Now, if you right click in any webpage, the context menu that should pop up (the one that contains "save page as" etc), will *not* appear, as if the right mouse button is not working. Also, if you left click any *folder* in the bookmark toolbar, the popup window with the items in that folder will not appear.

To show what's going on: in step #5 when you right click (and the popup window does not show up), open Mission Control (in my case it's swiping up with 3 fingers on the trackpad) to show the overview of all the desktops, and you will see that while Firefox is opened Fullscreen in Desktop 2+, the right-click context menu is opened in Desktop 1 which we assigned Firefox to in step #3.

The workaround is to NOT assign Firefox to a specific Desktop.

I found the issue, it seems to be a bug: I am running macOS 10.15.2 / Firefox 71.0; To reproduce: 1. Make sure you have multiple virtual desktops opened (mission control) 2. Go to "Desktop 1" and open Firefox (i used a new/clean profile) 3. Right click the opened Firefox icon in the Dock, and choose "Options - Assign to -> This Desktop" 4. Now maximize the Firefox window by clicking on the green dot to enter full screen (this will move Firefox to Desktop 2 or 3 or above) 5. Now, if you right click in any webpage, the context menu that should pop up (the one that contains "save page as" etc), will *not* appear, as if the right mouse button is not working. Also, if you left click any *folder* in the bookmark toolbar, the popup window with the items in that folder will not appear. To show what's going on: in step #5 when you right click (and the popup window does not show up), open Mission Control (in my case it's swiping up with 3 fingers on the trackpad) to show the overview of all the desktops, and you will see that while Firefox is opened Fullscreen in Desktop 2+, the right-click context menu is opened in Desktop 1 which we assigned Firefox to in step #3. The workaround is to NOT assign Firefox to a specific Desktop.
Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.