X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Middle click opens a new window

Размещено

I have issues with my mousewheel so I like to press Middleclick to open this circle, in which I then move my mouse up or down to scroll. It's also called "Auto Scroll".

The trouble is, when you activate it on a link, it opens a new tab instead of activating auto scroll. So thats when I disabled that in about:config. I set browser.tabs.opentabfor.middleclick to false.

But not what it does is it opens a new window. And I don't know how to disable that.

Do any of you know a workaround? I know there are extensions for this but I really really like the basic Autoscroll.

I have issues with my mousewheel so I like to press Middleclick to open this circle, in which I then move my mouse up or down to scroll. It's also called "Auto Scroll". The trouble is, when you activate it on a link, it opens a new tab instead of activating auto scroll. So thats when I disabled that in about:config. I set browser.tabs.opentabfor.middleclick to false. But not what it does is it opens a new window. And I don't know how to disable that. Do any of you know a workaround? I know there are extensions for this but I really really like the basic Autoscroll.
Цитата

Дополнительные сведения о системе

Установленные плагины

  • Shockwave Flash 32.0 r0

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Дополнительная информация

evhenry
  • Top 25 Contributor
  • Administrator
33 решений 188 ответов
Размещено

Полезный ответ

The problem here is even if you go in and disable "open in new window" by adjusting another setting it'll just open the link in the current tab/window :(.

There might be an extension that can disable opening links with middle click completely rather than replacing autoscroll entirely, however I cannot find one. I know the code exists (by looking for auxclick and preventdefault()), but it doesn't seem anyone has written one yet.)

The problem here is even if you go in and disable "open in new window" by adjusting another setting it'll just open the link in the current tab/window :(. There might be an extension that can disable opening links with middle click completely rather than replacing autoscroll entirely, however I cannot find one. I know the code exists (by looking for auxclick and preventdefault()), but it doesn't seem anyone has written one yet.)
Помогла ли вам это? 1
Цитата
cor-el
  • Top 10 Contributor
  • Moderator
17688 решений 160006 ответов
Размещено

You will have to make sure that you do not middle-click on an element that accepts a mouse click. Only if you click in 'free space' you can activate auto-scroll.

For some reason clicking on an active element happens for me a lot of times when one window (e.g the developer tools in a standalone window) is active and is on top of another window that I want to bring up front with a click in this window instead of using Alt + Tab or other ways.

You will have to make sure that you do not middle-click on an element that accepts a mouse click. Only if you click in 'free space' you can activate auto-scroll. For some reason clicking on an active element happens for me a lot of times when one window (e.g the developer tools in a standalone window) is active and is on top of another window that I want to bring up front with a click in this window instead of using Alt + Tab or other ways.
Помогла ли вам это?
Цитата
James
  • Top 25 Contributor
  • Moderator
1603 решений 11348 ответов
Размещено

Полезный ответ

http://kb.mozillazine.org/About:config_entries#Browser. browser.tabs.opentabfor.middleclick Determines the behavior of a link when middle-clicked. True (default): Opens link in new tab False: Opens link in new window

As you can see False does not mean you are turning middle-click off but rather open links in a new window.

http://kb.mozillazine.org/About:config_entries#Browser. browser.tabs.opentabfor.middleclick Determines the behavior of a link when middle-clicked. True (default): Opens link in new tab False: Opens link in new window As you can see False does not mean you are turning middle-click off but rather open links in a new window.
Помогла ли вам это? 1
Цитата

Задавший вопрос

Still, there should be an option for disabling middle-clicking links altogether. People have requested this for the past 15 years.

On some sites, such as ArtStation, links can cover 90% of the page making it very awkward to use AutoScroll.

Still, there should be an option for disabling middle-clicking links altogether. People have requested this for the past 15 years. On some sites, such as ArtStation, links can cover 90% of the page making it very awkward to use AutoScroll.
Помогла ли вам это?
Цитата
cor-el
  • Top 10 Contributor
  • Moderator
17688 решений 160006 ответов
Размещено

Try to middle-click the scroll bar to see whether that works.

Try to middle-click the scroll bar to see whether that works.
Помогла ли вам это?
Цитата

Задавший вопрос

That is already what I do. Which partly renders it useless as I could just use the scroll bar itself instead.

That is already what I do. Which partly renders it useless as I could just use the scroll bar itself instead.
Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.