X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Need help to debug imap authentication failure with gmail.

Размещено

I seem to be experiencing an issue similar to here:

https://support.google.com/mail/thread/4528103?msgid=19227686

Only in my case none of the workarounds seem to fix it. I was already using an app password and yesterday (2019-12-03) it suddenly stopped. Regenerating the app pass word doesn't help and neither does switching to oauth2. When I try oauth2 I get all the right login screens and I get the google validation but thunderbird sees some sort of failure. When I use app password I just get that the password is incorrect and to retry.

I'm using TB 68.2.1 on Ubuntu LTS 18.04.3

How can I get more debugging information on what might be happening?

Thanks.

I seem to be experiencing an issue similar to here: https://support.google.com/mail/thread/4528103?msgid=19227686 Only in my case none of the workarounds seem to fix it. I was already using an app password and yesterday (2019-12-03) it suddenly stopped. Regenerating the app pass word doesn't help and neither does switching to oauth2. When I try oauth2 I get all the right login screens and I get the google validation but thunderbird sees some sort of failure. When I use app password I just get that the password is incorrect and to retry. I'm using TB 68.2.1 on Ubuntu LTS 18.04.3 How can I get more debugging information on what might be happening? Thanks.
Цитата

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/78.0.3904.108 Chrome/78.0.3904.108 Safari/537.36

Дополнительная информация

sfhowes
  • Top 10 Contributor
1848 решений 9164 ответов
Размещено

If you have OAuth authentication with an IMAP gmail account, don't enter the app password when the OAuth window appears; just enter the account password. An app password is only necessary if you've applied 2-step verification and are using 'normal password' authentication.

http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite

If you change app passwords or the regular account password on the gmail site, delete the old password in Edit/Preferences/Security/Passwords/Saved Passwords, restart TB, and enter the new one when prompted.

If you have OAuth authentication with an IMAP gmail account, don't enter the app password when the OAuth window appears; just enter the account password. An app password is only necessary if you've applied 2-step verification and are using 'normal password' authentication. http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite If you change app passwords or the regular account password on the gmail site, delete the old password in Edit/Preferences/Security/Passwords/Saved Passwords, restart TB, and enter the new one when prompted.
Помогла ли вам это? 1
Цитата

Задавший вопрос

Thanks,

I do have 2FA active on this account. I was using app password successfully before it stopped working. I only tried the oauth2 after a some googling when app password didn't work.

I'm using the correct generated password for app password when its set to "normal password" and my gmail account password for oauth2 when I set it to oauth2. The oauth2 login works and google indicates that thunderbird has access but TB still fails with a authentication failure.

I have already deleted the previous app password in saved password and regenerated a new one. TB asks for a new password when it fails so I've done it that way as well.

This could still be user error but I don't remember doing anything before it stopped working and I believe I have all the settings correct.

Do you know how I can look at more debug info for whats is happening when the IMAP login is occurring? That way I can verify that what is happening matches my expectations.

Thanks, I do have 2FA active on this account. I was using app password successfully before it stopped working. I only tried the oauth2 after a some googling when app password didn't work. I'm using the correct generated password for app password when its set to "normal password" and my gmail account password for oauth2 when I set it to oauth2. The oauth2 login works and google indicates that thunderbird has access but TB still fails with a authentication failure. I have already deleted the previous app password in saved password and regenerated a new one. TB asks for a new password when it fails so I've done it that way as well. This could still be user error but I don't remember doing anything before it stopped working and I believe I have all the settings correct. Do you know how I can look at more debug info for whats is happening when the IMAP login is occurring? That way I can verify that what is happening matches my expectations.
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1848 решений 9164 ответов
Размещено

Полезный ответ

The Gmail article cited above suggests deleting google cookies if the app password fails to work. But you may just be facing Google's effect on accounts where the user is changing the authentication; it may become accessible after a day or so. The article also recommends not using 2-step verification.

You might find some debug info in Tools/Developer Tools/Error Console, or by using more complex logging.

The Gmail article cited above suggests deleting google cookies if the app password fails to work. But you may just be facing Google's effect on accounts where the user is changing the authentication; it may become accessible after a day or so. The article also recommends not using 2-step verification. You might find some debug info in Tools/Developer Tools/Error Console, or by using more complex [http://kb.mozillazine.org/Session_logging_for_mail/news logging].
Помогла ли вам это? 1
Цитата

Задавший вопрос

I don't have any choice on 2FA. It's set by my organization. However, I have figured out the app password issue. Turns out that same said organization disabled "less secure apps" yesterday. So that is what broke my app password access. :(

Its now re-enabled and app password is working again via "normal password." Strange that gmail let me make a new app password even though the entire feature was disabled.

OAuth2 however, still does not seem to work. I'll have to sort that out so that "less secure apps" can eventually be disabled. But I suppose that should be dealt with in another ticket.

Thanks for your help.

I don't have any choice on 2FA. It's set by my organization. However, I have figured out the app password issue. Turns out that same said organization disabled "less secure apps" yesterday. So that is what broke my app password access. :( Its now re-enabled and app password is working again via "normal password." Strange that gmail let me make a new app password even though the entire feature was disabled. OAuth2 however, still does not seem to work. I'll have to sort that out so that "less secure apps" can eventually be disabled. But I suppose that should be dealt with in another ticket. Thanks for your help.
Помогла ли вам это?
Цитата
everettrl338 0 решений 1 ответов
Размещено

I have 3 gmail email accounts. @ of them seem to perform normally. However the 3rd will not load. the following message appears:

"Authentication failure while connecting to server IMAP.gmail.com

Am I experiencing the problem being referred to in this thread or is it something else. Some of the suggestions were helpful in reinstalling the 2 working accounts, but no help for the 3rd.

I have 3 gmail email accounts. @ of them seem to perform normally. However the 3rd will not load. the following message appears: "Authentication failure while connecting to server IMAP.gmail.com Am I experiencing the problem being referred to in this thread or is it something else. Some of the suggestions were helpful in reinstalling the 2 working accounts, but no help for the 3rd.
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1848 решений 9164 ответов
Размещено

What could possibly be different between the 2 working accounts and the 3rd one? Make sure the authentication is OAuth2 and enter the regular account password when the OAuth browser window appears. Make sure that TB is 60.9.1 or 68.3.1 when adding new gmail accounts. Confirm the password by logging in on gmail.com.

What could possibly be different between the 2 working accounts and the 3rd one? Make sure the authentication is OAuth2 and enter the regular account password when the OAuth browser window appears. Make sure that TB is 60.9.1 or 68.3.1 when adding new gmail accounts. Confirm the password by logging in on gmail.com.
Помогла ли вам это?
Цитата
Ted Burnham 0 решений 7 ответов
Размещено

I have 4 Gmail accounts with 3 working and 1 which reports authentication failure server imap.gmail.com in TB

Settings on all accounts are the same

I have tried various workarounds as suggested earlier but none work. The account is working when I login to Gmail via Firefox.

TB 68.3.1 Windows 10 Pro.

Help would be much appreciated Ted Burnham 4th January 2020

I have 4 Gmail accounts with 3 working and 1 which reports authentication failure server imap.gmail.com in TB Settings on all accounts are the same I have tried various workarounds as suggested earlier but none work. The account is working when I login to Gmail via Firefox. TB 68.3.1 Windows 10 Pro. Help would be much appreciated Ted Burnham 4th January 2020
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1848 решений 9164 ответов
Размещено

Ted Burnham said

I have 4 Gmail accounts with 3 working and 1 which reports authentication failure server imap.gmail.com in TB Settings on all accounts are the same I have tried various workarounds as suggested earlier but none work. The account is working when I login to Gmail via Firefox. TB 68.3.1 Windows 10 Pro.

Is the authentication for the non-working account 'normal password' or OAuth2? Tools/Options/Security/Passwords/Saved Passwords, delete the passwords for the non-working account, for incoming and smtp, restart TB, enter the password when prompted. The password you enter depends on the authentication; OAuth2 is simplest, just use the regular password.

''Ted Burnham [[#answer-1278363|said]]'' <blockquote> I have 4 Gmail accounts with 3 working and 1 which reports authentication failure server imap.gmail.com in TB Settings on all accounts are the same I have tried various workarounds as suggested earlier but none work. The account is working when I login to Gmail via Firefox. TB 68.3.1 Windows 10 Pro. </blockquote> Is the authentication for the non-working account 'normal password' or OAuth2? Tools/Options/Security/Passwords/Saved Passwords, delete the passwords for the non-working account, for incoming and smtp, restart TB, enter the password when prompted. The password you enter depends on the authentication; OAuth2 is simplest, just use the regular password.
Помогла ли вам это?
Цитата
Ted Burnham 0 решений 7 ответов
Размещено

Authentication is OAuth2 - password has been changed in Gmail. Still get the same problem

Authentication is OAuth2 - password has been changed in Gmail. Still get the same problem
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1848 решений 9164 ответов
Размещено

Ted Burnham said

Authentication is OAuth2 - password has been changed in Gmail. Still get the same problem

When you changed the password in Gmail, did you remove the old OAuth2 token, and the imap://and smtp:// passwords, in TB Options?

''Ted Burnham [[#answer-1278372|said]]'' <blockquote> Authentication is OAuth2 - password has been changed in Gmail. Still get the same problem </blockquote> When you changed the password in Gmail, did you remove the old OAuth2 token, and the imap://and smtp:// passwords, in TB Options?
Помогла ли вам это?
Цитата
Ted Burnham 0 решений 7 ответов
Размещено

I removed the account from TB and attempted to create an entry in TB for the account.

I removed the account from TB and attempted to create an entry in TB for the account.
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1848 решений 9164 ответов
Размещено

If by 'create an entry' you mean add the password in Options, that's not possible. Restart TB, and you will be prompted to enter the password next time you connect to the account, at which point you can check the box to have it stored in Options.

If by 'create an entry' you mean add the password in Options, that's not possible. Restart TB, and you will be prompted to enter the password next time you connect to the account, at which point you can check the box to have it stored in Options.
Помогла ли вам это?
Цитата
Ted Burnham 0 решений 7 ответов
Размещено

Attached is copy of the settings for the account in question

Attached is copy of the settings for the account in question
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1848 решений 9164 ответов
Размещено

The settings are correct, but does the error appear when you try to connect to imap.gmail.com, i.e. receive mail, or to smtp.gmail.com, i.e. send mail? If you select the account in the left pane of Account Settings, is the Outgoing Server (SMTP) in the right pane the Default, or is it an smtp.gmail.com that has the same User Name and password as the left-pane account?

The settings are correct, but does the error appear when you try to connect to imap.gmail.com, i.e. receive mail, or to smtp.gmail.com, i.e. send mail? If you select the account in the left pane of Account Settings, is the Outgoing Server (SMTP) in the right pane the Default, or is it an smtp.gmail.com that has the same User Name and password as the left-pane account?
Помогла ли вам это?
Цитата
Ted Burnham 0 решений 7 ответов
Размещено

I get the IMAP error when attempting to receive mail. When trying to send I get "unexpected error 80004005. No description available, coud not send using Outgoing server SMTP. Please verify that SMTP settings are correct.

It would appear that my settings are correct

I get the IMAP error when attempting to receive mail. When trying to send I get "unexpected error 80004005. No description available, coud not send using Outgoing server SMTP. Please verify that SMTP settings are correct. It would appear that my settings are correct
Помогла ли вам это?
Цитата
Ted Burnham 0 решений 7 ответов
Размещено

I will be closing in a few minutes and will reopen tomorrow a.m. (UK time)

I will be closing in a few minutes and will reopen tomorrow a.m. (UK time)
Помогла ли вам это?
Цитата
Ted Burnham 0 решений 7 ответов
Размещено

I don't know how but I have resolved the issue.

Many thanks for your help

I don't know how but I have resolved the issue. Many thanks for your help
Помогла ли вам это?
Цитата
karindegorter 0 решений 1 ответов
Размещено

I seem to have similar problems, not just with imap but also smtp. Already executed tips regarding removing passwords in Thunderbird in preferences, authentication is set to OAuth with all 3 Gmail accounts that I use (imap and smtp). I do notice that I don't get the window by Google after these actions above to allow access to Gmail, aka the popup window doesn't appear. The message I receive in Thunderbird when trying to send an email is: [The message could not be sent because the waiting time for the connection to the outgoing (SMTP) server smtp.gmail.com has expired. Try again.] this message I translated from Dutch to English for this forum. It is possibly not exact the same as with an English version.

Any suggestions on what to try next?

I seem to have similar problems, not just with imap but also smtp. Already executed tips regarding removing passwords in Thunderbird in preferences, authentication is set to OAuth with all 3 Gmail accounts that I use (imap and smtp). I do notice that I don't get the window by Google after these actions above to allow access to Gmail, aka the popup window doesn't appear. The message I receive in Thunderbird when trying to send an email is: [The message could not be sent because the waiting time for the connection to the outgoing (SMTP) server smtp.gmail.com has expired. Try again.] this message I translated from Dutch to English for this forum. It is possibly not exact the same as with an English version. Any suggestions on what to try next?
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1848 решений 9164 ответов
Размещено

karindegorter said

I seem to have similar problems, not just with imap but also smtp. Already executed tips regarding removing passwords in Thunderbird in preferences, authentication is set to OAuth with all 3 Gmail accounts that I use (imap and smtp). I do notice that I don't get the window by Google after these actions above to allow access to Gmail, aka the popup window doesn't appear. The message I receive in Thunderbird when trying to send an email is: [The message could not be sent because the waiting time for the connection to the outgoing (SMTP) server smtp.gmail.com has expired. Try again.] this message I translated from Dutch to English for this forum. It is possibly not exact the same as with an English version. Any suggestions on what to try next?

As for timeouts, these are often caused by antivirus apps scanning outgoing mail. The TB profile folder should be added as an exception or exclusion in the AV settings, and also the scanning of secure (SSL) connections should be disabled, if it's activated.

''karindegorter [[#answer-1285245|said]]'' <blockquote> I seem to have similar problems, not just with imap but also smtp. Already executed tips regarding removing passwords in Thunderbird in preferences, authentication is set to OAuth with all 3 Gmail accounts that I use (imap and smtp). I do notice that I don't get the window by Google after these actions above to allow access to Gmail, aka the popup window doesn't appear. The message I receive in Thunderbird when trying to send an email is: [The message could not be sent because the waiting time for the connection to the outgoing (SMTP) server smtp.gmail.com has expired. Try again.] this message I translated from Dutch to English for this forum. It is possibly not exact the same as with an English version. Any suggestions on what to try next? </blockquote> As for timeouts, these are often caused by antivirus apps scanning outgoing mail. The TB profile folder should be added as an exception or exclusion in the AV settings, and also the scanning of secure (SSL) connections should be disabled, if it's activated.
Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.