X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Firefox does not correctly display text containing unusual characters.

Размещено

Special characters from other languages often do not display correctly. See attached screen print. This screen print was done from article at http://www.jewishworldreview.com/1119/burger_wont_rot.php3

Special characters from other languages often do not display correctly. See attached screen print. This screen print was done from article at http://www.jewishworldreview.com/1119/burger_wont_rot.php3
Приложенные скриншоты

Выбранное решение

This is likely a problem with the encoding: there server sends an eight bit ISO or Windows encoding, but the website uses Unicode˘i.e. you see the separate bytes of a multi byte Unicode character). Firefox always uses the encoding as send by the server if the server sends it, event when there is meta tag that specifies UTF-8 encoding.

You can check the Text Encoding (View -> Text Encoding) and make sure that it is set to Unicode. If this doesn't help then there is probably something wrong with the website.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Прочитайте этот ответ в контексте 1
Цитата

Дополнительные сведения о системе

Установленные плагины

  • Shockwave Flash 32.0 r0

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Дополнительная информация

TyDraniu
  • Top 25 Contributor
339 решений 1907 ответов
Размещено

In this document the Unicode character encoding has not been declared.

When displaying this document in Firefox, some characters outside the US-ASCII range will be incorrect. Encoding of page characters must be declared in a document or transmission protocol.

In this document the Unicode character encoding has not been declared. When displaying this document in Firefox, some characters outside the US-ASCII range will be incorrect. Encoding of page characters must be declared in a document or transmission protocol.
Помогла ли вам это?
Цитата

Задавший вопрос

TyDaniu, thank you for your response.

However, I am still mystified as to how to "declare" the correct encoding. I looked through the Firefox options before I posted my question to this Forum and did not see anywhere that can be done.

Any suggestions as to how this "declaration" can be accomplished would be appreciated.

Please note that this is not an isolated occurrence; I find it happens any time foreign words are included in the contents of a page.

TyDaniu, thank you for your response. However, I am still mystified as to how to "declare" the correct encoding. I looked through the Firefox options before I posted my question to this Forum and did not see anywhere that can be done. Any suggestions as to how this "declaration" can be accomplished would be appreciated. Please note that this is not an isolated occurrence; I find it happens any time foreign words are included in the contents of a page.
Помогла ли вам это?
Цитата
cor-el
  • Top 10 Contributor
  • Moderator
17588 решений 159105 ответов
Размещено

Выбранное решение

This is likely a problem with the encoding: there server sends an eight bit ISO or Windows encoding, but the website uses Unicode˘i.e. you see the separate bytes of a multi byte Unicode character). Firefox always uses the encoding as send by the server if the server sends it, event when there is meta tag that specifies UTF-8 encoding.

You can check the Text Encoding (View -> Text Encoding) and make sure that it is set to Unicode. If this doesn't help then there is probably something wrong with the website.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

This is likely a problem with the encoding: there server sends an eight bit ISO or Windows encoding, but the website uses Unicode˘i.e. you see the separate bytes of a multi byte Unicode character). Firefox always uses the encoding as send by the server if the server sends it, event when there is meta tag that specifies UTF-8 encoding. You can check the Text Encoding (View -> Text Encoding) and make sure that it is set to Unicode. If this doesn't help then there is probably something wrong with the website. Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Изменено cor-el

Помогла ли вам это? 1
Цитата

Задавший вопрос

cor-el,

That was the solution. The text was set to "Western". I changed it to Unicode and the special characters resolved themselves. In the future, if I encounter this problem I will know how to fix it.

Thanks.

cor-el, That was the solution. The text was set to "Western". I changed it to Unicode and the special characters resolved themselves. In the future, if I encounter this problem I will know how to fix it. Thanks.
Помогла ли вам это?
Цитата
cor-el
  • Top 10 Contributor
  • Moderator
17588 решений 159105 ответов
Размещено
You're welcome. *https://www.i18nqa.com/debug/utf8-debug.html
Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.