Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

Why Firefox can't download files and extensions after reinstall unless I give it Administrator privelegies on Windows 10?

  • 3 ответа
  • 1 имеет эту проблему
  • 1124 просмотра
  • Последний ответ от nickb.ufeim

more options

I restored my AppData folder. After that Firefox stopped downloading any files. I tried to reinstall it, but I got an error about unabling to create temporary archive from 7z. Then I tried to run installation as Administrator and Firefox was installed. Apparently sync wasn't working. I tried to install some extensions manually and got error message "Download failed. Please check your connection.", also, I couldn't download any file from any site (fail). When I start Mozilla as administrator, all downloads work fine, but application is working for another user.

Any idea how to fix it?

Выбранное решение

Found the cause: looks like I broke my Temp folder (inside AppData), so my environment variables "TMP" and "TEMP" was pointing to non-existed (or maybe forbidden) path. I've changed them to correct path and issue was solved.

Прочитайте этот ответ в контексте 👍 0

Все ответы (3)

more options

Try using the Refresh feature on the Profile where you "restored" your AppData folder.

https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

more options

the-edmeister said

Try using the Refresh feature on the Profile where you "restored" your AppData folder. https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Thanks! I restored my old profile with extensions, but download issue (and new extensions issue) still remains. I tried to switch off Windows firewall, but situation didn't change. Also downloads work well on built-in Edge browser and don't work on mozilla-based Tor browser.

Изменено nickb.ufeim

more options

Выбранное решение

Found the cause: looks like I broke my Temp folder (inside AppData), so my environment variables "TMP" and "TEMP" was pointing to non-existed (or maybe forbidden) path. I've changed them to correct path and issue was solved.

Изменено nickb.ufeim