X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

When I delete an email message from my inbox, it disappears for a few seconds and then immediately reappears.

Размещено

When I delete an email message from my inbox, it disappears for a few seconds and then immediately reappears. Here is the error message displayed, “The current operation on 'Inbox' did not succeed. The mail server for account XXX responded: Command Error.12." This also occurs when trying to delete (or even move) messages from any folder except the Trash folder (i.e. it lets me remove messages from the Trash folder). I am using Thunderbird for several email accounts, and this only occurs for this one email account, which is an imap account.

I first fixed the problem by going into the Config editor and changing the value for this field (mail.server.default.send_client_info) from true to false (see https://support.mozilla.org/en-US/questions/1064915 ). This worked for a couple of hours, then the problem re-occurred. I went ahead and changed the value back to true.

Next, I tried deleting the Trash and Trash.msf files from my Profile folder, just in case they were corrupted (see https://support.mozilla.org/en-US/kb/cannot-delete-messages ). That initially did not work. Then I tried also deleting the INBOX and INBOX.msf files, along with the Trash and Trash.msf files. It did not work until I restarted my computer. This fix worked for several days, but then reappeared.

This first only occurred on my work computer (Windows 7 Professional) while using Thunderbird, then several days later it happened on my personal laptop (Mac OS 10.11.6) while using Thunderbird, and now (weeks later) it is happening on both. This does not happen when I access this email account with my phone (Android 7.1.1) nor online, neither of which use Thunderbird.

Now neither fix works. I have even tried deleting all files and folders that do not contain actual email messages from my Profile folder (i.e. I deleted all files with extension .msf and all folders with extension.sbd). This did not work either.

In addition, I used my phone (where I can still do things), and I emptied all of these folders: Trash, Deleted Items, Sent, Sent Items, Junk, Inbox. Next, I compacted everything. Then I deleted everything but actual email messages from my Profile folder. Lastly, I restarted my computer. This did not work.

When I delete an email message from my inbox, it disappears for a few seconds and then immediately reappears. Here is the error message displayed, “The current operation on 'Inbox' did not succeed. The mail server for account XXX responded: Command Error.12." This also occurs when trying to delete (or even move) messages from any folder except the Trash folder (i.e. it lets me remove messages from the Trash folder). I am using Thunderbird for several email accounts, and this only occurs for this one email account, which is an imap account. I first fixed the problem by going into the Config editor and changing the value for this field (mail.server.default.send_client_info) from true to false (see https://support.mozilla.org/en-US/questions/1064915 ). This worked for a couple of hours, then the problem re-occurred. I went ahead and changed the value back to true. Next, I tried deleting the Trash and Trash.msf files from my Profile folder, just in case they were corrupted (see https://support.mozilla.org/en-US/kb/cannot-delete-messages ). That initially did not work. Then I tried also deleting the INBOX and INBOX.msf files, along with the Trash and Trash.msf files. It did not work until I restarted my computer. This fix worked for several days, but then reappeared. This first only occurred on my work computer (Windows 7 Professional) while using Thunderbird, then several days later it happened on my personal laptop (Mac OS 10.11.6) while using Thunderbird, and now (weeks later) it is happening on both. This does not happen when I access this email account with my phone (Android 7.1.1) nor online, neither of which use Thunderbird. Now neither fix works. I have even tried deleting all files and folders that do not contain actual email messages from my Profile folder (i.e. I deleted all files with extension .msf and all folders with extension.sbd). This did not work either. In addition, I used my phone (where I can still do things), and I emptied all of these folders: Trash, Deleted Items, Sent, Sent Items, Junk, Inbox. Next, I compacted everything. Then I deleted everything but actual email messages from my Profile folder. Lastly, I restarted my computer. This did not work.

Изменено applejack

Цитата

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Дополнительная информация

Toad-Hall
  • Top 10 Contributor
1809 решений 12184 ответов
Размещено

Then in Account Settings > Server Settings When I delete a message: Select: 'Move it to this folder' Select the 'Deleted Items on imap account' click on OK

Then in Account Settings > Server Settings When I delete a message: Select: 'Move it to this folder' Select the 'Deleted Items on imap account' click on OK
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Thank you, Toad-Hall. I wondered myself if this might be more of a move issue rather than a delete issue, since I cannot move any message either.

I tried your suggestion on both computers in Thunderbird, and unfortunately it did not resolve the issue.

By the way, should the 'Personal namespace' be "INBOX." with or without the quotes? I was not sure, so I tried it both ways, just in case.

Also, it may be nothing but you suggested changing this namespace from " " to "INBOX." The current name was "" instead of " " (without a space vs. with a space). Does that matter?

In addition, was I suppose to see some new sub-folder hierarchy after changing the namespace to "INBOX." because I did not?

Thank you, Toad-Hall. I wondered myself if this might be more of a ''move'' issue rather than a ''delete'' issue, since I cannot move any message either. I tried your suggestion on both computers in Thunderbird, and unfortunately it did not resolve the issue. By the way, should the 'Personal namespace' be "INBOX." with or without the quotes? I was not sure, so I tried it both ways, just in case. Also, it may be nothing but you suggested changing this namespace from " " to "INBOX." The current name was "" instead of " " (without a space vs. with a space). Does that matter? In addition, was I suppose to ''see'' some new sub-folder hierarchy after changing the namespace to "INBOX." because I did not?

Изменено applejack

Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

My last reply was not showing up, so I tried again.

My last reply was not showing up, so I tried again.

Изменено applejack

Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

My last reply was not showing up, so I tried again from another computer.

My last reply was not showing up, so I tried again from another computer.

Изменено applejack

Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.