X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

How to make tabs not so tall in Firefox 70?

Размещено

Firefox 70 has made the tab hight taller, and now they overlap the window frame on my computer (Win 7). How do I get them back to their size in Firefox 69 and stop them from eating into the frame? CSS is fine.

Firefox 70 has made the tab hight taller, and now they overlap the window frame on my computer (Win 7). How do I get them back to their size in Firefox 69 and stop them from eating into the frame? CSS is fine.

Выбранное решение

Did you try other Density settings via customize mode?

Were you using code in userChrome.css to modify the height of the Tab bar ?

Прочитайте этот ответ в контексте 1
Цитата

Дополнительные сведения о системе

Установленные плагины

  • Shockwave Flash 32.0 r0

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Дополнительная информация

cor-el
  • Top 10 Contributor
  • Moderator
17768 решений 160708 ответов
Размещено

Выбранное решение

Did you try other Density settings via customize mode?

Were you using code in userChrome.css to modify the height of the Tab bar ?

Did you try other Density settings via customize mode? *https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars Were you using code in userChrome.css to modify the height of the Tab bar ?
Помогла ли вам это? 1
Цитата

Задавший вопрос

cor-el said

Did you try other Density settings via customize mode? Were you using code in userChrome.css to modify the height of the Tab bar ?

When I opened customize mode, the density option showed that "compact" was chosen already. Just from frustration I clicked "compact" again anyway. Then, unexpectedly, the tabs shrank -- they became shorter. Possibly the upgrade to 70 did not carry over the setting or keep it in effect. The tabs still intrude into the window frame, but leave about half of the frame uncovered. This is much better visually, and I can live with it, but if you have a CSS suggestion that would shrink the whole tab bar so it did not enter the window frame I would welcome it.

''cor-el [[#answer-1260173|said]]'' <blockquote> Did you try other Density settings via customize mode? *https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars Were you using code in userChrome.css to modify the height of the Tab bar ? </blockquote> When I opened customize mode, the density option showed that "compact" was chosen already. Just from frustration I clicked "compact" again anyway. Then, unexpectedly, the tabs shrank -- they became shorter. Possibly the upgrade to 70 did not carry over the setting or keep it in effect. The tabs still intrude into the window frame, but leave about half of the frame uncovered. This is much better visually, and I can live with it, but if you have a CSS suggestion that would shrink the whole tab bar so it did not enter the window frame I would welcome it.

Изменено OneMoreName

Помогла ли вам это?
Цитата
cor-el
  • Top 10 Contributor
  • Moderator
17768 решений 160708 ответов
Размещено

There is a Drag Space setting in customize mode to make it possible to drag the Window instead of dragging the tabs around. This works differently with the title bar and menu bar hidden (i.e. tab are drawn in the title bar).

There is a Drag Space setting in customize mode to make it possible to drag the Window instead of dragging the tabs around. This works differently with the title bar and menu bar hidden (i.e. tab are drawn in the title bar).
Помогла ли вам это?
Цитата

Задавший вопрос

I have found a CSS element that is going to work.

  1. TabsToolbar .tabbrowser-tab { margin-top: 8px !important; )

The "8px" will be tuned up in a while -- just verifying that it has an effect.

Thanks.

I have found a CSS element that is going to work. #TabsToolbar .tabbrowser-tab { margin-top: 8px !important; ) The "8px" will be tuned up in a while -- just verifying that it has an effect. Thanks.
Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.