X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Adobe flash not recognized as being installed

Размещено

I'm running Manjaro linux XFCE 64bit. I have the latest version of Firefox installed from the Manjaro repositories (69.0.3-1). The flashplugin is also installed from the Manjaro repositories and is the latest version (32.0.0.270-1). In my plugin settings, Flash is set to ask to activate, and I've even tried turning off the "Block dangerous and intrusive Flash content" setting. Most websites that need Flash don't recognize that it is installed at all.

When I use Adobe's tools to check if Flash is installed, (https://helpx.adobe.com/flash-player.html) this page doesn't show the ask to activate plugin in the URL bar until after I click on "Check Now" so their tool shows that I do not have Flash installed or enabled. If I click allow Flash on this page and then refresh the page, it seems like Flash gets disabled for that website again, and clicking "Check Now" once again shows that Flash is not installed or enabled.

Another page to check if it is installed is (https://get.adobe.com/flashplayer/about/) which I found from downloading the flash plugin directly from Adobe in a readme.txt file. This page shows the Ask to activate directly on the Flash content, and when I click Allow, it recognizes that I have version 32.0.0.270 installed.

Most websites with Flash content that I want to use just don't show the Ask to activate prompt and show that I need to install Flash with the link to download from Adobe. I've tried uninstalling Flash and reinstalling, then rebooting my computer but that didn't help. This seems to be a reoccuring problem for me on linux, not just with Manjaro, but also Ubuntu, and even with other web browsers based on Chromium, like Brave browser. Does anyone know what causes this or how I can get Flash working on some pages?

I'm running Manjaro linux XFCE 64bit. I have the latest version of Firefox installed from the Manjaro repositories (69.0.3-1). The flashplugin is also installed from the Manjaro repositories and is the latest version (32.0.0.270-1). In my plugin settings, Flash is set to ask to activate, and I've even tried turning off the "Block dangerous and intrusive Flash content" setting. Most websites that need Flash don't recognize that it is installed at all. When I use Adobe's tools to check if Flash is installed, (https://helpx.adobe.com/flash-player.html) this page doesn't show the ask to activate plugin in the URL bar until after I click on "Check Now" so their tool shows that I do not have Flash installed or enabled. If I click allow Flash on this page and then refresh the page, it seems like Flash gets disabled for that website again, and clicking "Check Now" once again shows that Flash is not installed or enabled. Another page to check if it is installed is (https://get.adobe.com/flashplayer/about/) which I found from downloading the flash plugin directly from Adobe in a readme.txt file. This page shows the Ask to activate directly on the Flash content, and when I click Allow, it recognizes that I have version 32.0.0.270 installed. Most websites with Flash content that I want to use just don't show the Ask to activate prompt and show that I need to install Flash with the link to download from Adobe. I've tried uninstalling Flash and reinstalling, then rebooting my computer but that didn't help. This seems to be a reoccuring problem for me on linux, not just with Manjaro, but also Ubuntu, and even with other web browsers based on Chromium, like Brave browser. Does anyone know what causes this or how I can get Flash working on some pages?
Цитата

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Дополнительная информация

Размещено

Задавший вопрос

Quick update. I installed Google Chrome and after enabling Flash the page I was trying worked. In Brave browser and Firefox, enabling still does not work. It makes me think maybe there is another security/privacy setting that is on by default in Firefox and/or Brave that Chrome does not have on by default which also affects Flash.

Quick update. I installed Google Chrome and after enabling Flash the page I was trying worked. In Brave browser and Firefox, enabling still does not work. It makes me think maybe there is another security/privacy setting that is on by default in Firefox and/or Brave that Chrome does not have on by default which also affects Flash.
Помогла ли вам это?
Цитата
FredMcD
  • Top 10 Contributor
4261 решений 59653 ответов
Размещено

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow. ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and Left-click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager. ''' Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins. ''' Make sure the ones you want to use are set to '''Ask''' or '''Allow. ''' ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and '''Left-click''' the icon. Select '''Permissions. ''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow. '''
Помогла ли вам это? 0
Цитата
Размещено

Задавший вопрос

> In my plugin settings, Flash is set to ask to activate

I already specified that Flash was set to ask to activate in my original post. I also don't see anything under permissions for the site where I can set Flash to be allowed. When I click the icon, then select permissions, the only options are Location, Camera, Microphone, Notifications, and Autoplay.

> In my plugin settings, Flash is set to ask to activate I already specified that Flash was set to ask to activate in my original post. I also don't see anything under permissions for the site where I can set Flash to be allowed. When I click the icon, then select permissions, the only options are Location, Camera, Microphone, Notifications, and Autoplay.
Помогла ли вам это?
Цитата
cor-el
  • Top 10 Contributor
  • Moderator
17540 решений 158595 ответов
Размещено

Are there frames used on pages where you do not see the Lego block icon on the location bar ?

If content is loaded in an iframe then you may not get a request to activate Flash.

Are there frames used on pages where you do not see the Lego block icon on the location bar ? If content is loaded in an iframe then you may not get a request to activate Flash.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Yes, in particular this happens for a spend tracking tool on one of my credit card accounts, otherwise I would just point you right to it, but this does seem to happen frequently to me with Firefox on linux. It was the same with Ubuntu as I remember, and I haven't gotten Brave browser to be able to work either, but I have gotten chrome to work. It makes me think that it has something to do with a security setting.

I do keep the privacy and security settings fairly tight typically, but nothing that I need to make tweaks in about:config for, just what can be handled from the preferences menu. Also I have content blocking set back to standard right now and that doesn't seem to be working either.

I'm also using ublock origin, privacy badger, https everywhere, and decentraleyes in terms of privacy and security addons, but I've tried disabling all of them at once and reloading and it still doesn't work.

Is there a log file I can find or print out to see what may be happening?

Yes, in particular this happens for a spend tracking tool on one of my credit card accounts, otherwise I would just point you right to it, but this does seem to happen frequently to me with Firefox on linux. It was the same with Ubuntu as I remember, and I haven't gotten Brave browser to be able to work either, but I have gotten chrome to work. It makes me think that it has something to do with a security setting. I do keep the privacy and security settings fairly tight typically, but nothing that I need to make tweaks in about:config for, just what can be handled from the preferences menu. Also I have content blocking set back to standard right now and that doesn't seem to be working either. I'm also using ublock origin, privacy badger, https everywhere, and decentraleyes in terms of privacy and security addons, but I've tried disabling all of them at once and reloading and it still doesn't work. Is there a log file I can find or print out to see what may be happening?
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

I did try looking at the source html for the page this happens on, and searching through for the string "iframe" and came up with nothing, but I'm not a web developer and I only ever learned a small bit of html over 10 years ago, so I'm not totally sure what I'm doing and if I'm searching in the right place. I'll see if I can find another page where I can reproduce this which anyone can access.

I did try looking at the source html for the page this happens on, and searching through for the string "iframe" and came up with nothing, but I'm not a web developer and I only ever learned a small bit of html over 10 years ago, so I'm not totally sure what I'm doing and if I'm searching in the right place. I'll see if I can find another page where I can reproduce this which anyone can access.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

https://www.whatismybrowser.com/detect/is-flash-installed

That page doesn't show me a plugin block to click to allow anywhere. This image I included is a screenshot of that page, including the URL bar which doesn't show the plugin icon. They do recognize that I have javascript enabled though from this link.

https://www.whatismybrowser.com/detect/is-javascript-enabled

https://www.whatismybrowser.com/detect/is-flash-installed That page doesn't show me a plugin block to click to allow anywhere. This image I included is a screenshot of that page, including the URL bar which doesn't show the plugin icon. They do recognize that I have javascript enabled though from this link. https://www.whatismybrowser.com/detect/is-javascript-enabled
Помогла ли вам это?
Цитата
cor-el
  • Top 10 Contributor
  • Moderator
17540 решений 158595 ответов
Размещено

That website uses navigator.plugins["Shockwave Flash"]; to detect the Shockwave Flash plugin and doesn't create a Flash object, so you won't see the Lego block icon on the Navigation Toolbar.

That website uses <b>navigator.plugins["Shockwave Flash"];</b> to detect the Shockwave Flash plugin and doesn't create a Flash object, so you won't see the Lego block icon on the Navigation Toolbar.
Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.