X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Automatically delete junk settings not deleting old emails

Размещено

For awhile now I've been unable to get the "Automatically delete junk mail older than X days" function to operate properly in my account settings. I currently have it set to 14 days, but junk emails older than 14 days don't delete.

I've tried going through Junk > Properties > Retention Policy to set the limit there, but the result is the same. The junk emails that are older than the set time limit don't delete.

I've tried quitting and reopening the program, but that doesn't help.

I've tried reinstalling the program, but that only seems to help for awhile before this function stops working again.

Occasionally (I don't know why), I'll find that those junk emails with dates older than the set limits will delete themselves, but this doesn't happen very often. In fact, I can't remember the last time it deleted them.

Suggestions?

For awhile now I've been unable to get the "Automatically delete junk mail older than X days" function to operate properly in my account settings. I currently have it set to 14 days, but junk emails older than 14 days don't delete. I've tried going through Junk > Properties > Retention Policy to set the limit there, but the result is the same. The junk emails that are older than the set time limit don't delete. I've tried quitting and reopening the program, but that doesn't help. I've tried reinstalling the program, but that only seems to help for awhile before this function stops working again. Occasionally (I don't know why), I'll find that those junk emails with dates older than the set limits will delete themselves, but this doesn't happen very often. In fact, I can't remember the last time it deleted them. Suggestions?
Цитата

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36

Дополнительная информация

Размещено

Задавший вопрос

By the way, I'm using version 60.9.0

By the way, I'm using version 60.9.0
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1794 решений 12081 ответов
Размещено

Check to see if there is anything weird going on due to minor corruption. When did you last compact that folder?

  • Right click on Junk folder and select 'Compact'.

This will completely remove old hidden deleted emails and reduce the file size.

Check to see if there is anything weird going on due to minor corruption. When did you last compact that folder? * Right click on Junk folder and select 'Compact'. This will completely remove old hidden deleted emails and reduce the file size.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Yes, I tried that too. It didn’t help.

Yes, I tried that too. It didn’t help.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

The truly bizarre part is that my default settings are to delete after 15 days, but it appears now to be deleting after 30 days!

I have added two screen shots showing the settings.

The truly bizarre part is that my default settings are to delete after 15 days, but it appears now to be deleting after 30 days! I have added two screen shots showing the settings.
Помогла ли вам это?
Цитата
Matt
  • Top 10 Contributor
  • Moderator
3277 решений 22611 ответов
Размещено

is the account IMAP or POP? If IMAP, what is the retention policy for junk mail on the server? (30 days perhaps?)

is the account IMAP or POP? If IMAP, what is the retention policy for junk mail on the server? (30 days perhaps?)
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Yes, it's IMAP, but the server does not have a retention policy for junk mail. It's a cPanel server, and cPanel has no such auto-deletion feature built into it.

Yes, it's IMAP, but the server does not have a retention policy for junk mail. It's a cPanel server, and cPanel has no such auto-deletion feature built into it.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Also, even if there was such a policy, how would a 30 day policy on the server prevent Thunderbird from deleting emails in junk folder after 14 days?

By the way, the "30 day" thing has already fallen apart, because a day later the gap is now 31 days. So 30 days was a coincidence.

Also, even if there was such a policy, how would a 30 day policy on the server prevent Thunderbird from deleting emails in junk folder after 14 days? By the way, the "30 day" thing has already fallen apart, because a day later the gap is now 31 days. So 30 days was a coincidence.
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1794 решений 12081 ответов
Размещено

There is something not quite right about this. You are using an Imap mail account. Your images show that you have a 'Junk' folder and a 'Spam' folder. 'Junk' is usually a folder created by Thunderbird for POP mail accounts and 'Spam' is usually the server folder for all spam/junk mail. So it is a bit more unusual to see both. Did you manually create both of those folders or ... I located some info via cpanel webmail info that might explain things. When you create a new email account, the Dovecot mail server creates a Junk mailbox by default. When you access that new email account via the Roundcube webmail application, Roundcube will create a separate, additional bulk spam mailbox. This behavior causes the Roundcube webmail interface to display a Junk mailbox and a spam mailbox.

So I'm wondering if there is some confusion about what is recognised as the junk folder. Sometimes Imap accounts seem to work better if you select the 'Other' option and then choose the folder on imap account.

In Thunderbird 'Account Settings' > 'Junk Settings' for imap account.

  • Select 'Move new junk messages to'
  • Select 'Other' and choose the 'Junk folder on imap mail account'
  • select 'Automatically delete junk mail older than 14 days.'
  • click on 'OK'
  • Restart Thunderbird to ensure it uses new settings.
There is something not quite right about this. You are using an Imap mail account. Your images show that you have a 'Junk' folder and a 'Spam' folder. 'Junk' is usually a folder created by Thunderbird for POP mail accounts and 'Spam' is usually the server folder for all spam/junk mail. So it is a bit more unusual to see both. Did you manually create both of those folders or ... I located some info via cpanel webmail info that might explain things. ''When you create a new email account, the Dovecot mail server creates a Junk mailbox by default. When you access that new email account via the Roundcube webmail application, Roundcube will create a separate, additional bulk spam mailbox. This behavior causes the Roundcube webmail interface to display a Junk mailbox and a spam mailbox. '' So I'm wondering if there is some confusion about what is recognised as the junk folder. Sometimes Imap accounts seem to work better if you select the 'Other' option and then choose the folder on imap account. In Thunderbird 'Account Settings' > 'Junk Settings' for imap account. * Select 'Move new junk messages to' * '''Select 'Other' and choose the 'Junk folder on imap mail account'''' * select 'Automatically delete junk mail older than 14 days.' * click on 'OK' * Restart Thunderbird to ensure it uses new settings.
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1794 решений 12081 ответов
Размещено

If previous comment doesn't kick start the auto into working correctly, set the Retention Policy on the Junk directly.

  • right click on 'Junk' folder and select 'Properties'
  • select 'Retention Policy' tab
  • uncheck 'Use my account settings'
  • Select 'Delete mesasges more than 14 days old'
  • click on OK
If previous comment doesn't kick start the auto into working correctly, set the Retention Policy on the Junk directly. * right click on 'Junk' folder and select 'Properties' * select 'Retention Policy' tab * uncheck 'Use my account settings' * Select 'Delete mesasges more than 14 days old' * click on OK
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

That didn't work previously (see original post), but I'll try it again.

I've also emptied the junk folder, in case there was something in there corrupting it. So I'll have to wait another 14 days to see if the problem recurs.

That didn't work previously (see original post), but I'll try it again. I've also emptied the junk folder, in case there was something in there corrupting it. So I'll have to wait another 14 days to see if the problem recurs.
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1794 решений 12081 ответов
Размещено

Make sure you change the Junk Settings to use: Select 'Other' and choose the 'Junk folder on imap mail account'

Make sure you change the Junk Settings to use: Select 'Other' and choose the 'Junk folder on imap mail account'
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Yes. That's the way it's set already.

Yes. That's the way it's set already.
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1794 решений 12081 ответов
Размещено

If you have already made those changes then that's ok. My comments were based on the images you supplied which do Not show you using those settings.

If you have already made those changes then that's ok. My comments were based on the images you supplied which do Not show you using those settings.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Well, I did set the junk settings to 14 days, both in the account junk settings and in the properties for the junk folder. Today on October 31st there are still junk emails in the folder dating back to October 7th, 24 days ago.

Well, I did set the junk settings to 14 days, both in the account junk settings and in the properties for the junk folder. Today on October 31st there are still junk emails in the folder dating back to October 7th, 24 days ago.
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1794 решений 12081 ответов
Размещено

You and I are not on the same page: I asked you to Make sure you change the Junk Settings to use: Select 'Other' and choose the 'Junk folder on imap mail account'

Your answer to this was: Well, I did set the junk settings to 14 days,

The answer has nothing to do with the question.

please post image showing what you have got currently setup.

You and I are not on the same page: I asked you to Make sure you change the Junk Settings to use: '''Select 'Other' and choose the 'Junk folder on imap mail account'''' Your answer to this was: ''Well, I did set the junk settings to 14 days, '' The answer has nothing to do with the question. please post image showing what you have got currently setup.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Are these what you're looking for?

Are these what you're looking for?
Помогла ли вам это?
Цитата
Matt
  • Top 10 Contributor
  • Moderator
3277 решений 22611 ответов
Размещено

just a suggestion. in the folder pane where you set the retention, in the general information tab, have you selected the folder to be checked when Thunderbird get mail for the account. It might be the message aging stuff only executes when the folder is actually processed in the get messages process.

just a suggestion. in the folder pane where you set the retention, in the general information tab, have you selected the folder to be checked when Thunderbird get mail for the account. It might be the message aging stuff only executes when the folder is actually processed in the get messages process.
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

Interesting thought. It was unchecked, so I just checked it. I tried closing and opening Thunderbird a couple of times, but so far the old junk mails haven't disappeared. Still, I'll leave it set that way to see if it helps.

Interesting thought. It was unchecked, so I just checked it. I tried closing and opening Thunderbird a couple of times, but so far the old junk mails haven't disappeared. Still, I'll leave it set that way to see if it helps.
Помогла ли вам это?
Цитата
Toad-Hall
  • Top 10 Contributor
1794 решений 12081 ответов
Размещено

Right click on Inbox and select 'Compact'

In Account Settings > 'Server Settings' How frequently do you check for new mail? Is 'Clean up (Expunge) Inbox on exit' selected ?

In Account Settings > 'Synchronisation & storage' Is this selected: 'Keep messages in all folders for this account...' ? Click on 'Advanced' Is 'Junk' folder selected ?

Right click on Inbox and select 'Compact' In Account Settings > 'Server Settings' How frequently do you check for new mail? Is 'Clean up (Expunge) Inbox on exit' selected ? In Account Settings > 'Synchronisation & storage' Is this selected: 'Keep messages in all folders for this account...' ? Click on 'Advanced' Is 'Junk' folder selected ?
Помогла ли вам это?
Цитата
Размещено

Задавший вопрос

>> Right click on Inbox and select 'Compact'

I already ran the Compact function previously, but I did it again just now to be sure.

>> In Account Settings > 'Server Settings' How frequently do you check for new mail

It was set for every 10 minutes

>> Is 'Clean up (Expunge) Inbox on exit' selected ?

No, it wasn't. I checked it just now.

>> In Account Settings > 'Synchronisation & storage' Is this selected: 'Keep messages in all folders for this account...' ?

Yes

>> Click on 'Advanced' Is 'Junk' folder selected ?

No, it wasn't. I've checked it.

I restarted Thunderbird after making these changes, but the old emails in the Junk folder are still there.

>> Right click on Inbox and select 'Compact' I already ran the Compact function previously, but I did it again just now to be sure. >> In Account Settings > 'Server Settings' How frequently do you check for new mail It was set for every 10 minutes >> Is 'Clean up (Expunge) Inbox on exit' selected ? No, it wasn't. I checked it just now. >> In Account Settings > 'Synchronisation & storage' Is this selected: 'Keep messages in all folders for this account...' ? Yes >> Click on 'Advanced' Is 'Junk' folder selected ? No, it wasn't. I've checked it. I restarted Thunderbird after making these changes, but the old emails in the Junk folder are still there.
Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.