Поиск в Поддержке

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I get rid of the icons that have appeared in the bookmarks toolbar with the latest Firefox update (69.0)?

  • 15 ответов
  • 2 имеют эту проблему
  • 396 просмотров
  • Последний ответ от cor-el

more options

The question says it all, I think: the unwanted (and visually irritating) icons have nudged several items off my visible toolbar.

Выбранное решение

Hi mail93, line 3 has the reference to "browser.xul" that cor-el was talking about. This limits where the rule is applied. Now that the file named has changed to "browser.xhtml" the rule doesn't do anything. So you need to edit the .xul to .xhtml to make the rule work in Firefox 69. Or you could simplify your file to just line 4 and get rid of the rest.

Прочитайте этот ответ в контексте 👍 1

Все ответы (15)

more options

Hello , The Bookmarks toolbar is hidden by default.

To turn it on or back off : Click the menu button and choose Customize…. Click the Toolbars button at the bottom of the screen. Click Bookmarks Toolbar to select it. To turn off the toolbar, remove the check mark next to it.

And you can reorder the items that you want to appear or hide by dragging it to and from the toolbar.

Hope this helps.

Изменено Ruba

more options

Thanks for your suggestion, but this gets rid of the toolbar altogether, whereas I want the toolbar but with just text (abbreviations) in it, not icons too.

more options

Try this:

/* hide icons for bookmark folders */

  1. personal-bookmarks .bookmark-item:[container="true"] .toolbarbutton-icon {
display:none!important;

}

I don't know if this will work for your current version but I found the suggestion in another Support question here:

https://support.mozilla.org/en-US/questions/1226362

There's also another topic where this is addressed here, which involves an addon:

https://support.mozilla.org/en-US/questions/1001200

more options

Thanks for the suggestion. I think that code (or something like it) for the userChrome.css file was what I used successfully with an earlier version of FIrefox, but it doesn't seem to work for the latest one. And nor does the Classic Theme Restorer, which doesn't seem to have been updated for a while.

more options

If you use a @-moz-document url() block in your code then you probably need to modify it.

@-moz-document url(chrome://browser/content/browser.xul) =>
@-moz-document url(chrome://browser/content/browser.xhtml)
more options

Thanks, but this is stretching the limits of my competence (zero) with userChrome.css doctoring. Could you tell me exactly what you think should go in the userChrome.css file in its entirety? Thanks again in anticipation.

more options

Hi mail93, could you share your entire userChrome.css file for review? You can paste it on the following site anonymously (no account required) and share the URL of your paste page back here. There's a selector below the box where you paste to indicate it is CSS. That makes it a bit easier to read:

https://pastebin.com/

more options

Hi, my userChrome.css file is at https://pastebin.com/1zt8hb9z. As far as I recall, I got this from a Mozilla support forum in November 2017, and it worked fine until Firefox 69.0 came along. Thanks in advance for anything that will effectively replace it.

more options

Выбранное решение

Hi mail93, line 3 has the reference to "browser.xul" that cor-el was talking about. This limits where the rule is applied. Now that the file named has changed to "browser.xhtml" the rule doesn't do anything. So you need to edit the .xul to .xhtml to make the rule work in Firefox 69. Or you could simplify your file to just line 4 and get rid of the rest.

more options

Yes! – it works (as I'm sure you knew it would). Thanks so much; I'm very grateful.

For the benefit of anyone else with this issue, the userChrome.css file that has done the trick is

  1. personal-bookmarks .bookmark-item:not([container]) .toolbarbutton-icon { display: none !important; }
more options

personal-bookmarks .bookmark-item:not([container]) .toolbarbutton-icon { display: none !important; }

I'm trying to get rid of my toolbar icons too. Above code in my mac pro Catalina, Firefox ver 70, laptop10/Library/Mozilla/chrome/userChrome (using TextEdit, to save, bounce Firefox back open, toolbar icons remain) - ugh. Help please?

I'm an IT installer and use single letters for my favs, past Firefox versions I've been able to eliminate the icons, I've attached an image, I've burnt hours on this, copied lots of code suggestions into userChrome w/o luck.

more options

Hi Jay0918OnFF, the forum has formatting code for lines that start with # or * so you need to Quote a reply to see the original text (and use special tricks to re-post it):

mail93 said

For the benefit of anyone else with this issue, the userChrome.css file that has done the trick is

#personal-bookmarks .bookmark-item:not([container]) .toolbarbutton-icon { display: none !important; }

If you make sure that you have a # before personal-bookmarks, does it work for you?

more options

Make sure that userChrome.css is in the chrome folder in the profile folder and that the file is a plain text file (i.e. not RTF formatting code) laptop10/Library/Mozilla/chrome/userChrome is quite likely not the correct location on Mac.

  • ~/Library/Application Support/Firefox/Profiles/<profile>/chrome/userChrome.css

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Изменено cor-el

more options

How can I get rid of "ByteFence AntiMalware" icon that shows up as I open Firefox page? It persistently asks me to buy the software.

Изменено Ahmed Helmi

more options

Did you try to uninstall this software via the Windows Control Panel ?