X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Opening Google page need to click on it to allow typing?

Размещено

If I just "go to google" (www.google.com) in Firefox (Quantum v68.0.2 64-bit) and start typing, nothing happens. I need to click in the "search box" in order for typing to show there. I checked this with both IE and Chrome, and going to to www.google.com I can start typing and I am "automatically" in the search box. What is the difference? How can I set FF to automatically wait for input when I go to www.google.com?

If I just "go to google" (www.google.com) in Firefox (Quantum v68.0.2 64-bit) and start typing, nothing happens. I need to click in the "search box" in order for typing to show there. I checked this with both IE and Chrome, and going to to www.google.com I can start typing and I am "automatically" in the search box. What is the difference? How can I set FF to automatically wait for input when I go to www.google.com?

Изменено C.W. Billow

Выбранное решение

When testing by disabling add-ons, I suggest disabling all the ones you can go without for 24 hours first to see whether the problem is in one of your core extensions or one of the less frequently used ones. You might find that it's in an extension you no longer need.

Прочитайте этот ответ в контексте 0
Цитата

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Дополнительная информация

jscher2000
  • Top 10 Contributor
8637 решений 70654 ответов
Размещено

Where does the text go, if anywhere?

What if you reload the page (Ctrl+r) -- does the cursor move into the search box automatically?

Any difference if you follow a link instead of using the address bar? https://www.google.com/

Google uses a script to move the cursor into the search box when the page loads. If that isn't working on yours, that script might be blocked from running for some reason, or there might be a conflicting script running.

Note: the New Tab Page is a special case because instead of putting the cursor in the page, it puts it in the address bar. But it doesn't sound as though you are having this problem due to changing your New Tab Page to Google.

Where does the text go, if anywhere? What if you reload the page (Ctrl+r) -- does the cursor move into the search box automatically? Any difference if you follow a link instead of using the address bar? https://www.google.com/ Google uses a script to move the cursor into the search box when the page loads. If that isn't working on yours, that script might be blocked from running for some reason, or there might be a conflicting script running. Note: the New Tab Page is a special case because instead of putting the cursor in the page, it puts it in the address bar. But it doesn't sound as though you are having this problem due to changing your New Tab Page to Google.
Помогла ли вам это?
Цитата

Задавший вопрос

Clicking the (your) link above gave me no difference, As to where the typing goes, I have no idea. Where it does NOT go is into the search box!

Clicking the (your) link above gave me no difference, As to where the typing goes, I have no idea. Where it does NOT go is into the search box!
Помогла ли вам это?
Цитата

Задавший вопрос

I just cycled through my browsers (IE, Chrome, Edge (Both chromium-based and "old" Edge), and Firefox Quantum. All the others, when going to https://www.google.com/, give me the blinking cursor in the search box. Firefox's cursor blinks once when the page first loads, but then disappears.

I thought that there might be some conflict with something I am running (several), but: As noted above it doesn't happen on any other browser, and, I didn't notice it until recently, in the last month or so.

I just cycled through my browsers (IE, Chrome, Edge (Both chromium-based and "old" Edge), and Firefox Quantum. All the others, when going to https://www.google.com/, give me the blinking cursor in the search box. Firefox's cursor blinks once when the page first loads, but then disappears. I thought that there might be some conflict with something I am running (several), but: As noted above it doesn't happen on any other browser, and, I didn't notice it until recently, in the last month or so.
Помогла ли вам это?
Цитата
jscher2000
  • Top 10 Contributor
8637 решений 70654 ответов
Размещено

Well, you don't need to check other browsers, it definitely works in Firefox for most people or the forum would be flooded with complaints.

Google constantly performs user interface experiments on its users, so that is a possibility, although this would be a weird thing to change.

Do you use any add-ons that could affect scripts in pages?


If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon (or i-in-a-circle) at the left end of the address bar and, after a pause, "Clear Cookies and Site Data" should appear at the bottom. Click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Well, you don't need to check other browsers, it definitely works in Firefox for most people or the forum would be flooded with complaints. Google constantly performs user interface experiments on its users, so that is a possibility, although this would be a weird thing to change. Do you use any add-ons that could affect scripts in pages? ---- If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon (or i-in-a-circle) at the left end of the address bar and, after a pause, "Clear Cookies and Site Data" should appear at the bottom. Click that. In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Помогла ли вам это?
Цитата
jscher2000
  • Top 10 Contributor
8637 решений 70654 ответов
Размещено

C.W. Billow said

Firefox's cursor blinks once when the page first loads, but then disappears.

Now that I read that again: what could be taking the cursor out of the box or away from the window?

Is the window switching from active to inactive?

The main sign is that the title bar becomes faded but this can be extremely subtle depending on your theme. To test whether the window is still active, you can call up the control menu by pressing

Alt + Spacebar

If the upper left corner menu does not come up on the window with the Google tab, then the window is losing focus.

If the menu DOES come up on the window with the Google tab, this is not the issue.

''C.W. Billow [[#answer-1246652|said]]'' <blockquote> Firefox's cursor blinks once when the page first loads, but then disappears. </blockquote> Now that I read that again: what could be taking the cursor out of the box or away from the window? '''Is the window switching from active to inactive?''' The main sign is that the title bar becomes faded but this can be extremely subtle depending on your theme. To test whether the window is still active, you can call up the control menu by pressing Alt + Spacebar If the upper left corner menu does not come up on the window with the Google tab, then the window is losing focus. If the menu DOES come up on the window with the Google tab, this is not the issue.
Помогла ли вам это?
Цитата

Задавший вопрос

Jefferson;

Firefox is not losing focus (per Alt+Spacebar) because the menu does show.

Starting in safe mode however DOES seem to mitigate the issue.

That's good news on the one hand, but that means now I have to disable the add-ons one at a time to figure out which one it is :-(.

Sigh...

Jefferson; Firefox is not losing focus (per Alt+Spacebar) because the menu does show. Starting in safe mode however DOES seem to mitigate the issue. That's good news on the one hand, but that means now I have to disable the add-ons one at a time to figure out which one it is :-(. Sigh...
Помогла ли вам это?
Цитата
jscher2000
  • Top 10 Contributor
8637 решений 70654 ответов
Размещено

Выбранное решение

When testing by disabling add-ons, I suggest disabling all the ones you can go without for 24 hours first to see whether the problem is in one of your core extensions or one of the less frequently used ones. You might find that it's in an extension you no longer need.

When testing by disabling add-ons, I suggest disabling all the ones you can go without for 24 hours first to see whether the problem is in one of your core extensions or one of the less frequently used ones. You might find that it's in an extension you no longer need.
Помогла ли вам это?
Цитата

Полезный ответ

Jefferson, I found it.

It was/is the ProWritingAid extension (https://prowritingaid.com/).

Click it off, and the cursor shows on Google. Click it on, and the issue returns,

I'll be reporting that to their developers.

Regards, Chuck

Jefferson, I found it. It was/is the ProWritingAid extension (https://prowritingaid.com/). Click it off, and the cursor shows on Google. Click it on, and the issue returns, I'll be reporting that to their developers. Regards, Chuck
Помогла ли вам это? 1
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.