Поиск в Поддержке

Избегайте мошенников, выдающих себя за службу поддержки. Мы никогда не попросим вас позвонить, отправить текстовое сообщение или поделиться личной информацией. Сообщайте о подозрительной активности, используя функцию «Пожаловаться».

Learn More

adblockplus is still disabled in my firefox v52.9.0 browser, on my Windows XP computer. How can I reactivate?

  • 25 ответов
  • 2 имеют эту проблему
  • 59 просмотров
  • Последний ответ от cor-el

more options

Hi Jscher2000,

My issue (https://support.mozilla.org/en-US/questions/1258165?page=1) was closed before I could respond! So, I am following up here.... (and I could post this follow up there -if you want to re-open that thread, for continuity of the issue?)


I tried your solution to update the certificate, but it did not work.

Note, I could not figure out where to check the certificate was updated (as you posted in the screen capture of image #2).

The first step seemed to work (clicking on your link and clicking OK on the popup to download the certificate).

The RESET of the lastupdate value also seemed to work, and after restarting Firefox it now shows VALUE of 1557118303.

But the adblcok plus stll not working.

Note, I tried to download the certificate using step 1 again, and that time an ALERT said CERTIFACATE ALREADY INSTALLED...

What can I do now?


FYI: Your instruction in the OTHER THREAD was:

Hi Matt, I was able to start testing in Firefox 52 ESR. When I install the hotfix extension, nothing happens, other than showing up on the Extensions panel of the Add-ons page. In the Browser Console, I see this message: TypeError: browser.experiments is undefined That means the main command of the extension doesn't run, so it's a dead end.

Next idea:


(1) Install the certificate the hotfix would have installed (2) Trigger Firefox to re-verify your extensions (3) Wait until it is back to normal


(1) Install certificate

I extracted the certificate from my Firefox 66 and saved it on my webserver. Obviously if you don't trust me, you should not install it.

Two possible methods: click to download through the certificate installer, or right-click > Save Link As to save a local copy and then import it.


Screenshot #1 shows the download method. Don't check any of the boxes, just click OK.

To import instead:

Go to the Options/Preferences page, Advanced section, Certificates panel, then click Certificate Manager. Make sure the Authorities tab is selected, then click Import. Find the file you downloaded and open it, then you should get the same dialog as in Screenshot #1, don't check any of the boxes, just click OK. Then you should see the new cert in the list in the Certificate Manager, as shown in Screenshot #2.

(2) Clear the time Firefox last re-verified

This will set Firefox up to check much sooner than it otherwise would check.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste xpi- and pause while the list is filtered

(C) Right-click the app.update.lastUpdateTime.xpi-signature-verification preference and click Reset on the context menu

Screenshot #3 illustrates the expected result.

(3) Restart Firefox

You can exit Firefox normally, then start it up again. In my tests, it took less than 60 seconds for Firefox to verify my extensions. Screenshot #4 is "before" and Screenshot #5 is "after."

Hopefully that will work for you.

Все ответы (5)

more options

Seeing this prompt to install extensions happened because extensions.json was removed. This causes Firefox to ask for permission for extensions found in the extensions folder.

If you have Firefox 66.0.4 then you do not need the hotfix and you can check the about:config page for extensions.signer.hotfixed = true to confirm you have the certificate.

more options

mnalep said

The only thing still disabled in my about:addons / extensions is the Microsoft .NET Framework Assistant could not be verified for use in Firefox and has been disabled. I'm not sure what I need that for? It says under that message that it "Adds ClickOnce support and the abilty to report installed .NET versions" How do I get that back, assuming I really need it?

I wouldn't bother. I don't think it worked in Firefox in recent years.

more options

Jscher2000, I thought I had seen it disabled earlier, but I was not sure. Thanks for verifying.

Also, thanks for your help.

Now, is there any chance I would lose Adblock Plus again?

If so, do I need to get that certificate, and then delete the extensions.json file again?

more options


I have Firefox 66.0.3 and I checked the about:config page for extensions.signer.hotfixed = true - I don't have that value, but Adblock Plus is working on that computer, so I must have the correct certificate.

Thanks for your help. I appreciate it.

more options

Firefox 66.0.3 uses a shield study (Normandy; hotfix extension) to 'inject' the intermediate certificate and sets a normandy pref. Firefox 66.0.4 has the certificate builtin, but saves it in the Certificate Manager and sets extensions.signer.hotfixed = true. Firefox 66.0.5 has the certificate hard coded builtin and doesn't store it in the Certificate Manager and doesn't set any prefs as well.

  1. 1
  2. 2