X
Нажмите здесь, чтобы перейти на мобильную версию сайта.

Форум поддержки

Help! My emails incoming and outgoing emails have question marks in the sentences. I'm on 60.6.1 (32 bit) Windows 10

Размещено

Help Please, My incoming and outgoing emails have questions marks in the sentences. I'm on Thunderbird 60.6.1(32-bit) Windox10 and my provider is Verizon. This happened before and I fixed it by changing the encoding. Now this does not seem to work.

This is what I'm getting: After seeing the news about 9-year-old??Riley Morrison ??sending?? Stephen a letter about ???NOT??? having girls sneakers in his product line , I said, ???I can do that too???!

Help Please

Help Please, My incoming and outgoing emails have questions marks in the sentences. I'm on Thunderbird 60.6.1(32-bit) Windox10 and my provider is Verizon. This happened before and I fixed it by changing the encoding. Now this does not seem to work. This is what I'm getting: After seeing the news about 9-year-old??Riley Morrison ??sending?? Stephen a letter about ???NOT??? having girls sneakers in his product line , I said, ???I can do that too???! Help Please

Выбранное решение

The following answer is posted elsewhere in the Mozilla Support Forum:

Go to the Thunderbird Configuration Editor ( Tools, Options, Advanced, General, Config Editor). Scroll down to mail.strictly_mime Click on it to change it from False to TRUE.

This fixed the problem for several others on the forum, and also fixed it for me.

P.S. my provider is also Verizon.

Прочитайте этот ответ в контексте 1
Цитата

Дополнительные сведения о системе

Приложение

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36

Дополнительная информация

sfhowes
  • Top 10 Contributor
1509 решений 7140 ответов
Размещено

It's an issue with anyone who sends through an ATT/Rogers/AOL/Yahoo smtp server, i.e. Yahoo-brand mail (including Verizon).

https://support.mozilla.org/en-US/questions/1257326

It's an issue with anyone who sends through an ATT/Rogers/AOL/Yahoo smtp server, i.e. Yahoo-brand mail (including Verizon). https://support.mozilla.org/en-US/questions/1257326
Помогла ли вам это? 0
Цитата

Задавший вопрос

Hi, Yikes!! Note, I created the email via a word doc and cut and pasted it into my email!

Can you please tell me how to fix it? What should my encode setting be etc.?

HELP LMS

Hi, Yikes!! Note, I created the email via a word doc and cut and pasted it into my email! Can you please tell me how to fix it? What should my encode setting be etc.? HELP LMS
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1509 решений 7140 ответов
Размещено

When you paste content from Word or any other app, use Paste Without Formatting (Ctrl+Shift+V). This is separate from the issue of Yahoo-type sending accounts inserting question marks for spaces.

When you paste content from Word or any other app, use Paste Without Formatting (Ctrl+Shift+V). This is separate from the issue of Yahoo-type sending accounts inserting question marks for spaces.
Помогла ли вам это?
Цитата

Задавший вопрос

Hi Again, I just forwarded an email to myself and it had ?? in the body

This is really not good - what should my settings be UTF8 for incoming & outging

Hi Again, I just forwarded an email to myself and it had ?? in the body This is really not good - what should my settings be UTF8 for incoming & outging
Помогла ли вам это?
Цитата

Задавший вопрос

Hi Again, This didn't not work

When you paste content from Word or any other app, use Paste Without Formatting (Ctrl+Shift+V). This is separate from the issue of Yahoo-type sending accounts inserting question marks for spaces. SEE BELOW

After seeing the news about 9-year-old Riley Morrison?? sending Stephen a letter about ???NOT??? having girls sneakers in his product line , I said, ???I can do that too???! Hence, I posted my ???patented???

Hi Again, This didn't not work When you paste content from Word or any other app, use Paste Without Formatting (Ctrl+Shift+V). This is separate from the issue of Yahoo-type sending accounts inserting question marks for spaces. SEE BELOW After seeing the news about 9-year-old Riley Morrison?? sending Stephen a letter about ???NOT??? having girls sneakers in his product line , I said, ???I can do that too???! Hence, I posted my ???patented???
Помогла ли вам это?
Цитата
HokieFan 1 решений 1 ответов
Размещено

Выбранное решение

The following answer is posted elsewhere in the Mozilla Support Forum:

Go to the Thunderbird Configuration Editor ( Tools, Options, Advanced, General, Config Editor). Scroll down to mail.strictly_mime Click on it to change it from False to TRUE.

This fixed the problem for several others on the forum, and also fixed it for me.

P.S. my provider is also Verizon.

The following answer is posted elsewhere in the Mozilla Support Forum: Go to the Thunderbird Configuration Editor ( Tools, Options, Advanced, General, Config Editor). Scroll down to mail.strictly_mime Click on it to change it from False to TRUE. This fixed the problem for several others on the forum, and also fixed it for me. P.S. my provider is also Verizon.

Изменено HokieFan

Помогла ли вам это? 1
Цитата

Задавший вопрос

Thanks so much.... my problem is fixed!

Verizon is a "HOT MESS" at times...

Do you know what caused the problem? Lori

Thanks so much.... my problem is fixed! Verizon is a "HOT MESS" at times... Do you know what caused the problem? Lori
Помогла ли вам это?
Цитата
pfw51 0 решений 11 ответов
Размещено

I have an att.net email and I've had the same problem for about a month now. I've been trying to do your fix to get to the Configuration Editor (Tools, Options, Advanced, General, Config Editor) but the menu does not work in that order. I do Tools > Options, but there is no "advanced" link anywhere except next to "Language and Appearance", and when I click on that there is nothing helpful. I did a search for "config editor" and it turns up nothing. My version is 67.0.2 64 bit.

I have an att.net email and I've had the same problem for about a month now. I've been trying to do your fix to get to the Configuration Editor (Tools, Options, Advanced, General, Config Editor) but the menu does not work in that order. I do Tools > Options, but there is no "advanced" link anywhere except next to "Language and Appearance", and when I click on that there is nothing helpful. I did a search for "config editor" and it turns up nothing. My version is 67.0.2 64 bit.
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1509 решений 7140 ответов
Размещено

pfw51 said

I have an att.net email and I've had the same problem for about a month now. I've been trying to do your fix to get to the Configuration Editor (Tools, Options, Advanced, General, Config Editor) but the menu does not work in that order. I do Tools > Options, but there is no "advanced" link anywhere except next to "Language and Appearance", and when I click on that there is nothing helpful. I did a search for "config editor" and it turns up nothing. My version is 67.0.2 64 bit.

Version 67.0.2 is the latest Firefox. Open Tools/Options... in Thunderbird.

''pfw51 [[#answer-1230053|said]]'' <blockquote> I have an att.net email and I've had the same problem for about a month now. I've been trying to do your fix to get to the Configuration Editor (Tools, Options, Advanced, General, Config Editor) but the menu does not work in that order. I do Tools > Options, but there is no "advanced" link anywhere except next to "Language and Appearance", and when I click on that there is nothing helpful. I did a search for "config editor" and it turns up nothing. My version is 67.0.2 64 bit. </blockquote> Version 67.0.2 is the latest Firefox. Open Tools/Options... in Thunderbird.
Помогла ли вам это?
Цитата
pfw51 0 решений 11 ответов
Размещено

Thanks... I figured it out. Found a tech blog from another site that had the answer.

Thanks... I figured it out. Found a tech blog from another site that had the answer.
Помогла ли вам это? 0
Цитата
MarkVictor 0 решений 23 ответов
Размещено

I use [for now] Thunderbird ver. 60.7.2 (32-bit). I'm sure an update is soon to come (right after Windows 10 update).

I am still getting the question marks... but not from all incoming email. In Config Editor, changing mail.strictly_mime to TRUE did not eliminate the question marks. I have set it back to FALSE.

Next step will be to go through the listed encodings (Tools -> Options -> Display -> Formatting -> Fonts & Colors: Advanced) and see which works best, testing each with strictly_mime: FALSE and strictly_mime: TRUE.

  • Mail replies from my father (who uses TBird) contains the question marks. I'm assuming that the two of us need to use the same encoding for incoming and outgoing to get rid of that... right?
  • Gmail from one friend replying to me shows my original message exactly as I sent it.
  • Mail replies from GoDaddy are like Gmail — original messages have no question marks and are in the original font.
  • How does Outlook fare?? Not sure I know anyone who uses it...
  • I will keep an eye out for when other web-based email replace two spaces , em-dashes —, and other special characters with ??.

Lots of variables... and isn't there a config setting for AutoDetectTextEncoding or equivalent? Don't have time to check right now... but may be a crucial setting if I'm doing testing, eh?!

I must say that Verizon's servers did not pose this problem; the combination of Verizon migrating to AOL's servers and me updating to later versions of TBird seem to be the problem. But I can't prove that correlation for sure. Let's see what happens when two TBird users coordinate encoding for in and out... if my father can do that...

Way too many variables... chacun a son gout!

I use [for now] Thunderbird ver. 60.7.2 (32-bit). I'm sure an update is soon to come (right after Windows 10 update). I am still getting the question marks... but not from all incoming email. In Config Editor, changing mail.strictly_mime to '''TRUE''' did not eliminate the question marks. I have set it back to '''FALSE'''. Next step will be to go through the listed encodings (Tools -> Options -> Display -> Formatting -> Fonts & Colors: Advanced) and see which works best, testing each with strictly_mime: FALSE and strictly_mime: TRUE. * Mail replies from my father (who uses TBird) contains the question marks. I'm assuming that the two of us need to use the same encoding for incoming and outgoing to get rid of that... right? * Gmail from one friend replying to me shows my original message ''exactly'' as I sent it. * Mail replies from GoDaddy are like Gmail — original messages have no question marks and are in the original font. * How does Outlook fare?? Not sure I know anyone who uses it... * I will keep an eye out for when other web-based email replace two spaces , em-dashes —, and other special characters with ??. Lots of variables... and isn't there a config setting for AutoDetectTextEncoding or equivalent? Don't have time to check right now... but may be a crucial setting if I'm doing testing, eh?! I must say that Verizon's servers did not pose this problem; the '''combination''' of Verizon migrating to AOL's servers and me updating to later versions of TBird seem to be the problem. But I can't prove that correlation for sure. Let's see what happens when two TBird users coordinate encoding for in and out... if my father can do that... '''''Way''''' too many variables... chacun a son gout!

Изменено MarkVictor

Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1509 решений 7140 ответов
Размещено

Полезный ответ

MarkVictor said

I use [for now] Thunderbird ver. 60.7.2 (32-bit). I'm sure an update is soon to come (right after Windows 10 update).

If you see question marks in your received mail, changing the preference has no effect, even if your account is Yahoo-type. It's the sender who uses TB who has to change the preference if they send through a Yahoo-type smtp server.

''MarkVictor [[#answer-1234823|said]]'' <blockquote> I use [for now] Thunderbird ver. 60.7.2 (32-bit). I'm sure an update is soon to come (right after Windows 10 update). </blockquote> If you see question marks in your received mail, changing the preference has no effect, even if your account is Yahoo-type. It's the ''sender'' who uses TB who has to change the preference if they send through a Yahoo-type smtp server.
Помогла ли вам это? 1
Цитата
MarkVictor 0 решений 23 ответов
Размещено

Thank you, sfhowes, for your reply. You verified for me — and I hope for others including moderators of this forum — that at this moment there is no solution for this problem of replacement of double spaces and extended characters with question marks. This problem is not solved, and currently cannot be completely solved by the common user of TBird, only mitigated.

Considering your reply (thank you!), it seems that Thunderbird developers may not be able to create code for their product that solves this problem.

There are industry standards that either are not being followed or don't exist.

Is my analysis above correct? If so, this problem should not be marked "Solved". This is quite annoying for me, an end-user.

However, I do appreciate all who have replied with proposed solutions. Let's keep working on it.

Thank you, sfhowes, for your reply. You verified for me — and I hope for others including moderators of this forum — that at this moment there is '''no solution''' for this problem of replacement of double spaces and extended characters with question marks. This problem is '''not solved''', and currently cannot be completely solved by the common user of TBird, only mitigated. Considering your reply (thank you!), it seems that Thunderbird developers may not be able to create code for their product that solves this problem. There are industry standards that either are not being followed or don't exist. Is my analysis above correct? If so, this problem should not be marked "Solved". This is quite annoying for me, an end-user. However, I do appreciate all who have replied with proposed solutions. Let's keep working on it.
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1509 решений 7140 ответов
Размещено

The problem is solved as far as TB users sending through Yahoo servers no longer getting complaints from recipients about question marks replacing spaces and special characters. Since it only happens with Yahoo servers, it is more than likely a configuration issue with their system, so we can't expect TB to add code that's needed for a single mail provider.

The problem is solved as far as TB users sending through Yahoo servers no longer getting complaints from recipients about question marks replacing spaces and special characters. Since it only happens with Yahoo servers, it is more than likely a configuration issue with their system, so we can't expect TB to add code that's needed for a single mail provider.
Помогла ли вам это?
Цитата
MarkVictor 0 решений 23 ответов
Размещено

Are we absolutely sure that this is a consistent problem with only Yahoo servers? Case in point:

Just got an email with copious ??????, strewn throughout my original below the line, through GoDaddy from a sender whose previous emails did not present that issue.

Of course, Internet routing could pass an email through a Yahoo server before it gets to the intended recipient(s)... am I right?

Note these observations:

  • The problem is not solved, especially as regards replies to the original sender who uses TBird.
  • Although inconsistent and ostensibly associated only(?) with Yahoo servers, it still needs a solution.
  • The problem is also one that has appeared only since the beginning of this year, certainly in my email client (TBird).
  • The problem is also probably not one that either you or I can solve. It can only be solved at or near the top of corporate structures by Mozilla and Yahoo and AOL and Verizon...

Do you know if Mozilla has taken any action as regards fixing internet email protocols so that this problem disappears for good? Do you know how I can get the messages contained in my string to Mozilla's top ITs or administrators? I suppose I shouldn't expect Mozilla to bust a... well... to focus significant resources to a problem that someone else has caused, but they sure can give voice to the many of us who are experiencing various, often high levels of annoyance (me? very annoyed!). And as far as not getting complaints, many email users give up after awhile. I'm not going to let this go — quite yet.

Thank you for your responses. Although not solving this problem, our conversation has been helpful in analyzing an obstinate issue — and I hope someone at Mozilla is reading.

Mark Victor

Are we absolutely sure that this is a consistent problem with only Yahoo servers? Case in point: Just got an email with copious ??????, strewn throughout my original below the line, through GoDaddy from a sender whose previous emails did not present that issue. Of course, Internet routing could pass an email through a Yahoo server before it gets to the intended recipient(s)... am I right? Note these observations: * The problem is '''not''' solved, especially as regards replies to the original sender who uses TBird. * Although inconsistent and ostensibly associated only(?) with Yahoo servers, it still needs a solution. * The problem is also one that has appeared '''only''' since the beginning of '''this''' year, certainly in my email client (TBird). * The problem is also probably not one that either you or I can solve. It can only be solved at or near the top of corporate structures by Mozilla and Yahoo and AOL and Verizon... Do you know if Mozilla has taken any action as regards fixing internet email protocols so that this problem disappears for good? Do you know how I can get the messages contained in my string to Mozilla's top ITs or administrators? I suppose I shouldn't expect Mozilla to bust a... well... to focus significant resources to a problem that someone else has caused, but they sure can give voice to the many of us who are experiencing various, often high levels of annoyance (me? '''''very''''' annoyed!). And as far as not getting complaints, many email users give up after awhile. I'm not going to let this go — quite yet. Thank you for your responses. Although not solving this problem, our conversation has been helpful in analyzing an obstinate issue — and I hope someone at Mozilla is reading. Mark Victor
Помогла ли вам это?
Цитата
sfhowes
  • Top 10 Contributor
1509 решений 7140 ответов
Размещено

Полезный ответ

I suggest you follow this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1435903
Помогла ли вам это? 1
Цитата
MarkVictor 0 решений 23 ответов
Размещено

All I have to say is WTF!! OMG!! Oy veh! etc. etc. etc.

The entire string confirms my worst thoughts about Yahoo etc. — incompetency well-personified.

My recent experience w/ ?? continues, regardless of .strictly_mime setting, and I send/receive in UTF–8. I'll follow up in Bugzilla to make sure some attention to this continues, even though TBird staff have worked to find a solution only to be thwarted by Yahoo & Co. I'll also see if my long-term relationship with Verizon gains me some access to higher-level ITs. This relatively sophisticated computer user is not giving up!

This is quite the frustrating story for all, Many thanks for your help and comments.

Mark Victor

All I have to say is WTF!! OMG!! Oy veh! etc. etc. etc. The entire string confirms my worst thoughts about Yahoo etc. — incompetency well-personified. My recent experience w/ ?? continues, regardless of .strictly_mime setting, and I send/receive in UTF–8. I'll follow up in Bugzilla to make sure some attention to this continues, even though TBird staff have worked to find a solution only to be thwarted by Yahoo & Co. I'll also see if my long-term relationship with Verizon gains me some access to higher-level ITs. This relatively sophisticated computer user is not giving up! This is quite the frustrating story for all, Many thanks for your help and comments. Mark Victor
Помогла ли вам это?
Цитата
Задать вопрос

Для ответа на сообщения вы должны войти в свою учётную запись. Пожалуйста, задайте новый вопрос, если у вас ещё нет учётной записи.